Nyame Ephraim

Hi, my HSC counts accumulated pulses but destination register does not count

9 posts in this topic

Hi, my HSC counts accumulated pulses but destination register does not count !

will appreciate any contribution to help resolve this issue 

thanks 

HSC Issues.pdf

Share this post


Link to post
Share on other sites

Posted (edited)

I assume you see values in the accumulators while running.

Are these rungs in subroutines? Are the subroutines being called?

Are the contacts before the MOV instructions true?

Are there any other instructions which write to the destinations?

If you are testing by forcing the outputs their associated contacts won't follow the forced state.

Edited by b_carlton

Share this post


Link to post
Share on other sites

Hi b_carlton thanks for the contribution you have made, when i configured HSC:0.ACC, it was working very well and counting in the destination register L9:0, but when i configured the other HSC, for example, when i connected my square wave simulator input in IN 4 which reads HSC:1, I noticed only the HSC was accumulating, but the destination register was not counting. 

i connected the pulse input back to IN0, that is HSC:0 Only the accumulator was reading and the register L9:0 was not reading any longer. 

just  thought of something, could it be that the battery am using to power my square wave generator is low ? and as such the pulses it generate now are weaker to work with the PLC scantime ?

 

 

Share this post


Link to post
Share on other sites

Posted (edited)

If the HSC accumulates then the battery is not the problem. The hookups for counting would not affect the transfer of the accumulator's values in the MOV commands. If you print your program to a PDF and post it (or send a PM to me for my email) I can look at it. Meanwhile check the other items I proposed.

And just for the heck of it, make sure the PLC is in 'Run'. Since the HSC is a hardware device within the CPU I can't remember if it can accumulate in other modes.

Edited by b_carlton

Share this post


Link to post
Share on other sites

Hello, I noticed something, I configured the two counters in the same program but different ladders, the first counter and it register counters well.

the second counter only the Accumulator counts the destination register does not count. 

Please will appreciate any contribution to resolve this suituation 

thanks 

image.jpeg

Share this post


Link to post
Share on other sites

The MicroLogix operating system only automatically executes Ladder 2.

All of your other Ladder routines must be called with a Jump to Subroutine (JSR) instruction from Ladder 2, or executed by a system interrupt.

Share this post


Link to post
Share on other sites

Ken - Nyame Ephraim has been in touch with me via email. After many exchanges I came to the conclusion that he believed the Program File Number (PFN) in the HSC setup indicated the ladder in which all HSC related instructions must be placed. My last email to him was this morning and I haven't heard anything else. From all his descriptions to me I believe this may be the case. I guess I'll just wait to see if my guess was confirmed.

Share this post


Link to post
Share on other sites

Hi experts thank you people for the wonderful contributions you made. The program works well now 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now