Milosh

Etn021 ip address change problem

9 posts in this topic

Posted (edited)

I have cts-etn021 module, and I change ip address via i/o tabe unit setup, and also set rotary switch to last segment of ip address. Let say ip address is 192.168.106.147 and rotary switch is set to 93. Now when I want to change ip address, from i/o unit table setup, and click on Transfer pc to unit, error is displayed *Transfer failed 11 mode and download failed*

What is the best way to change the ip address of this module?!

Ps. Tried in program/stop mode and also via toolbus, and ethernet.

Edited by Milosh

Share this post


Link to post
Share on other sites

Posted (edited)

When you change the IP address, you will lose connection because you are configured to connect with the previous module address.

Are you sure that it did not change to the new address? Try connecting again with the new address.

Alternatively, try connecting via serial port or USB then change the IP address. (You didn't mention the PLC model)

Edited by IO_Rack

Share this post


Link to post
Share on other sites

Posted (edited)

I tried with serial cable toolbus, cs1h-h cpu64h. First time I success to change, but second time I tried I can't change.

I tried cpu power off, etn21 reset, but it always displays message Transfer failed.

 

I also tried with Transfer to PLC option, and check IO Table and Special Unit Setup. Special Unit Setup always fails.

 

Edited by Milosh

Share this post


Link to post
Share on other sites

Did someone try to change IP address via web interface or via DM area?!

Share this post


Link to post
Share on other sites

is it possible that you changed the unit number, along with the node number?

Share this post


Link to post
Share on other sites

No, I didn't change node number.

I will try to change ip address via DM or web interface when I go to site next week. But, I wish to know if someone have the similar experience...

Share this post


Link to post
Share on other sites

Just a guess, but seeing a "Mode 11" message appears, try to double check your IO Table.

Did it say CS1W-ETN21(ETN11 Mode) or CS1W-ETN21(ETN21 Mode)?
There might be a chance that your ETN21 was set up in ETN11 Mode, but now you are accessing it in ETN21 Mode, or vice versa.

In any case, in the IO Table, you can click on the ETN21 unit, then click "Options --> Change ETN21 Mode" to choose the mode suitable for your needs.

1 person likes this

Share this post


Link to post
Share on other sites
8 hours ago, innoaloe said:

Just a guess, but seeing a "Mode 11" message appears, try to double check your IO Table.

Did it say CS1W-ETN21(ETN11 Mode) or CS1W-ETN21(ETN21 Mode)?
There might be a chance that your ETN21 was set up in ETN11 Mode, but now you are accessing it in ETN21 Mode, or vice versa.

In any case, in the IO Table, you can click on the ETN21 unit, then click "Options --> Change ETN21 Mode" to choose the mode suitable for your needs.

It is in etn21 mode for sure.

I will try it on site, next week.

Share this post


Link to post
Share on other sites

Today I have success. I tried to change only last segment of IP address via DM registers without success. But after that I open web page of the module with IP address set before xxx.xxx.xxx.xxx/0 and login with ETHERNET, under Settings->System tab, I changed only last segment of IP address xxx.xxx.xxx.yyy than click on button Set, than Regist and reset the PLC. after that everithing eas ok.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now