Sign in to follow this  
Followers 0
SolidRio

FX5U and Encoder project

6 posts in this topic

Hello everyone. I need to share my thoughts with someone.

I already have 2 project that’s includes machines like flying saws (that moving with production line and cut) and I faced some problems. Maybe someone will share their experience.

1 project:

Production line that creates sandwich panels. At the end of line staying flying saw which moving by servo. As a distance meter was 1000 HTL push pull encoder with 300 mm circle that moving on sandwich panel.

I used FX5U plc. Connected channel A and B on X0 and X1. Made High speed I/O Ch1 with 2 phase 1 multiple. We put 2 1,5k Ohm on both X0 and X1. Encoder cable shield was grounded.

Program was like pulses*ratio=distance. Distance =>Setpoint -> Cut.

And then started something random. Every start of line error between setpoint and real distance of panel was different. In one start there was error like 2-3 mm. After a day maybe, when they start line different start to be like 10mm or another. They had to increase setpoint every time.

We checked everything encoder circle, its rotating on panel, all mechanicals things. Nothing helps. We decided that cause was the temperature in room. In place where encoder stayed sandwich panel was right after heating process and metal decreases in length right after saw cut it.

So we put encoder on motor shaft which pull material. So now we have something like 250 pulses on 1 mm of production (before was 3.33333) and dont depend on real material. And that’s helped. Error was stable 1-2 mm.

 

2 project:

Production line that creates plastic pipes.

Flying saw at end of line. Encoder 1250, circle 500 mm.

FX5U, X0 and X1. 2 phase 1 multiple. Resistance and ground.

Program same.

At the start was multiple random difference errors like 20-30 mm. Accidentally we noticed that our resistance (0,25 watt) were really hot. We cut them. And all started to work properly, but… Difference between setpoint and real pipe length was something 70mm. So they want 9,72 meter pipe and for that need 9,79 setpoint. Error was stable and they seems ok with that. But on another day when we left city – they started another orded with thicker pipe and to get 9,72 pipe they need to put 9,82 setpoint. They still ok with that, but I am not.

Maybe I something missing, but encoder that rolling on material is just don’t work with me. How to make precise cutting in this type of projects? Speed synchronization between line and saw is ok, cause cut is clean and on different speeds – same error. Guys, help me.

Share this post


Link to post
Share on other sites

Posted (edited)

There's no simple answear for your problem.

I had a similar task few yers ago. No luck with FX5 main unit only.

I ended up adding FX5-40SSC-S module and end all my problems.

Check the solution example below. It's IQ-R series simle motion module, but FX5-40/80SSC-S module have the same functions, but up to 4 or 8 Axis.

 

https://www.google.com/url?sa=t&source=web&rct=j&url=http://dl.mitsubishielectric.co.jp/dl/fa/document/catalog/servo/l03135/l03135a.pdf&ved=2ahUKEwjPpYrT5O_hAhVs2aYKHTc7CcIQFjAAegQIAxAB&usg=AOvVaw0DFtX3_A9VPK6frXK6qJ-L

Удачи братан! :)

Edited by glavanov
1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

On 27.04.2019 at 1:48 PM, glavanov said:

Brand and model of the servos?

Different servos being used. First one was Delta servo, second Lenzo.

On 27.04.2019 at 2:09 PM, glavanov said:

There's no simple answear for your problem.

I had a similar task few yers ago. No luck with FX5 main unit only.

I ended up adding FX5-40SSC-S module and end all my problems.

Check the solution example below. It's IQ-R series simle motion module, but FX5-40/80SSC-S module have the same functions, but up to 4 or 8 Axis.

Why it cant be done with only main unit and ? Cause of low speed of high speed inputs? Or program scan time? Or wrong count? I just dont get it. 

I dont know how to implement that module with this servos. And still you must put encoder signals to fx5u main unit, isnt? We dont have problem with servo control, because we change line speed and error still same. So it seems problem with encoder.

I am not working with servos and encoders at all (cause working in mining industry), but its second project on side with encoder and i feel really dumb. 

In first project moving encoder on motor (more pulse on mm of production) helped fix error to 1-2 mm (and thats ok), so it seems possible with cpu itself, but i wanna do it with encoder wheel on production (2,5 pulse on mm of production).

On 27.04.2019 at 2:09 PM, glavanov said:

Удачи братан! :)

;-)

Edited by SolidRio

Share this post


Link to post
Share on other sites

Posted (edited)

I'm not saying it's inpossible to do it with main unit, but i quit trying.

Main unit positioning instructions are ment to be used for simple positioning tasks.

When you use pulse trian to control servos you don't actually have feedback to the PLC what the amp is doing.

You can count only on good servo tuning and wire some amp outputs to PLC  for example "in position" signal to vrify that servo is done with positioning and redy for next instructio.

Yes, the scan time delay is factor.

When you need synchronisation of servo with another Axis or encoder you need special function unit that can hadle encoder, high speed inputs for positioning or synchronisation start and delay compensation parameters that can be set depanding on your mechanical/servo system, mark detection function also.

FX5-40/80SSC-S have it all, but yes it can work only with JE/J3/J4-B series amps with SSCNETIII/H optical interface. It's not cheap solution but is dedicated exactly for aplications like yours and it's maybe the most cost efective solution out there when you can use it with JE_B series amps.

It have differential/incremental encoder/MPG inputs, high speed/mark detection inputs.

It have synchronous control and Cam function, also cam auto generation function.

All the Axis data like current feed value, command feed vlaue, or encoder counter value right there in the buffer memory redy to be used in sequence orogram or monitored.

 

 

Edited by glavanov
1 person likes this

Share this post


Link to post
Share on other sites
17 hours ago, glavanov said:

I'm not saying it's inpossible to do it with main unit, but i quit trying.

Main unit positioning instructions are ment to be used for simple positioning tasks.

When you use pulse trian to control servos you don't actually have feedback to the PLC what the amp is doing.

You can count only on good servo tuning and wire some amp outputs to PLC  for example "in position" signal to vrify that servo is done with positioning and redy for next instructio.

Yes, the scan time delay is factor.

When you need synchronisation of servo with another Axis or encoder you need special function unit that can hadle encoder, high speed inputs for positioning or synchronisation start and delay compensation parameters that can be set depanding on your mechanical/servo system, mark detection function also.

FX5-40/80SSC-S have it all, but yes it can work only with JE/J3/J4-B series amps with SSCNETIII/H optical interface. It's not cheap solution but is dedicated exactly for aplications like yours and it's maybe the most cost efective solution out there when you can use it with JE_B series amps.

It have differential/incremental encoder/MPG inputs, high speed/mark detection inputs.

It have synchronous control and Cam function, also cam auto generation function.

All the Axis data like current feed value, command feed vlaue, or encoder counter value right there in the buffer memory redy to be used in sequence orogram or monitored.

 

 

Your post made me think all evening after work. I got it. And it seems moving encoder on motors shaft in first project helps in that way - more pulses on 1mm of production - scan time delay affects less on error, cause if i wrong count 250-500 pulses, its only 1-2mm, but if i use the wheel - 250-500 pulses - its already 75-150mm. 

Next time i will fill mitsu servos, amps and that module into that type of project. And make this sh*t work without error in distance.

Really thank you for your effort in this question. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0