Sign in to follow this  
Followers 0
NeilG

SoftLogix and RSLinx Connection Issue

2 posts in this topic

I am trying to setup communications between RSlinx and Softlogix on Windows 7 PC.

I open SoftLogix and configure a CPU and Ethernet module. I then cannot open RSLinx GUI since RSLinx is already running as a service. I stop the service, which automatically removes my CPU from SoftLogix but does allow me to open RSLinx GUI. However I cannot connect to the Softlogix now since it has no PLC. When I try and add a CPU I get a message that RSLogix must be run as a service. However in that situation I cannot open the GUI.

Share this post


Link to post
Share on other sites

Posted (edited)

I'm supposing that you're not able to open the GUI because the RSLinx icon doesn't show in the taskbar in Windows 7. I suggest to make a copy of the shortcut, edit it and add the command line: /service in the Target field.

It will look similar to: "C:\Program Files\Rockwell Software\RSLinx\RSLINX.EXE" /service

Save it

Use this new shortcut to launch RSLinx

Now the icon will show in the taskbar and you'll be able to open the GUI while running as service.

Hope this helps

Bye
 

Edited by chantecler

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0