Connecting CPM1 to KEPServerEX5

4 posts in this topic

Hello there,

I'm having a problem with connecting my Omron CPM1 PLC with KEPServerEX5.

The problem is that I can't find any drivers that support a serial connection with the CPM1. The only driver that comes close to what I'm looking for is the Omron FINS Serial driver, but that one only supports the following devices:


Even if i choose the CVM1 (that has simular TAG-addresses as the CPM1) I can't get any connection because it requires an ID with the following format (UU.AAA.NNN.) and I have no idea where to get this.

I also tried to using the U-CON (user-configurable) driver, but I can't figure out how to get this working.

I'm running a program in the CPM1 with a Input(00.01) , Output(10.01) and Timer(T000). I used the Transaction Editor to import these tags in KEPWare:


I checked the serial port settings and they are correct.

The only thing I'm not sure about is the device ID, but I tried 0 until 5 and I don't think it could be any higher than that.

I'm hoping any of you guys is experienced with making a serial connection to KEPWare and is able to help me with this problem.


Share this post

Link to post
Share on other sites

Check to see if there is a Host Link or Sysmac Way driver?

Other option would be to try the C200 version of the FINS Driver.

C200 would be pretty close to the CPM1.


Share this post

Link to post
Share on other sites

Thank you very much I tried the Host link driver with the C200 PLC and it worked.




Edited by IkBenNietHier

Share this post

Link to post
Share on other sites

Glad you got it to work.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now