hmwright

M340 NOE IO Scanning of DSE 8610 Gen Contyroller

6 posts in this topic

I am having issues with M340 IO scanning. I have the NOE card next to the CPU which is a 2020 item. I have set the Network for the CPU as 192.168.0.5 and the NOE card as 192.168.0.12. To the NOE card I have connected a Deep Sea Electronics 8610 MkII generator controller which has configurable modbus pages. Its IP is 192.168.0.3. I have set the IO scan tab of the NOE to read the device at 192.168.0.3 starting at remote address 442497 (Page 166 of the DSE, 166*256). for 80 registers and to store them in PLC at %MW300 onward. When compiled this read works perfectly with values being loaded. The problem comes when I try a second read from the same device. This time Page 167 (167*256) at address 442753 which is sent to local PLC %MW380 onward. Now when I compile the code the first page is read OK as prior but the second read shows a "Faulty/Absent" on teh IO scanner debug page and no values are read. If I change the first entry to scan page 167 with page 166 deleted, again all is OK. It seams I am unable to make more than one read of the DSE product. I have spoke with DSE whom state the device can have multi reads from multiple masters and they have proved multiple reads from the same and different devices. I am now at a loss as to what to try next. I hope somebody can provide some insight. I also tryed doing teh second read with a standard READ_VAR command with teh same result. Just wondering if its a NOE thing or a set up thing I have missed.

20180911_144113.jpg

Share this post


Link to post
Share on other sites

As a side note I have now tried not using the IO scanning tab and just setting up two READ_VAR calls. This works with no drama, therefor this must be related to the IO scanning set up tab and not any hardware or connections.

I hope we get an answer as I would prefer the IO scan way instead of writing to large arrays of varaiables

Share this post


Link to post
Share on other sites

can you show your setup in the io scanning when you read from the second area as well please

Share this post


Link to post
Share on other sites

Thanks cHud;

Please see set up for scanning two sets from the same device.

IO Scanning.jpg

Share this post


Link to post
Share on other sites

I tried to find the gen controller modbus manual but can only get in upon request. Can you attach it here. 

Just on thing i see. You said that the 1st read you want to start at 42497 and second on 42753 yet in your setup you start on 42496 and on 42753. There normally is a one bit offset with modbus. Just thinking maybe you are reading from the middle of a floating register or something on those lines....If i have the modbus manual of the controller it would make things clearer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now