Zubair  Ahmed

HMI and PLC Communication problem

18 posts in this topic

hi there. .. i am new to plc programming.. Right now i am having problem related to communication between hmi and plc..

i have HMI WEintek 6070ip and plc mitsubishi FX2n..

i have written a program in gx developer . and communicate it with EASY Builder for HMI. so for now plc is communicating with my program written for hmi on pc. but when i downlaod to hmi and connect plc cable to hmi then hmi shows no plc communication.

i am having a problem for communication between hmi and plc.

any help will be a life saver.

thanks in advance

Share this post


Link to post
Share on other sites

Wel, you should really take this up with your HMI supplier or in this case a Weintek forum.
The HMI supplier should supply the documentation for which driver he is using etc.

Further more how are you connected via the CPU or a board ?

 

1 person likes this

Share this post


Link to post
Share on other sites

What have you set for your serial communication board ? 
Maybe you can post a screencapture

 

Share this post


Link to post
Share on other sites

ok but you bare using an FX2N-232-BD  right. You have to set the setting for this. 

Check your PLC parameters

Share this post


Link to post
Share on other sites

You said you were using RS232 9 pins ????

If you have it connected to the FX CPU port that is RS422. So than your cable needs to convert 

Share this post


Link to post
Share on other sites

i am not getting it.. kindly tell me in detail for life saving... :(

Share this post


Link to post
Share on other sites

my laptop has com port 1... my cable is 9pin to plc connector .. when i connect easybuilder to hmi .. it connects and download the program.. same as when i connect plc to gx developer it connects and download the program.. also online simulation in easybuilder it shows plc data.. but when i connect hmi and plc to each other without plc.. then it shows no plc response.

 

Share this post


Link to post
Share on other sites

one more thing i have noticed that on HMI serial port db9 connector it has written over it( com 1 rs232 , com2 rs485)

 

while on plc port it has writter rs422... what is this means

Share this post


Link to post
Share on other sites

Then you are probably using an Sc09 (red) cable between GX Dev (PC) and FX. This cable converts from RS232 to RS422.

So if you are connected to the CPU port the settngs are correct 7 even 1 9600.

Has the RS232 port of the Weintek the same pin layout as a Standard serial port of a PC ?

I see that a Weintek Com 1 support 232 and 422. Has the right one been selected ?
If not try com 2 as that one only support RS232. (your cable already converts)

 

 

 

 

Edited by Gambit

Share this post


Link to post
Share on other sites

I don't mean that. I meant from the weintek. Is that set to 232 or 422. and what does each pin do ? SD RD SG etc

1 person likes this

Share this post


Link to post
Share on other sites

THANKS GAMBIT FOR all the help.. problem is solved . . as weintek is on rs232 while plc port is rs422.  sorry for your suffer.. and thanks for help...

Share this post


Link to post
Share on other sites

:-2

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now