Transistor

PrintActivePages(FALSE) scales text and graphics differently

4 posts in this topic

I have a legacy application with [PRINT] buttons on many of the screens. The screens are very simple with text and boxes as frames around the text. The [Print] button calls the CX-Supervisor script:

Quote

PrintActivePage(FALSE)

where FALSE suppresses the print dialog.

5b86ba7908f72_CX-supervisorframe.png.b23

Figure 1. One of eight of the temperature control boxes.

I have upgraded to CX-Supervisor 3.41 Developer and Runtime for a couple of modifications. Now when we print the text comes out OK but the graphics (the boxes) are about eight times the correct size and overlay the text. This happens when printing to the printer and to XPS.

5b880b8818555_CX-Supervisorscalingerror.

Figure 2. The eight temperature texts and the giant boxes on an A4 XPS file. (It's the same when printed directly to printer.)

Has anyone seen anything similar? Is there a fix?

Many thanks.

Edited by Transistor
Added Figure 2, etc.

Share this post


Link to post
Share on other sites

Hi T,

I have something similar. This looks like a defect (probably related to the new shaded and transparent drawing of objects added in 3.4) so I raised a ticket on myOMRON.com and indeed they confirmed it was already reported and the fix will be released shortly.  Hurray!

Regards,

BB

Share this post


Link to post
Share on other sites

I can confirm that. The next release is scheduled for October. You might be able to get a beta version from them with a fix.

Share this post


Link to post
Share on other sites

Hi 

I got a beta ver 341(3) and I also have isue printing.

Banker

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now