Sign in to follow this  
Followers 0
STTAndy

Mitsubishi GX Works Bugs??

1 post in this topic

Hello

I have been using GX Works 3 for a while now and I have discovered a couple of things, maybe bugs. I have not had any training for the software or hardware so maybe I did something wrong.

1 Labels.

If you sort a global label table into any order other than the unsorted order that appears by default you are unable to create, delete or edit any labels. Our Mitsubishi representative discovered that if you click on the column header between 'Data Type' and 'Class' the order does not change but now editing is available. This, it turns out is a really bad idea. It seems the position the label was in when it was created is preserved, I think this is the unsorted order you get by default. If you sort the list and then delete a label it is possible that the label that should be in that position is also deleted.

I have attached a small project to demonstrate this. Open the Global Labels notice the order they were created. Now change the sort order, click on the column header I described earlier to make them editable and then delete the label in position 1.

For a while I thought this was the only problem but recently there has been a number of instances where I have created a label, given it a carefully selected address only to discover that it is being overwritten by another variable. I have not been able to work out exactly what is going on but I believe it is connected to the sort order of the labels. Also if you sort the order and change an address, have you changed the address of another label? The only solution I have found is to keep label tables very short so they are managable without having to sort the order, that is probably good practice anyway

1 Axis software limits.

I have been using a number of axes in pairs, in incremental mode as caterpillar feeders, using FX5U-40SSC simple motion modules. I had a problem that the axis synchronised to follow would suddenly stop moving, the customer was having to power down the machine and start again. This problem persisted for months with Mitsubishi scratching their heads unable to fathom it out and ultimately stating that the problem must be in my code somewhere. It was suggested by the customer that it may be getting to a software limit, I showed the customer that the software limit was disabled in the setup and it was confirmed by Mitsubishi that it was not the problem. guess what, it is a problem.

Once the actual position reached the limit of the double word memory it would stop moving. The solution is the take the servos out of synchronisation in order to set the position (datum) to zero every cycle. Unfortunately the drives do not always re-synch on the first attempt so you have to keep trying till it does, this now causes slight variations in cycle times but it works.

Andy

 

 

Label Test.gx3

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0