11 posts in this topic

My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111

I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.

Share this post


Link to post
Share on other sites

Thanks for the insight but generally I already followed the whole thing. Already did it with the controller's given IP, but still no controller detected. Is something wrong with the way I connect things? Or am I not suppose to use a hub? :-1 Just the controller to the PLC then usb connect the NJ to the PC?...

Share this post


Link to post
Share on other sites

An IP address beginning with 169 is typically used when your computer is set for DHCP and was not assigned an IP address by a server properly.  Keep in mind IPCONFIG is going to show ALL of the IP addresses on your PC, and one is likely the wireless connection.

It sounds like your computer is not on the same subnet as the robot.

Share this post


Link to post
Share on other sites

Already turned off the Wifi, only lan card is active, and tried both 255.255.255.0 subnet and 255.255.0.0 subnet... Controller still can't be seen... 

Share this post


Link to post
Share on other sites
On 6/4/2018 at 4:48 PM, Dutdut said:

I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0,

Since you're having Sysmac I believe you're familiar with a tool called DirectEthernetUtility which comes with Sysmac installation.
If not you can find the said program in C:\Program Files (x86)\OMRON\Communications Middleware\DirectEthernetUtility.exe

This is a very handy tool from Omron which lets you connect to any Omron PLC through Ethernet without knowing it's IP Address (if connected directly with cable). However it causes a royal pain if you're trying to connect to other ethernet devices through your LAN Card (such as Adept robots) because this application generates a secondary Local IP Address starting with 169.xxx.xxx.xxx. All other applications using Ethernet might be affected as well.

Two suggestion from me:
1. Keep the DirectEthernetUtility as it is right now, and change Adept Robot IP Address to match the current 169.xxx.xxx.xxx IP and Subnet Mask using C:\Program Files (x86)\OMRON\Sysmac Studio\AdeptRobotIPAddressSettingTool, or better you can change it from ACE (yes, you can change it even without having a correct IP Subnet in your PC).

2. Open the DirectEthernetUtility, disable it, then set your PC LAN IP and Subnet to match Adept's current 172.xxx.xxx.xxx.

Share this post


Link to post
Share on other sites

Hi appreciate the reply, and apologies if I left that note.. I tried the DirectEthernetUtility and to note there is no problem with my connection to NJ, I can connect it just fine using USB, direct Ethernet and by switch hub. All works fine. My concern is e robot contoller, the display shows an IP of 172.16.132.111 so I set my PC IP settings to 172.16.132.10 for example with a subnet of 255.255.0.0 even ACE 'Connect To Controller' option, or using the AdeptRobotIPAddressSetting Tool, it cannot detect the robot controller. Displays nothing, triedd all connection ways by connecting the robot to NJ, by directly connecting the robot by Ethernet, or by using a hub and setting those address stated above. No IP of the robot displays. I have a eMB-60R controller with two ethernet ports. Strang thing is I tried pinging the robot IP address with a return reply, and ARP on prompt seeing that the IP can be seen by my PC with my settings but it seems SYSMAC or ACE cannot recognize the controller. Please help...

:-(

Share this post


Link to post
Share on other sites

Well, ping command is just sending ICMP packets so no TCP Connection is generated. That's why it will always work as long as the IP is there.
Have you tried using another computer to test the connection?
 

22 minutes ago, Dutdut said:

even ACE 'Connect To Controller' option

Try the IP Setup in ACE. There's should be a Magnifying Glass icon near the Connect To Controller option which will shows all connected controllers as long as the cable is connected. From there you can modify the controller IP and Subnet Mask too.

Share this post


Link to post
Share on other sites

Tried it in a desktop and laptop.. both with the same result... :-(.... 

 

Share this post


Link to post
Share on other sites

Posted (edited)

If so, the problem might lie with the Subnet Mask. Sometimes I find an eMB-60 using subnet mask of 255.255.255.0 eventhough the IP started with 172.xxx

Try changing your PC subnet mask to 255.255.255.0 instead. Cannot guarantee anything though...

Edited by innoaloe

Share this post


Link to post
Share on other sites

I really do apologize for having not detailed my steps, but I also tried that one though... :doh:.. Guess I'll just have to try on another PC though... :-1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now