Rolf_Inge

Convert project from Developer or not?

27 posts in this topic

Posted (edited)

Hello

I have an old test rig (hydraulic cylinder applies pressure to a crank in sawtooth pattern) project written in gx developer for the Q03 plc. To this plc is connected a 1041 beijer panel, I have uploaded the project to E-designer.

I am rewriting the sequence code because a new but similar test is prepared. Have a PID-block in gx works 2 (not in a simple project sadly) i would like to import  and use in gx developer. This is causing me some trouble though. 

Can anyone tell me how to get the PID-blocks from GX Works 2 to GX Developer? Do you recommend me to upgrade the project to GX Works 2 instead? How will the panel react? I need to reprogram this as well.

Cheers // Rolf

GX Developer.PNG

E-designer.PNG

Edited by Rolf_Inge

Share this post


Link to post
Share on other sites

Posted (edited)

GX Developer is not the same as GX IEC Developer.

I would upgrade the GX IEC Developer program  to GX Works 2.

The HMI panel should behave the same as it is only looking at devices D0 will be D0 in GX IEC as in GX Works 2.

 

Edited by Gambit

Share this post


Link to post
Share on other sites

Posted (edited)

7 hours ago, Gambit said:

GX Developer is not the same as GX IEC Developer.

I would upgrade the GX IEC Developer program  to GX Works 2.

The HMI panel should behave the same as it is only looking at devices D0 will be D0 in GX IEC as in GX Works 2.

 

Thanks for quick answer. Feels better to be back in gx works 2.

Though i cant seem to find where you set the option to download via usb. And since its been a year i cant find where to invert a pin. If im not wrong it was a quick keyboard command. Do you know? Google could not help.

Cheers

Edited by Rolf_Inge

Share this post


Link to post
Share on other sites

To answer your first question. just click on RS232 USB next to PC side i/f on the connection destination setup 

usb.JPG

Share this post


Link to post
Share on other sites

Posted (edited)

As for your second question. when you hold the Ctrl button your keyboard and double click (left mouse button) on the contact it should change to negative logic.. pulse up , pulse down etc

But if you double click (left mouse button) on the contact without the CTRL you should get a pop-up with a selection 

selection.JPG

 

If you want to invert the pin of a FB  left mouse button double click on the FB just before the pin.

 

Edited by Gambit
2 people like this

Share this post


Link to post
Share on other sites
On 2018-05-30 at 9:20 AM, Gambit said:

As for your second question. when you hold the Ctrl button your keyboard and double click (left mouse button) on the contact it should change to negative logic.. pulse up , pulse down etc

But if you double click (left mouse button) on the contact without the CTRL you should get a pop-up with a selection 

selection.JPG

 

If you want to invert the pin of a FB  left mouse button double click on the FB just before the pin.

 

Perfect. That was what i was looking for. Found the transfer menu down to left. Slowly i'm warming up to gx works 2 again. Quite nice environment.

One thing i am wondering though is why its such a hassle to "initialize" inputs and outputs. Does it need to be that hard? Writing some hex-number to a certain variable.

Thanks!

Share this post


Link to post
Share on other sites

What do you mean with inputs and outputs as Inputs are read from the hardware and Outputs can be set to hold their value at stop.

For all other devices you can use the inial value value file.

 

Share this post


Link to post
Share on other sites
34 minutes ago, Gambit said:

What do you mean with inputs and outputs as Inputs are read from the hardware and Outputs can be set to hold their value at stop.

For all other devices you can use the inial value value file.

 

I mean the setup for which channels to use for input and output. Writing hex values, moving and setting different X and Y.

I'm just used to adding the hardware, setting addresses and all is set.

GX Works AI.PNG

GX Works AO.PNG

Share this post


Link to post
Share on other sites

Posted (edited)

aha you mean setting up modules. I see...

If you use the special function utils. You do not have to do that.
Well you have to activate a bit for each channel when using an anlog output module but that is in there for control purposes.

This is also much better in GX Worsk 2 than in GX IEC Developer.

Select Intelligent function Modules. rigth mouse click and add module 

Edited by Gambit

Share this post


Link to post
Share on other sites
On 2018-06-01 at 9:10 AM, Gambit said:

aha you mean setting up modules. I see...

If you use the special function utils. You do not have to do that.
Well you have to activate a bit for each channel when using an anlog output module but that is in there for control purposes.

This is also much better in GX Worsk 2 than in GX IEC Developer.

Select Intelligent function Modules. rigth mouse click and add module 

Hi again

I added the two modules Q64ADV and Q64DAN. But I have 4 modules, the first 2 seem to be regular modules and cannot be added with the intelligent function module. Is that right?

Cheers

 

20180604_104212.jpg

Add Module.PNG

Add Module.PNG

Share this post


Link to post
Share on other sites

Correct. This is an input module (X) and an output module (Y).

These are not special modules just IO modulen.
The default settings for these can be changed in the PLc parameters => IO assigment =>Detailed settings if you want to change the the input filter for the input module for instance.
Default is 10ms

 

 

Share this post


Link to post
Share on other sites

Thanks for that. I am understanding it more now.

I have one remaining issue now. From mitsubishi I received 2 block, PID Control and PID Start. After implementing these i try simulate but come up with CPU ERROR. The error help is saying:

The instruction cannot process the contained data.
Access error of ATA card or SD memory card occurs by SP.FREAD/SP.FWRITE instructions.
A file being accessed by another function was accessed with SP.FWRITE instruction.

Have you seen this before?

Cheers

5b1537c1ebb32_GXWorksErrorMemorycard.thu

 

PID.PNG

Share this post


Link to post
Share on other sites

Well most likely de values you have set for the PID init are not correct.
I see the values for PID are only set when temp1 is pulsed. So they are 0 when PID is set So this is probably the problem.
They have to have a minumum value of 1.

So if you change the temp1 for SM402 (init pulse) your problem will be gone.

 

Share this post


Link to post
Share on other sites

Posted (edited)

On 2018-06-05 at 8:08 AM, Gambit said:

Well most likely de values you have set for the PID init are not correct.
I see the values for PID are only set when temp1 is pulsed. So they are 0 when PID is set So this is probably the problem.
They have to have a minumum value of 1.

So if you change the temp1 for SM402 (init pulse) your problem will be gone.

 

Thanks for tip. It was actually due to me placing the pid start and control blocks in the wrong order. Pid start is to be executed last. Now it works like a charm, until next error will surface :)

Parameters were also wrong like you said by the way. Pid control gave parameter error. Until correct values were put in. Was possible to simulate though. 

 

Edited by Rolf_Inge

Share this post


Link to post
Share on other sites

Hello again

Regarding switch settings. I think I understand it now.

One question though, i am trying to access input channel 7 by adressing it the same way as has been done earlier in the AI block. But when i change channel[5] to channel[7] the compiler states:

Quote

Program compile    The specified array element is out of range. The size of array subscript is too large.(Ladder Block No.8)    C1031

How is it done correctly? Any tip?

Cheers // RI

GX Works 2 switch setting.PNG

GX Works 2 switch setting manual.PNG

GX Works 2 AI Channel.PNG

Share this post


Link to post
Share on other sites

Just saw it now that Channel[] is a local label array. Question is then, could i just expand the array and be able to take in the other analog inputs / channels?

Cheers

AnalogIn.PNG

Share this post


Link to post
Share on other sites

Posted (edited)

ok first of all if you register the special modules in your GX Works 2 project than you can use the selections there to set the switch settings.

The channel[x] is just an Array so yes you can expand this. But there must be a FB where the analogs signals are read into the Array.

 

Edited by Gambit
1 person likes this

Share this post


Link to post
Share on other sites
1 hour ago, Gambit said:

ok first of all if you register the special modules in your GX Works 2 project than you can use the selections there to set the switch settings.

The channel[x] is just an Array so yes you can expand this. But there must be a FB where the analogs signals are read into the Array.

 

Okay, I did that.

Am i right in that i now do not need the networks 1-4 anymore? Can I now directly address the analog input channels to pass them on to scaling block?

Thanks for the help.

5b336d7eaa4d7_IntelligentFunctionModule.

IFm2.PNG

Share this post


Link to post
Share on other sites

Yes that is correct if you set the Refresh settings. For the analog output you will still need to set the output enable flag.

If you have any problems just right click the module => Register to intell function module monitor and you can see all the info direcly from the module.
Oh I see you have already done that now in your screen capture.

 

1 person likes this

Share this post


Link to post
Share on other sites

Posted (edited)

Thanks for info. Then i remove these networks. But how do I address an analog input directly? Like i did in picture 3?

Regarding analog out, I believe i have enabled it. Have attached the picture. Will remove the networks 4-8 for the output also then.

AO.PNG

AO-block.PNG

Auto-refresh.PNG

AO3.PNG

Edited by Rolf_Inge

Share this post


Link to post
Share on other sites

Posted (edited)

in the intell function modules you can det de devices you want to use in the refresh settings
SO this will setup the switch setting like in the IO assigment

1.JPG

2.JPG

In the refesh you can link the data to a device. Like below D0

3.JPG

Now all you do is create a Label with the same adres. (or an Array )

4.JPG

Edited by Gambit
1 person likes this

Share this post


Link to post
Share on other sites

Thank you. I tried it yesterday without adding a label but adressed D501 directly in the scaling block. Was not able to read any value from the analog inputs. Will create a label and try again. I will have no access to the equipment for a while though.

Cheers

Share this post


Link to post
Share on other sites

The scaling block does just that change the value. Did you set up D501 in the refresh settings?

Share this post


Link to post
Share on other sites
On 2018-06-28 at 4:14 PM, Gambit said:

The scaling block does just that change the value. Did you set up D501 in the refresh settings?

Hi

Back after vacation. Have tried downloading the software with IFM in use, can't get the analog in to work though. Am using a signal tester to the AI channel 5 but the plc does not read it. With the old setup without IFM it works. Can you see any fault i am making? Cheers

GX Works 2 IFM No input.PNG

Share this post


Link to post
Share on other sites

Hmm. In the IFM monitor i do get a correct signal value for channel 5. It's is somehow the transfer to D501 that i have done wrong.

AI5 Works.PNG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now