6 posts in this topic

Hello, i'm newbie for plc.

i want to ask about PC/computer send data to PLC CP1E with serial communication (RS232).

my wiring cable is:

PC                         PLC

2                             2

3                             3

5                             9

4&6   

7&8

                              4&5

and if i send data from PC to PLC, my indicator in COMM is blinking. i think the cable have no problem.

but if i send data from PC to PLC, the memory is not same as what i send and whatever i send data, the memory didn't change.

i will attach my ladder diagram.

what should i do? 

 

New folder.rar

Untitled.jpg

1 person likes this

Share this post


Link to post
Share on other sites

First of all, the reception completed flag is A392.06.  Secondly, post a picture of the settings for the comm port.  Or just go ahead and post your project (.cxp file).

Share this post


Link to post
Share on other sites

Sorry for my late response, its my .cxp file, send data from PC to Omron CP1E i think its no problem, but if i send data from PC and i check data in plc memory, its no same and didn't change.

Thank you

PC to PLC edit.cxp

Share this post


Link to post
Share on other sites

Does the Reception bit turn on (A392.06)?  Use differential monitor to check.  Also, do you see a  value in A393?

If neither of the above is true, do you have a CR+LF as the terminator in your data? 

The program and settings look correct if using CR+LF as the terminator.

 

 

 

Share this post


Link to post
Share on other sites
On 9/10/2018 at 9:38 PM, Michael Walsh said:

Does the Reception bit turn on (A392.06)?  Use differential monitor to check.  Also, do you see a  value in A393?

If neither of the above is true, do you have a CR+LF as the terminator in your data? 

The program and settings look correct if using CR+LF as the terminator.

 

 

 

sorry for my late response, if the indicator rs232 in cp1e is on, why a932.06 is always off if i send data or not? how to solve it?
Thank you

Share this post


Link to post
Share on other sites

Posted (edited)

The receive complete bit will energize based on the Settings for the End Code for the serial port.

In your Settings, you have the End Code configured as CR + LF.

The receive complete bit will only turn on when the CR + LF (0D0A hex) string is received.

The other option is to specify a different End Code, or specify the number of bytes to be received.

If data is being received (regardless of the indicator led) there should be a value in A393.  A393 will reset to zero when the RXD instruction is executed.

I hope this will help.

Settings_20181009.jpg

Edited by gtsuport

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now