Sign in to follow this  
Followers 0
Babyblue10

qj71mb91

4 posts in this topic

I have this module that is currently polling some modbus adddress. Problem i am facing is everytime this module is power cycle, i have to manually on back the communication via the function utiliy. how do i auto start this communication? 

Share this post


Link to post
Share on other sites

Posted (edited)

If you are referring to ‘starting’ the Modbus TCP card after a powercycle...

This can be started via the utility or via the User Program. I dont know about the Modbus cards but normally the start request in an Intelligent Module (32 bit) is the first output bit of the slot number- so for example if your card is in slot 0- then your start request signal will be Y0 (you can also analyse the inputs X0-X1F for module state before sending the start request).

Edited by collinsd70

Share this post


Link to post
Share on other sites

meaning y0 i need to enable so that everytime power cycle the module will auto start?

Share this post


Link to post
Share on other sites

Posted (edited)

Babyblue10

 

According to the QJ71MB91 User Manual- your start request is sent via Bit 5 so at starting X/Y 0000- your address will be Y4.

See the attached diagram which shows your process flow and signals to analyse.

 

 

 

Cheers.

IO.png

Flow.jpg

Edited by collinsd70

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0