malyalewariat

CX-Configurator CJ1W-PRM21 connection problems.

6 posts in this topic

Hi again.

I'm trying to make profibus connection between CJ2M and "Bosch Rexroth HF03 Manifold 12 Station DeviceNet Bus Box".

After configuration I/O table in cx-Programmer and up[loading it to plc I've tried to configure settings in CX-Configurator. I've set up correct connection parameters of cj1w-prm profibus master. When I use "Test" option or just go online I get errors: "Communication Failure with unit" and "CX-server cound not be initialized".
Am I missing CX-Server? I don't have this software installed on pc...

When i try to use scan option i get another error:


"Scanning failed, DTM returned an error for the request.
Following DTM reported the error:
Tag: CJ1W-PRM21 PROFIBUS Master
Name:CJ1W-PRM21 PROFIBUS Master (Version V1.xx)

Vendor OMRON Corporation.:


Any advices? I can't find any good manual for CX-Configurator but i get CX-Profibus manual - is it interchangeable? Because i can see  some same options in both.

Regards!

  •  

Share this post


Link to post
Share on other sites
Quote

Bosch Rexroth HF03 Manifold 12 Station DeviceNet Bus Box

This is a Devicenet slave, not a Profibus slave.  You need a CJ1M-DRM21-V1 master.

Share this post


Link to post
Share on other sites

Posted (edited)

I'm almost sure that this bosch unit provides profibus connection.

I've made mistake, because communication module is diffirent than I mentioned before.

http://www.ist-import-export.de/Bosch-Rexroth-RM65M-Comnet-DP-RM65M-16DP-F-1827030116-211

This module has COMNET-DP except DeviceNet printed on the top.


It is profibus slave.

What about those errors? I have no idea. Anytihng I  should verify, check?

Edited by malyalewariat

Share this post


Link to post
Share on other sites

Depending on your CJ1W-PRM21 version (latest is 3.0 I think) you might need to upgrade your CX-ConfiguratorFDT in order to make it work.

CX-Server is a middleware that is installed along with other software during CX-One installation.

Share this post


Link to post
Share on other sites

So many communication protocols to choose. I was sure that I've tried all but I didn't. It supposed to be toolbus(usb) in configuration tab, and now i can use test, and go online options without any errors.

I can now use diagnostic option and I can see states of plc and module.

But still I can't scan in order to find connected slaves. Help!

diag.png

error scan.png

Share this post


Link to post
Share on other sites

Again... what version is your PRM21? And does your CX-Configurator contains a DTM Version for that model or not?
Seeing the scan returns error with DTM version 1.0, I think your CX-Configurator is an outdated version. Try to run the AutoUpdate so you'll get a newer version (if you have a registered copy)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now