Mr.Moe

Sending alarms with NA panel

8 posts in this topic

Hello,

I have a question about the NA5 HMI. Is it possible to get the HMI to send important alarms to a phone or email? I know it is a basic function on some Beijer IX panels, but can`t find anything in the NA. Is it possible to do it in the PLC maybe?There we have a NX1P2 PLC.

Share this post


Link to post
Share on other sites

No phone or email support on the HMI.  I do not recall ever seeing email capability on the PLC either.

Share this post


Link to post
Share on other sites

Thanks for reply. 

Do Omron have any other solution to handle the alarm distribution? What is the best way to overcome this? A simple notification on email or SMS is what we want.

Share this post


Link to post
Share on other sites

I was able to get this to work with a local email server, but my ISP blocks port 25, so I cannot send it outside of my house.  I can show you what I did and see if that helps.

I downloaded hmailserver, which is a simple and free email server.  

I setup a domain that is set to default settings except for the name of the domain itself.

email2.jpg.fd7f6fd42e268958a10e5fef8e425

I created two accounts, one called mike@mikewalsh.net and one called test@mikewalsh.net and made up some simple passwords for them  

email3.jpg.effa7d61209bc6e9fdb804c7871dc

I left all other account settings at default.

 

Under Settings, Protocols, SMTP, then on the delivery of mail tab, I was sure to set the local host name to localhost (that just points the server to my PC).

email4.jpg.f7bc22848c011a473851e492321cd

I made sure to hit save and then closed out of the administration tool.

Then, In my email client, I set up both accounts like this:

email5.jpg.0aa39519570210822608a9d4801f1

email7.jpg.cf36145f766eba1e65b62ad702ac1

Lastly, my ladder looked like this (note, changed the timeout to 20 (2.0 s):

email1.thumb.jpg.dfdd9776d00ad2751a84bee

And the email that was received looked like this:

email6.jpg.4e88dd2443fdbfc3b1021464527ab

Edited by Michael Walsh
Fixed mistake.

Share this post


Link to post
Share on other sites

I was thinking about this some more today and I realized why I could not send email outside of my house yesterday.  Just because my NJ cannot use SSL, does not mean that my new email server cannot do SSL.  So, I configured my hmailserver email server to relay the email through gmail.  Using SSL allows the server to use port 465 (not blocked by my ISP).  You just need to configure the delivery of e-mail tab as shown below and then you can send email from the NJ, through hmailserver to gmail's server and then on to the final destination.  

 

email8.jpg.01e77c8887bb0df9ab455088a6076

Share this post


Link to post
Share on other sites

@Mr.Moe I just sent an email to your gmail account from my NJ.  Using the settings above.  

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now