Failure to communicate between a PC and a Red Lion G315 HMI SOLVED

3 posts in this topic

This is a problem that shouldn't happen .. It may be due to a defective Network port in the PC.

Basically, it's easy to connect to Red Lion G3 HMI's.. using USB, or Ethernet.   Unfortunately there is a flaw with the G315 processor.. and you cannot connect with newer PC's via USB .. and there is no FIX.   However, connecting via Ethernet should be quite easy .. and, I'm able to do it with several old and newer PCs' .. EXCEPT one:   A Dell Latitude E6410.  

I don't need help with the Red Lion programming to enable Ethernet communication via TCP/IP ... That's kinda straight forward. (sorta)

What I need help with is... what's wrong with my PC ..?  sniff!      I have two similar Dell's  .. one is an ATG model... I've set the fixed LAN IP address the same in both ( and I've set the HMI's Ethernet port (789) to an address in the same subset:  ...   The E6410 ATG communicates no problem.. the other E6410 ..communication fails.  Everything seems identical in both PC's (well... not totally .. the LAN cards might be different)

Anyone ever had this connectivity problem where only one of two identical PC's can connect via Ethernet?

Thanks Much...

PS: perhaps a suggestion on troubleshooting a LAN Network card?

OR..Firewall blocking the HMI connecting...  ?  

Edited by lamboom

Share this post

Link to post
Share on other sites

Firewall could have something to do with it. Try connecting to something else with both laptops and see if the problem persists.

1 person likes this

Share this post

Link to post
Share on other sites

Thanks for the reply Joe

PROBLEM SOLVED... The reason was not expected .. and worth sharing.    There were many good articles out there on how to manage the Windows Firewall .. but that wasn't the problem.

There were two identical computers, each was to be able to communicate with the HMI (not at the same time)  One could do it, the other could not. The HMI's IP address is set by configuration software created by the PC, and downloaded to the HMI.   That IP address was    Neither of these two PC's had made the original download.   I looked at the LAN static IP address for both PC's, and it was

Then I checked (using NetSetMan) the IP address of the PC's WiFi ... One was (the PC that worked) ... and the other was (the one that didn't work)

Could there be a conflict?  Two different networks: one trying to communicate with to an IP address over LAN, which is the same as the PC's WiFi  DHCP IP Address?    REALLY?

So I turned off the WiFi (little switch on the side of the PC),  Powered Cycled the PC ...  And The communication worked.

Well, I liked having the WiFi active .. almost never turn it off   So, I re-sent the HMI configuration software with a new IP address for the HMI:  And now both PC's communicate just fine with the HMI.. with the WiFi on and working too... :-)

PS.. I do have to turn the WiFi off when running a full Virus Scan with System Mechanic .. otherwise SM will crash .. but that's another story.


Edited by lamboom

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now