Joe E.

Wired connection kills wifi (Win XP Pro SP3)

3 posts in this topic

Our IT folks had to do a clean install of Windows XP on one of our maintenance laptops to get some of their security software to update.  We never got the wireless adapter working well before, but we would really like to now.  Today, I got the laptop back from them and found the right drivers from Intel for the wireless adapter to get it connected to our corporate network.  That works fine, and if I plug in the wired adapter to the corporate network with DHCP, everything works there, too.  What we want to do (and what we're already doing on several other laptops running Windows 7), is have the wireless adapter autoconfigure to get an address via DHCP to get access to corporate network resources (network storage drives, internet, some machines that are route-able, etc.) and have the wired connection manually configured with several static IP addresses to connect directly to machines.

The problem is that I can enable the wifi adapter and connect to the network and ping stuff that's out there and access drives and the internet just fine...until I plug in a cable to the wired adapter.  At that point, the wifi stops working altogether.  As soon as I unplug the cable, wifi comes right back up.  There seems to be a setting somewhere that kills the wifi as soon as a wired connection is connected.  If that's the case, I can't find that setting.  Here's what I've done/checked:

1) Metrics.  Go to "Network Connections".  Double-click on each adapter to open its "properties" dialog, double-click on "Internet Protocol Properties", click "Advanced...", un-check "Automatic metric" and enter a high number for the wired LAN adapter (999) and a low number for the wireless adapter (3 right now).  I initially tried 2 and 1, respectively, but I read somewhere that 1 is reserved for a loop-back adapter.  No change.

2) Connection order.  In the "Network Connections" window, click on "Advanced".  On the "Adapters and Bindings" tab, change the order so that the wifi adapter is first and the wired adapter is second.  No change

3) I read that removing the default gateway from the static IP addresses will help, so I did that.  No change

4) Double-click on each adapter to open its "properties" dialog.   Near the top, click on "Configure..." and select the "Advanced" tab.  There are a bunch of settings there.  According to our local IT guy, the setting I'm looking for is in there, but I can't find it at all.  I've checked every setting for both adapters and nothing seems to apply.

5) Checked the system BIOS.  Very little in there, nothing that's relevant.

The laptop is a Panasonic Toughbook CF-53 running Windows XP Pro SP3, 32 bit.  The wireless adapter has the driver recommended by its manufacturer (Intel).  Panasonic just referred me to Intel for the driver.  Intel said it's a Windows issue, that they don't have any such settings to change.

Again, we have this working well on multiple Windows 7 laptops, including our other Toughbook.

Any ideas? I'll be away from this over the weekend, so I'll check in on Monday.

Share this post

Link to post
Share on other sites

Here's a perhaps useful detail that we discovered.  The corporate network (which the wifi adapter automatically connects to via DHCP) allows certain address ranges to "route" through the switches.  One of those ranges is 10.130.249.*.  Each laptop has a static address in the 249 subnet reserved.  When the laptop in question has its reserved static 249 address set up in its wired connection, plugging in the wired connection will cause the wireless adapter to disconnect.  When we delete the 249 address from the wired adapter and leave just the 192.168.0.* address, the wireless works fine.  We don't have this problem with our Windows 7 laptops, just the Windows XP one. 

Interestingly enough, the network also routes 10.130.32* addresses.  Having the laptop's wired adapter configured with its reserved static 32 address doesn't seem to have the same effect.

Share this post

Link to post
Share on other sites

When I needed to do something similar, I think a mix of 1) and 3) worked for me.

In the metrics I put low number like 10 for wireless, and then higher number 100 or more for wired.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now