guillencito

Connection with a CPM2A PLC

9 posts in this topic

Hi! Who knows how can I connect a PC to a CPM2A PLC using the PLC's serial port? Because I lost the original communications cable for this PLC (CQM1-CIF02) And I believe this cable is connected by the peripherial port (I never used the cable and don't remember what kind of connectors it have) And we can't get another new cable because I need to check quickly an error in the PLC's program Thanks a lot by your help! Guillén

Share this post


Link to post
Share on other sites
If using the serial port turn the little switch next to the port to the on position. This means 9600, 7 E 2. Hostlink (sysmacway) And heres the link to the cables found in the download section Omron Serial Cables

Share this post


Link to post
Share on other sites
Thanks a lot, Sleepy Wombat! I really appreciate your help. Now we are on line with PLC and found the problem in a mechanical device (after verifying the program)

Share this post


Link to post
Share on other sites

I have connet to PLC CPM2AE but I have changed Peripheral to RS232C and now I not connect to PLC to PC when used CX One. I have tried connet two kind:

1. Cable CIF01  to peripheral : not connect

2. Cable RS 232 to port RS 232: not conect.

PLC is normal: run but port RS 232 in PLC have not connect to HMI althought before connect normal.

I have setting wrong hotlink to Rs232 but now I don't connect to PLC to change. PLC have no battery. Please help me to connect PLC or clear setting port.

Thank you somuch 

On 12/22/2002 at 3:03 AM, Jay Anthony said:

Check DM 6602 for #0001; if it is true, then the program is write protected. Change the value of DM6602 to #0000. See table below:

 

Share this post


Link to post
Share on other sites
17 hours ago, khanhtdh said:

I have connet to PLC CPM2AE but I have changed Peripheral to RS232C and now I not connect to PLC to PC when used CX One.

When using the CIF01 cable to connect to CX Programmer, set Peripheral tab settings to Host Link. Default setting is Standard(9600: 1,7,2,E) but this may be changed.

On ‎11‎/‎9‎/‎2004 at 9:22 AM, Sleepy Wombat said:

If using the serial port turn the little switch next to the port to the on position. This means 9600, 7 E 2. Hostlink (sysmacway) And heres the link to the cables found in the download section Omron Serial Cables

This is referring to the 9 Pin port. Did you try this? Be sure to find the correct cable. The HMI cable will not work with CX Programmer.

1 person likes this

Share this post


Link to post
Share on other sites

Thank you Mr IO_Rack. I will test it and reply you. Because PLC in china has not little switch on near serial. I will drill on board.

 

Share this post


Link to post
Share on other sites

Because PLC CPM2AE made in china has not switch ON/OFF near RS232 port. I have open board and check but pin in position dipswitch have no circuit.

In RS232 on PLC connect HMI used hotlink (9600,7,2,E) but now port not connect to HMI although before connect normally.

Cable RS232 is OK because I used many time: XW2Z-200S-CV.

Cable CIF-01 is ok.

It is difficult for me: no battery, no clear config plc, no reset plc.

Please help me, but not connect I must change CP1E and modul, I must pay money for that change.

May clear PLC?? because I have program PLC before change config.

Thanks you so much !

Share this post


Link to post
Share on other sites

I have connect cable with PLC by 2 kind:

1. CIF01

2.RS232 :  XW2Z-200S-CV  to serial port in PLC

When connect the led in PLC  (COMM): is flash red but no respond from PLC. I used CX one and used SYS Win but not connect.

Please help me !

Share this post


Link to post
Share on other sites

I was unaware of the Chinese model "E".

Did you try the Auto Online > Direct Online feature in CX Programmer using the CIF01 cable?

Is the HMI an Omron? If so, it's possible the 9 pin port may be set to NT Link and you will not be able to connect CX Programmer.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now