Linhvct

Using ModbusRTU Easy Master Function to control Inverter 3G3JX?

16 posts in this topic

Hi all! I'm a very new member of our forum (and in automation area too). I'm trying to use PLC CP1L (M CPU type) to control a inverter model 3G3JX. You know, the easiest way is using build in function ModbusRTU Easy Master, but I still can't make it work. Let me talk to you how I use this build in function so that you can help me out. I want to give a run command to inverter that its address is set to 01, so I inset these follow values to fixed DM: D32300 : #0001 D32301 : #0005 D32302 : #0004 D32303 : #0000 D32304 : #FF00 Then I kick up A640.00 ON using "SET" code. Before that I wrote a frequency value #500 into the "Frequency Referency Register" which its address is #0002h. D32300 : #0001 D32301 : #0006 D32302 : #0004 D32303 : #0001 D32304 : #0500 But there's nothing happened, and in the DM address D32502, I just saw #0080. I don't know why, everything is just ok but it didn't work. I show you the value of parameters that I set to inverter: A001 : 3 A002 : 3 B089 : 1 C070 : 3 C071 : 5 C072 : 1 C074 : 1 C075 : 1 C076 : 2 C077 : 0 C078 : 0 and somes... Would you please tell me why it didn't work? Thank you all!
1 person likes this

Share this post


Link to post
Share on other sites
Serial gateway can be tricky to figure out. I have created a generic Modbus/RTU Master application that includes CP1L. The link below is a complete Modbus/RTU solution, and the .pdf document that is included shows example setups for 3G3JX and 3G3MX2, including wiring, 3G3JX setup, and even an NS HMI application to run either an MX2 or JX. If you don't have an NS, you can use the Simulation mode of CX Designer to communicate to the PLC. http://forums.mrplc....ds&showfile=867 Below is the Easy Modbus portion of some training that I developed for the CP1H. It nearly identical for the CP1L. CP1H Easy Modbus Master section of Top Gun 2006 Training.pdf Edited by PMCR

Share this post


Link to post
Share on other sites
Eck, Just codes 03 and 10 is used to read and write registers. May be I find out what I made wrong. Many thanks for you supports.

Share this post


Link to post
Share on other sites
Your DM setup looks OK. Check the wiring, DIP Switches on the CIF11 or CIF12. DIP Switch on JX. Are you using the Right most option board slot (not the one on the left)?

Share this post


Link to post
Share on other sites
Thank PMCR, wiring, DIP switch in JX and CP1W-CIF11 are just the same as your picture, but it still doesn't work. May be I set up JX's parameters wrong. I can not find what I did wrong. In PLC's programme, setting page, tab Port 2, I set "serial gateway" and baud speed is 9600 with 1,8,1-N. Is there something else that I miss?

Share this post


Link to post
Share on other sites
In your first post, you show A001 : 3 Frequency Ref = Modbus A002 : 3 Run / Stop Command = Modbus B089 : 1 Monitor Display = Output Freq C070 : 3 Operator /Modbus selection = Modbus C071 : 5 Baud = 9600 C072 : 1 Node 1 C074 : 1 Parity Even C075 : 1 1 Stop Bit C076 : 2 Ignore Modbus Errors C077 : 0 Comm Error Timeout = 0 C078 : 0 Comm Wait Time = 0 Set C074 : 0. This will make the parity None, which is standard for Modbus. Serial port setup should be...

Share this post


Link to post
Share on other sites
I had just implemented inverter control using CP1 Series Easy Modbus and CJ with SCU. The postings and examples in omron forum were really helpful. In just 3 days I had everything tested. To those having problems using modbus..read the examples and follow the steps especially those presented by PMCR Dont have time testing and understanding protocol macro..it gives me headache haha. mine is pure serial gateway. Thanks everyone.

Share this post


Link to post
Share on other sites
Hello PMCR! Now I'm theme graduation and I want to connect direct 3G3JX inverter with PC through scada softwre ( ex: OPC kepware or vijeo citect) can you help me this problem? thank you!

Share this post


Link to post
Share on other sites
I can't help you with the specific setup of the software, but I can point you in the direction of the Omron material that you will need. In general, you will need to setup the driver to read / write from the Modbus registers and coils in the JX. http://forums.mrplc.com/index.php?app=downloads&showfile=988 The above link is the Omron 3G3JX Manual. PDF page 162 is the start of the 'communications' section of the manual. It list the addresses (coils and registers) for all the data in the inverter. When reading or writing an adderss, subtract 1 from the coil or register address in the manual to get to the Modbus register or coil. The JX supports Modbus Function Codes 01,03, 05,06, 0F, and 10. PMCR

Share this post


Link to post
Share on other sites
from the original post: >I want to give a run command to inverter that its address is set to 01 I'm not an Omron guy, but I've done dozens of Modbus setups with different devices. Usually a slave's address is set mechanically with DIP or rotary switches or via keyboard configuration or setup download, depending on what the device and how it configures. Many devices have no provision for changing the slave address via the serial port or Modbus protocol, in fact, I'm trying to think of one that does. A few devices I've run into require a power cycle on/off to recognize communications parameter changes. Most devices I've run across will default to address 01 anyhow. For what it's worth . . .

Share this post


Link to post
Share on other sites
Hi all! I want to learn and understand little bit more this ModBus communication mode. I Manage to conect an Omron CP1l cpu L with Yaskawa V1000 ower ModBus. I made a little simple program in CX programmator with default FB for Inverters. Basic run, stop, fw, bw... It really simple. And its working. But i wanted to made a little test scren in CX-Designer that i don't need to turn off and on the bits in the CX-Programmer to make it simple. (I don't have any touch screen i just want to made a virtual touch screen in CX designer) But the problem is that when i want to simulate i can't make it to work in real time with CX Designer? Is it possible to made a test with the CX designer (simulation) to really start the motor? or i can just virtualy simulate the working..? And another thing. You all know about the Yaskawa and Omron Inverters. Before they was same but not any more. I wandered yesterday can i parameter the Yaskawa Inverter with Omron CX Driver and i manage to do that. From yaskawa told me that is inpossible. It is working just with DriveWIzard Plus what is made for Yaskawa Inv. Products. The question is.. coz i had a little problem to connect with the CX driver the program changed some parameters in inveretr, i hope that i did't kill the original softwer in yaskawa, is ther a possibiliti that i owerflashed thew softver in Yaskawa driver with CX Driver program and i kill some fuctions with this conection in Yaskawa driver? After that conection i cold not made a ModBus conection i had to reset all the parameters in V1000 and made all the parameters back but i don't know did i change more something what at the moment i don't know. If someone have some conclusion or opinion pls tell me. Now it seems working fine I hope that my question is clear.\ \Sorry for my bad english. Thanx forward for the answers! Best regards Arpad Edited by arpix

Share this post


Link to post
Share on other sites
How is your NS connected to the PLC? I doubt you can simulate the CX if it is serial

Share this post


Link to post
Share on other sites
No my friend i don't have an NS! I want to simulate the NS with CX-Designer!

Share this post


Link to post
Share on other sites
No, bud. Ok its my fault because i did not give a good specification! My PLC is conected with V1000 with ProfBus communication. My PC and My PLC is connected with USB (Printer, programming cable). So basicly no ethernet communication. I am runing my PLC with CX-Programmer. Best regards Arpad

Share this post


Link to post
Share on other sites

Hey guys 

I m trying to communication yaskawa v1000 with cp1l -m30 

I have writen a program as photo

But nothing happen when i turn on a640.0 bit

Plz help 

IMG_20161010_161246.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now