Sign in to follow this  
Followers 0
zolti103

TSX3721 communication problem

17 posts in this topic

Hello, Dear i have a telemechanique PLC TSX 3721 series i wants to upload program from it, i have PL7PRO v 4.5, software, unitelway drivers 1.6, and a USB cable USB-TSXPCX3030(new OEM version not the orignal one, toggle switch at RX position), i have installed all the software properly i connect cables 1 end to PC USB port and other to PLC TER port, as the cable is detected on com3 i edit the com address in schenider driver manager in unitelway configuration to COM3, by default baud rate 9600(aslo tried on 19200), parity odd (also tried none), 1stop bit, 8 data bits , link type=unitelway, force virtual com port enable(also tried disable ), then i go to xway test, here remote address=0.254.0(by default) then i click 'connect' the status shows 'connecting' never shows 'connected' some times computer gets hang. i have tried this procedure on 2 same model CPU, 1 brand new without program, without memory card and battery, RUN indication OFF, battery indication ON, ERROR indication ON and TER indication is blinking, and other CPU is old one (with program )showing RUN indication ON, ERROR=OFF, BAT= ON, TER= slightly blinking. please help me for getting CONNECTED with CPU, if u suggest for conflict in OS version of part then i think after getting connected with cpu i can upgrade or downgrade the OS version using OS-Loader utility.. please get me out of this trouble I will remain thank Full to you. Regards with Great Anticipation

Share this post


Link to post
Share on other sites
what os are you using on your computer?

Share this post


Link to post
Share on other sites
Check your system OS. You should not use Vista with PL7 PRO. Also, in the Drivers Manager, increase the value for Link Time Out and RX/TX Delay for the UnitelWay driver (When I use USB cables, I put these values in 2 or 3). The path is Drivers Manager, UnitelWay Driver, Configuration, Edit..., Advanced Tab.

Share this post


Link to post
Share on other sites
thanks for reply and sorry for my very late reply actually i was out of station.. my OS is winXP SP2 as i have told that i have been tried different values for each function please tell me the exact values for each function i must have to put for the successful connection.. is battery or memory card must required for it ?? Best Regards with Great Anticipation

Share this post


Link to post
Share on other sites
yes i have been installed the drivers Driver Manager version = 2.5 IE18 Unitel way version = 1.6 IE16 the cable is successfully detected in Driver manger of windows XP at COM3 PORT...all information is in my first thread to this topic regards

Share this post


Link to post
Share on other sites
Those drivers are the default drivers, I want to be sure the TSXPCX3030 device driver is correctly installed on your PC: can you check on Installation Application of your Windows if "TSXPCX3030 device driver" is installed?? Otherwise you could install this

Share this post


Link to post
Share on other sites
Hello, 'TSXPCX3030 device driver' is listed in 'ADD/REMOVE PROGRAM' tool of windows in control panel my OS is winXP SP2 as i have told that i have been tried different values for each function(i.e baud rate, parity, remote address, unitelway slave address,delay values........ etc) please tell me the exact values for each function i must have to put for the successful connection.. is battery or memory card must required for it ?? and what should be the status of PLC for communication to the PLC Best Regards with Great Anticipation

Share this post


Link to post
Share on other sites
salut essay de mettre le couvercle de la carte mémoire pour éliminer le voyant Ter

Share this post


Link to post
Share on other sites
thanks for reply, but i cant understand your message i can only understand english regards

Share this post


Link to post
Share on other sites
salut essay de mettre le couvercle de la carte mémoire pour éliminer le voyant Ter What you like basic chassis?

Share this post


Link to post
Share on other sites
if you have an expandable chassis, you must put the terminating resistor

Share this post


Link to post
Share on other sites
i have CPU all the IOs are inserted no more IOs can be inserted and TER is directly conected to interface ADAPTER cable, can you please tell what exactly should i put in following fields of unitelway driver configuration fields, if you have any document regarding all the details of 'unitelway driver' and 'xway test' and in which mode PLC should be for successful communication with PC (RUN, STOP, DIAGNOSE) cpu only has 1 button for diagnose mode Thanks with anticipation

Share this post


Link to post
Share on other sites
You should be able to communicate with the CPU regardless of which mode it is in. The default port settings should work unless someone changed them in the PLC, and then there's no way to tell other than try all combinations.

Share this post


Link to post
Share on other sites
Check that in PL7 the Driver is UNTLW01 and the Address is SYS. This can be seen from PLC-> Define the PLC address. Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0