Search the Community

Showing results for tags 'visual studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 82 results

  1. C-mode hostlink library for NJ/NX1P or CP1L

    Anyone knows if there is a C-mode hostlink library for NJ/NX ? Also, a C-mode hostlink library for CP1L could be helpful, to translate such a library to work with NX1P is probaly less work whan writing a new library.  Maybe Omron France has developed such a library? - they seem very active..   Background: Looking into writing a programmatic c-mode hostlink master for NX1P12, this is for connecting the handheld NSH5 HMI to the NX1P12 via RS232C using a CIF01. I have the hardware set up, and an machine built, expected some compatibility efforts by Omron.... but the NSH5 seems to talk C-mode hostlink, and the CIF01 only seems to support the FINS version hostlink.   On the NJ you can of course add an SCU module, thus not need a library.  But working with NX1 ( due to limited space available ), you are dependet on available CIF-modules which do not support C-mode hostlink.  
  2. How to watch the value in decimal directly in the ladder page ?  Default Hexadecimal The only way I can do it is in Watch Tab and I/O map per example Thank you
  3. I have a new PC that is running Windows 10, I have RSLogix 500 loaded and working no problem, along with RSLinx, Factory Talk Activation... etc. I also loaded the Studio 5000 package and it loaded without a problem however will not run. It starts and allows you to pick a project to work on, then will display the Logix 5000 splash window for a second, then just close. No error message, crash or idea of what it is doing, just closes. So far no help from AB, perhaps someone here is running this on Windows 10 or has an idea how to figure out why it is closing. Thanks
  4. i am new in indusoft web studio. i am facing a problem about communication of indusoft with plc.   i am communicating with plc through fx2n-422-bd card.   can some one guide me the steps of communication.  he/she will be a life saver.. as i am  in a deep trouble
  5. Hi. I am new to Allen Bradley PLCs and bumped into the following issue, that I cannot find any solution to. When trying to add a module to the I/O configuration I get the attached error, error code 80131940. This prevents me from adding any hardware configurations in Logix Designer. I have tried to reinstall Logix Designer and uninstall all AOPs. I am running V30.00.00 on a Windows 7 Enterprise SP1 OS. Your feedback is very much appreciated.
  6. Hi, is it possible to communicate between the Sysmac studio simulator and the CX-Programmer simulator? I want to test the exchange of data between a NX1P2 and a CJ2H, but I don't have the controllers with me. Thanks and have a great day!
  7. Torque Control

    Hi, For my system I use the functions Mc_MoveAbsolte and Mc_TorqueControl. my problem is when i use absolute function after torque control for zero point. the servo turns the torque point control. For example: Target 1: 200 mm target 2: 150 mm Target 3: 240 mm ( Start point of torque) Taget 4: 330  mm (end of process) Target 5: 0 mm After "end of process" the servo turns  to "start point of torque" Can you help me please    
  8. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  9. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  10. Hi all, I uploaded SW from working PLC NJ301 1100 v 1.9. Uploading worked, but when I tried to open program, all rungs were empty (see picture). Does anyone know the cause?
  11. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  12. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  13. Any new tags I add in studio 5000 the HMI project shortcut cannot locate the tags, it says unresolved route to processor. It's the same shortcut all of the other tags are using. Please help. 
  14. This is my first time to the forum and I am still very new to plc programming. I just had to move all of our software over to a new computer ( kind of new) it's running windows 7 pro. The same is as the computer before. Same computer name, same I'm, same file directory. However when I add tags in studio 5000 and reference them in the HMI, it says it is unresolved in route to the processor. It only does this for the new tags. I used the same shortcut and everything so I am at a complete loss here. What do I do.
  15. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.
  16. OS: Windows 7 Ultimate 64-bit running on VMware virtual machine. Installed software: Studio 5000 V21.0 Licence: Concurrent (served by licence server on another PC). On starting Setup.exe from the VM's desktop I get the message     "Studio 5000 does not support this version of windows" Any ideas how to proceed?
  17. Hi guys, I am trying to open an application and i keep getting this error. Failed to initialize the service: {3F883B87-2208-11D4-B0E7-001083022E04} Does anyone know how to get rid of this error? Regards,
  18. Hello,   I want to do a small scada for Allen bradley plc  on C#. I did a hmi/scada for Siemens S7-1500 plc on C#, it is working and free. I dont want to use Advanced  Hmi. it is looking free but I can not use it in industries as free. so I decided to use direct C#. Do anybody has sample program, code, document, library, link, etc.. about C# and Rockwell plc communication? second solution and question, if anybody has no solution; I may solve it with modbus TCP. but I dont know Compact logix L27ERM CPU support direct modbus tcp protocol. if anybody has knowledge about the modbus tcp protocol document, sample program etc.. I can try to communicate with modbus tcp C# and Allen Bradley.   Thank you in advance. 
  19. Is there any way to establish a variable as min/max value of a gauge on sysmac studio?
  20. I am using an Omron NJ controller and a Cognex Dataman 260 bar-code scanner.   At this point I can trigger the scanner and receive data from the scanner via ethernet/ip. My issue is in converting the response from the scanner to something human readable. The bar-code I scanned reads "872-3GSq".  The results of the scan are located in the variable Dataman_to_NJ[8]-[11]. At some point I know I need to use the SWAP function but I believe my lack of data type knowledge in this system is hindering me. How can I convert the value in Dataman_to_NJ[8] to the string "87"? Any assistance would be appreciated.  
  21. HMI VIEWER APP

    Hi recently I have seen Omron Europe and I have download an app for Android and iOS, that app can allow you to remote view HMI types NB,NS and NA9last from Omron). The reason of all of this, is if some body have try this app and also if communication and remote view was creat it. I have try all my best but still can't make it, if some body did it, could you please share it?. Thanks, Jose
  22. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  23. Hello, Does anyone have experience with getting online a NJ/NX via USB with Sysmac Studio running on windows 10? At Omrons website it says Sysmac Studio offers windows 10 support from version 1.15 but I can't find drivers anywhere. Have checked in the communication middleware folder as you can see in the attached picture.  https://www.myomron.com/index.php?action=kb&article=1580 I have Sysmac Studio 1.20.1.0 running on Windows 10 Professional. Its not a big problem for me right now, because I can always connect via Ethernet, but if the driver exist I would appreciate having it.  
  24. Hey, this is probably a stupid question, but how do I delete old FactoryTalk View Programs. They are the ones that I have uploaded from a PanelView Plus via the "Transfer Utility" and then restored runtime using the "Application Manager". I open up FactoryTalk View Studio and I can see a list of all the runtime applications or I can create a new one. My question is, where are these applications stored by default? I have a bunch of old ones and test programs that I want to delete that are just cluttering up my list. I attached a screenshot to show you exactly what I'm talking about. Thanks, I'm sure this is a pretty easy/ dumb question. Howard
  25. Hello, this is a noob question on how to code properly. Im trying to do something like this on a code editor inside HMI (NA5) Page:   For i = 1 to 100 Me.Button_"i"_Line_ON.Enabled = True Next i The code is more complex than this, thats why I cannot use the Animation tab feature on the interface to set Enable The number of buttons are 100, so I dont want to go 1 by 1. My poor knowlegde on Visual.Net and searching engines does not allow me to find a solution for this in a short lapse of time. Anyway to do this? Thx in advance.