Search the Community

Showing results for tags 'thermocouple'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 6 results

  1. I'm testing installation of a custom-built machine. The equipment is at room temperature of about 19°C for a couple of weeks but the PLC is reading 25 to 29°C from the J-type thermocouple inputs. I suspect the machine builder has used copper cable to wire the thermocouples back to the I/O point. He has also used what appear to be regular M12 connectors to make the connection. Configuration of the input module does not appear to be correct. We're in 50Hz-land. I can't find any wiring instructions in the A-B documentation but I suspect that we should at least be using compensating cable and proper J-type connectors near the heater zones. Any pointers?
  2. Rockwell 1756-IRT8I

    I'm using three 1756-IRT8I's.  This is a test application.  Of the possible 24 TC inputs, they may use any one of the inputs or only 1.  One TC is required on the first card input 0.  The reset of the points may or may not be used.  I do not see a built in bit that indicates whether or not a TC is connected.  Should I just look at the under range bit?
  3. Help Programming a Beckhoff PLC

    I have a very simple problem that I need help with.  I have some programming experience but I am brand new to PLCs and structured text.  I am using TwinCat 3 to program a Beckhoff CX9020.  My goal is to read the temperature from my thermocouple and open or close a valve based on the temperature.  I have successfully connected the PLC to the TwinCat software and I am able to see the value of the thermocouple increase and decrease when I touch it with my fingers.  I need to link that value to a variable in my code so I can have the valve act on it.  I don't know how to properly address the inputs and outputs.  Thank you!
  4. Hey all, i have a friend with an application where he has a "black box" which is comprised of a heater and a thermocouple (4 wires coming out in total). he's using a B&R digital output module to turn the heater on (i.e. give it 24V) and a thermocouple module to read the temperature from the TC sensor. with one of these "black boxes" he has encountered a strange phenomenon - once the reading from the thermocouple reaches a certain temperature (and the digital output giving power to the heater from that same "black box" is still on), instead of climbing, the temperature reading begins to drop. Once the output from that same "black box" is turned off - the temperature reading jumps to what it was supposed to show if it hadn't dropped. other than a defective sensor ("black box" was changed and the phenomenon stayed), do you have any other explanation for why this would happen?   Thanks.    
  5. I'm new to Omron, and after several days of diving into manuals trying to figure this out on my own and giving myself a headache I've come to accept that i need help. my task is the following: Control of the discrete and analog inputs/outputs in a DeviceNet system using an Omron CJ1M PLC’s and PT’s. Use at least one thermocouple, one analog input, and one analog output for the DeviceNet network. Use a pushbutton and a light for the start of the process and an indicator for the started process. I have a Drt1-Ad04 input, a Drt1-ad02 output, and a Drt1-ts04t temperature control. My devicenet is Cj1w-drm21, The Omron system itself is a cj1m-cpu13 etn21. I have node addresses for my input, outputs and temperature control, those being 35 for input, 25 or 30 for output and for temperature control 5, 15, or 20. The ip address im using for this project is 142.214.143.9I'm using Cx programmer, Designer and Integrator. On Cx programmer I've managed to create an IO table but i have no idea on how to begin the program or even get a current reading from my generator.On Designer I've made what i believe to be the layout of the pushbuttons, I just have no idea of what addresses to enter.And on integrator i'm having troubles on figuring out how to make a routing table. I've went through many manuals and either i'm missing something really basic here or I just have no idea on what I'm doing. The only advice I was given was to dive into more manuals and find my addresses for my inputs, outputs, and temperature or to find the information from an outside source be that a forum or customer service. I am able to provide more information, and screenshots of what I have done if needed. Any kind of help would be greatly appreciated!
  6. Simple Heating Circuit

    Good morning....I am new to mr plc. and new to setting up a heating circuit I am experiencing an issue with setting up a very simple heating circuit using AB Compactlogix 5370 , 1734-IT2I t'couple card, k type t'couple System is simple Setpoint 300 F high limit 305 F low limit 295 F I want to turn the heater on and have the PID cycle the contactor as necessary to reach and maintain desired set-point does anyone have any sample logic? Do I need to mess with gains? Thanks!