Search the Community

Showing results for tags 'sysmac studio 1.13'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 108 results

  1. hi dears, I have one CS1D omron Redundant controller ( CP65H) that must be connected to NS15 Touch panel. I want to use Ethernet for connecting HMI and CPUs (CS1D-ETN21D). I have one question. for NS15 we can use CX designer and sysmac studio? is it true? which one is better? what is your recommendation for HMI software? Thanks.
  2. How do I edit an array size ARRAY[0..13] OF REAL to ARRAY[0..15] OF REAL? Sysmac Studio doesn't allow it to be done online, as far as I can see. If I do it offline and then go online and Synchronise, Transfer to Controller I receive error Any ideas?
  3. Trying to connect our old Sysmac C200HE PLC to the CX-Programmer software however, failed connection appears. We are using a USB-Serial connection and have set up the comms on the device manager. To try and connect to the PLC we are using the Auto connect function, selecting the usb-serial connection and selecting the comms the same as the host network. Any help would be greatly appreciated.
  4. Hey guys I have searched the forum, but can not find the answer I am looking for. I have an Omron Nx102-9000 along with an NA5 (9 ") that I use to control an industrial furnace. I need to set an output one at a given time (date and time)  A time that should be able to specified from day to day via the HMI Is there anyone who can help me? Then I would really appreciate it
  5. Good morning, I am working with sysmac studio v1.25 controller NX1P2 and HMI NA5. I have been trying to link and modify members of an structure in HMI without success and I don't know if i'm missing some syntax or if it is even possible what I am trying to do. 1. In the PLC I have the struct "Formato" and global variable "Formatos" which is an array of Formato. 2. I have mapped this variable to the NA5 so I can use the same data type. 3. I am trying to give a value to the members of my struct with a recipe of the HMI. I am trying with different syntax, with AT connection, without AT connection and none is working for me.   Is it possible what I am trying to do?   Thanks very much in advance,
  6. Hello everyone, I have a problem with packing machine. There are some issues with one of the axis, when axis actual position is near to 1800000 some error appear and operator has to turn off machine on main contactor. This axis is working in Linear mode. I think that rotary mode would be better for this axis. And here is my question. Which instructions, and what options i should change/check when i change count mode in axis's options. Can any1 point me some manuals to read or give me some advice ? Thank you in advance.  
  7. I need to import/export all recipe templates to/from a single csv. file Anyone with a Solution for this? Thank you 
  8. Hi there,  I am considerably new with setting up E/IP on OMRON's NX1P2 PLC. I have been trying to connect a Keyence IV-G to my PLC with E/IP connection (because there's no analog I/O available) and struggling with getting a connection going between PLC and camera. I connect these two through an unmanaged network switch, which I believe doesn't need any further configuration. I have set tags on Built-in E/IP inside SYSMAC Studio, and when I monitor them it says "normally resolved". Unfortunately, it still has red dot which means connection is cannot be established. The error I'm getting is "Tag data link connection timeout". Maybe built-in E/Ip just doesnt work for this case? I have yet to try getting connected with Network Configurator, but have the feeling that it will just accomplish the same thing that I did with Built-in E/IP inside Sysmac Studio.
  9. Hello, I'm looking for sample program to communicate Cognex DataMan 262Q, now i have connecting by Tags, 496 bytes input/output, but in manual i see :  
  10. I am trying to use the Event "SaveUserAlarmLogToFile" tied to my F1 button to save my alarm history to my SD card installed in my screen, but I can not find any details on how to specify the file name for the save...can someone please clarify what should be entered for the file name?     Thank you!!!!
  11. Hello everyone, I have this message when I trying to open my project which I did.  "The project includes a model that cannot be used with the current license. The project is closed." I recently reinstalled windows, but version of Sysmac Studio is same, License is same, but now I not be able to open my project. I just tried to install last version of Sysmac Studio 1.25, and of course nothing changed, looks like issue with license. But again, license is same.
  12. I'm very new to sysmac. I am trying to display the current date and time in the corner of each of my HMI pages. I saw a button labeled date and time. It is asking for a variable for behavior. Do I need to write some basic structured text or FB in plc to get date and time and pass it over? I figured the button would update itsself since when I placed it on the screen it had the current date and time and refreshes every time I leave the page and come back. 
  13. NA5 Orientation

    I was wondering if the NA5 could be flipped for a portrait orientation, I am working on a new project that has serious width restrictions!  I looked through the Sysmac software but could not see anywhere that it could be done in the hardware configuration.   Thank you!!
  14. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  15. Good Evening, using the Ethernet Built-in LAN I need to program 4 power supply. I'm tryng to program the firstone but even if I can send the correct command to the power supply I always recive a 2006 error on SKTTCPRCP function Is there someone that can help me in order to not receive the 2006 error code? Have I to respect a procedure? It seems that at the second connection time the socket remain closed. Thank you!
  16. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  17. I am a long time Omron user, but this is my first time using the Sysmac software, I want to compare the 16 bits of my array to zero, if any of the bits are on I want to turn on an output, I see the AryCmpNE and AryCmpNEV, but they have a seperate bit for each item in the Array, is there any way to do this without using Unions?   Thank you!!
  18. I use Netgear routers with multi-NAT capability to attach machines to the company LAN. One of the advantages is that similar machines can have identical network addressing schemes while a multi-NAT router on each machine can be used to assign unique external addresses. The usual error on these setups is to forget to assign a gateway IP address and so the PLC can't respond to requests from outside its subnet. I have the router set up as normal (as I have done a hundred times before on other machines). PLC has correct IP address, subnet and gateway (that of the router LAN address). Router has NAT rule configured, correct LAN subnet, etc. I can PING the PLC from the company network. This implies that the router, wiring, etc., are all OK. If I disconnect the PLC ethernet cable during a PING I get errors. This implies that the address is unique, etc. Controller --> Communication Setup --> Ethernet connection via hub --> Ethernet communication test --> "A communication error has occurred." Has anyone seen this? Any reason why it shouldn't work as I expect? Many thanks.  
  19. Hello, I am looking for a way to programatically select a recipe. Any time that a recipe is change or saved, the recipe viewer object always resets its view and selects the first recipe. This will lead to possibly writing the wrong recipe to the controller, as well as frustrate the user if they have to scroll through a hundred items to find the recipe again. I looked at the VB functions, but the only one I could find that was close was the .SelectedRecipe, which is a read only. I am using Sysmac Studio v1.1.7, and an NA5 HMI. Any help would be appreciated.
  20. FinsGateway Help

    First of all, I apologize if there is a simple solution, if there is, I can't seem to find It. I simply want to make and HMI talk to a PLC using Omron's FINSGateway/SYSMAC window's drivers.. Heck, if I can get an example that uses a simple Excel spreadsheet talking via DDE that would help. I have been writing custom drivers in Windows for years to send FINS commands back and forth to the various Omron PLC's, based off of a bit change either on the HMI side or PLC side. Super fast since only the data that has changed is written back and forth... Lately I have tried using DDE (polling type) communications as some jobs require this and not custom drivers. We use Wonderware Intouch for the most part and have found their DA and OI servers for Omron to be terrible at communications on large IO installations. Their IO servers essentially send 1 packet per bit or word every x msecs over the network according to a wireshark capture instead of blocks of word ranges. I was told FINSGateway / Sysmac Gateway could be installed on a machine and map via datalink( or the sorts) PLC memory to  psedo PLC memory on the windows computer; that the local computer mimics a PLC. The third party application can then read the local memory many times faster than going across the network to get it packet by packet. I can't seem to find a simple 'DDE' type interface with FINSgateway whether trying to use it locally or to a remote PLC. Usually a Topic name and an Item / Tagname....  I have used these DDE interfaces with other brand PLC controllers and their local driver, but can't find squat with the Omron Driver.  Usually you specify in the HMI a tagname and it is pointed to a 'TOPIC' and 'ITEM' that relates to an address in the PLC. Anyone have any type of info on this? I see posts in forums about doing this, but can't find any specifics. Again, I would think this would be basic beginner stuff, but can't seem to find any info on FINS/SYSMAC gateway  and how to make a third party app talk to it. It's been around for many years so I find this odd. Thanks for your time..  
  21. I am beginning my first project with the newer NX platform and am a little confused by the description in the manual vs what is actually in the sysmac setup.  The manual makes it sound like you can adjust the range settings for the card, but I don't see any where to do it in the setup.  I also don't know what the Index and sub-index columns mean, so I am wondering if this is a back door to access the range settings? 
  22. Hey was just curious if anyone has come across the error message for Sysmac Studio posted. I have uploaded an image. Essentially what happened was I was using sysmac studio, went for lunch and it wouldn't open when I got back. I uninstalled v1.23, ran the remover (1901) and reinstalled it. Still could not open without the error. I uninstalled and tried installing V1.13 (oldest one I have) and again am getting the error. Any help would be much appreciated. Thanks, DJ  
  23. Hi, Now I am using Sysmac Studio - NA HMI. I am facing the problem of Data edit tool here I am unable to give Indirect address. Like this address HM15_Recipe_hmi(Index_No).SetPoint_1 But If I give direct Address its working HM15_Recipe_hmi(8).SetPoint_1   I Hope someone give the solution.    
  24. Hello everyone, Working in Automation for the first time as a Co-op student so i'm fairly new to PLC's and the Automation field in general. I've recently been tasked with converting a RSlogix 5 program from an old PLC 5 project into a Studio5000 project. I referenced the manual (I'll attach link below), and had no issues using the RSlogix Project Migrator tool that I downloaded off the Rockwell website. My problem is that once I convert the program, my I/O tags that were originally sequenced in octets(0-7, 10-17, 20-27, ...) from the RSlogix 5 program, are switched into a sequential scheme in Studio5000 that just increments them in order (1, 2, 3, 4, ...). I hope this make sense, but basically the first seven tags match between the projects, but then I:010 in rslogix 5 is equivalent to I[8] in 5000, I:011 is I[9], and so on and so forth. Has anyone had this issue before and found a way to have Studio5000 keep the original octet scheme? I don't see this normally being an issue, but the customer has specifically asked that the I/O tag names be kept the same as the original program. Thanks for any help. - Ben   Converting PLC-5 reference manual link: https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/1756-rm085_-en-p.pdf
  25. I have a new PC that is running Windows 10, I have RSLogix 500 loaded and working no problem, along with RSLinx, Factory Talk Activation... etc. I also loaded the Studio 5000 package and it loaded without a problem however will not run. It starts and allows you to pick a project to work on, then will display the Logix 5000 splash window for a second, then just close. No error message, crash or idea of what it is doing, just closes. So far no help from AB, perhaps someone here is running this on Windows 10 or has an idea how to figure out why it is closing. Thanks