Search the Community

Showing results for tags 'servo motor kinetix compactlogix'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 110 results

  1. PROFINET Gateway Confusion

    I'm trying to setup some interlock signals between a CompactLogix L33ERMS and an optical gauge.  The gauge only offers PROFINET as the fieldbus for interlock signals (hard-wiring is not an option).  The PROFINET connection for interlocks in the gauge is supplied via a Beckhoff EL6631-0010 PROFINET RT device terminal (connected to a Beckhoff CX8010 bus coupler, but I assume that is not relevant). The PROFINET connection on the CompactLogix side is supplied via ProSoft PLX31-EIP-PND "EtherNet/IP™ to PROFINET® IO Device Gateway". My PROFINET experience is zero, and the ProSoft gateway was selected before my involvement in the project.  It seems to me that one of the PROFINET devices needs to be a controller or "master" on the network.  Right now, both the ProSoft and Beckhoff devices appear to be devices or "slaves", but the terminology is fuzzy to me (PROFINET IO vs PROFINET RT, etc.). Should I be able to make the connection using current ProSoft Device gateway, or do I need to upgrade to a PLX82-EIP-PNC "EtherNet/IP™ to PROFINET Controller Gateway" or equivalent?  Does at least one of the devices on the network need to be controller-level? Any direction would be greatly appreciated.
  2. Greetings every one...!                                         I am using NX1P2 PLC and G5 series Incremental Servo for decoiler machine. Now am facing issue, in the time of feeder working power interrupted then last position values are lost, but I need to retain last position value and feed again remain position. In the case  I am telling about (MC_Axis000.Act.Pos) this variable value I need to store and retrieve it back when power came.                                             Any sysmac software experts give me the best solution for this issue.  Thanks in Advance...!!
  3. Hi,  I want to use the servo drive in internally speed control, how can I change the motor direction? Do you help me for wiring and parameter settings please.  
  4. CompactLogix to Keyence CV-X

    Hi All. Was wondering if anyone has any ladder logic examples for controlling a Keyence CV-X vision system. There does not seem to be any examples listed on Keyence's website.  I have the CV-X connected to Logix via Ethernet/IP and it does respond to trigger commands. I am having some issues with changing programs in the CV-X controller via PLC control. Any help would be much appreciated. Thanks  
  5. hallo everyone ...i use mitsubishi Q00UJCPU and QD77MS2.. i try to make a speed control program and the speed wants to be changed during servo operating, i use dedicated instructions ZP. PSTRT1 (axis 1) and have tryed but it was only successful to change speed with "change speed control" function once ... is it like it? cannot change "change speed control" many times when servo operations?
  6. Hello forum! I'm using AB Compactlogix 1769 L35E CPU energized by 1769-PA2 power supply which is also supplying to 1769-SDN DeviceNet scanner, both via backplane. Trying to build a simply DN network connecting the scanner to a Balluff BNI DNT-104-000-Z004, which is a 16 PNP digital input block, since is only input module I rely that no extra power supply will be required. The problem is that when connecting both scanner and input block via my DN thick cable (Balluff BCC07YY), the input module does not energize. In fact I got no voltage reading when measuring voltage between scanner V+ and V- terminals. I measured voltage at 1769-PA2 power supply DC output (which is not in use) and its providing 24VDC, also scanner is powered on so I do not think the problem could be power supply nor backplane. Scanner display shows 92 number, scanner manual says that 92 error is "no devicenet power" and has the following description: No network power detected on DeviceNet port. Provide network power. Make sure the module drop cable is providing the proper power to the DeviceNet port. Which I do not get, is not the power supply from 1769-PA2 via backplane enough?  Is not the scanner supposed to provide voltage to the network? I've no grounding connection connected to PE yet (just between devices GND terminals)... is that a problem for testing this small network? It will be done soon but now I'm waiting for cable material. Actually I'm online using Studio5000 and have 1769-SDN DeviceNet scanner device declared at the project, there is no warning nor major fault displayed from the software. Thanks for reading.
  7. Is there a way to monitor the Temperature of a Servo Motor on Allen Bradley Servo motors... MPL? PLC: CompactLogix 1769-L30ERM Drive: Kinetix 6500   Motors: MPL-B310P-MJ72AA, and  MPL-B560F-MJ72AA I would like to be able to monitor the temperature, and flash a warning screen on the HMI if the Motor gets too hot, or perhaps shut down the operation before the Motor overload trips. The drive and PLC are connected through Ethernet IP What I don’t know is if that Motor heatsink temperature information is available to the PLC.
  8. Hi All, I am doing an application that use servo motor to feed plastic film to a target length (set by operator), and it need to stop immediately if marker sensor is ON. This application is control by Omron CP1E PLC. It will feed plastic film in 500-1000mm/s depends on the target length set by operator. It is require to stop immediately if the servo feed length more than 90% of the target length and the marker sensor is ON. However, is there any possibility for the servo to stop immediately once the condition is meet? As I am using PLS2(887) to feed with target length, and INI(880) to stop immediately, however, it cannot get the desired result as servo not able to stop immediately after marker sensor is ON, I am not sure is because of the PLC scan time, or servo need time to deceleration (deceleration rate assigned to #FFFF). Appreciate anyone able to assist on this. Thank you.
  9. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  10. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  11. CC-Link IE + C#

    We have a controller written in C# and need to integrate a servo.  We are looking at the Mitsubishi servo MR-J4 line.  Unfortunately it doesn't support Modbus TCP but does have the CC-Link IE protocol.  Does anybody know if it is possible to talk to CC-Link IE via C#?   I'm having a helluva time trying to find an answer.  I see some thing about Seamless Message Protocol (SLMP) and CC-Link but the info is somewhat sporadic.  Any advice is much appreciated as I've never worked with the Mitsubishi product line (but interested in their PLCs).
  12. Dear Friends, I am doing a pick and place project using stepper motor.programmed movement by PLS2 command and motion are running fine.I want to program origin for the stepper axis.Please help. i don't know how to origin with a home sensor input.I am using CP1E PLC and stepper driver DM860.
  13. Hi Guys, I need your various suggestion and helps on this issues. Past few days we facing an issues whereby the gantry of Z-axis which using the Kinetix 5500 servo drive straight crash down on the conveyor. The fault was Excessive Velocity Error and the first thing we took a look was the teaching and the speed. Somehow the teaching value of the motor and the speed was alright, we are running the axis on 100% speed. We have no idea the fault might be on the wiring or it might be the acceleration of the motor speed. We use to run this machine onsite at various customer, and this happens past few days. We run out of idea and we will be very much appreciated if there is any helpful idea could be bring up to. Steps taken so far; - Verify encoder value - Checked teaching position - Verify speed,acceleration and deceleration value was correct - Power motor connector was shielded  
  14.  Hi all. I have a question about how to set up the motor in rotary mode. My application will be a basic rotary table driven by a servo motor without gearbox between. So, in my servo drive axis settings, I select the motor as a rotary mode. then I defined the maximum position setting value for 360 degrees, and minimum to 0. So far so good. But the problem comes when I want to make an absolute move using the mc_moveAbsolute to move 360 degrees. Whit this settings the error "target position settings out of range " will come up. So, what is the solution to rotate 360 degrees without generating this error? if I set up the maximum value to 361 degrees and then if I rotate 360 the error will not occur and the motor will rotate 360 degrees as I aspected, but it's this correct ? or there is another way to do it? Thanks  
  15. Kinetix 300 servo drive

    Is there a real-time help resource for this thing other than the worthless AB site, on which the support page has been giving an error message for 2 weeks?
  16. Hello everyone! I have problem with understanding the usage/principle of operation of parameter "Mark detection number".  In manual i read: "The number of mark detections is stored. "0" clear is executed at power supply ON. Continuous detection mode: 0 to 65535 (Ring counter) Specified number of detection mode: 0 to 32 Ring buffer mode: 0 to (number of buffers - 1) Refresh cycle: At mark detection" My question is which mark detections are stored? Servo detects some kind of marks? I am novice in servo programming, please explain in the easiest way. Thanks for help.
  17. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  18. CompactLogix I/O Fault

    Hello, Back in December 2017, we replaced a customer's PLC-5 control system with a CompactLogix.  Everything was working fine until about a month ago, when they started having an I/O fault, Code 16 - I/O module connection failed on required module.  At first it was showing up on multiple modules, and also the end cap.  However, after a few more faults, it was only showing up on module 2.  We replaced that module and the faults stopped for about a week and then returned.  The module we replaced is a 1769-IA16. Any idea what may be causing this?  The customer insists nothing was done to the panel since the initial installation.  
  19. Servo Motor Connection

    Hello, I am using the R88M-1M40030T-BS2 ( 200V 3ph) servo motor. I am looking for a diagram that explains the connections on the top of motor ( for power supply).. there are more than 3 pins and i am not sure why. Can anyone help me understand the pins on the motor for the 3ph supply?  Thank you 
  20. Posted 22 July · Report post Dear Friends,       I want to set my servo controller overload setting as per my machine load requirement since all my servo installed in my machine over travelling and hitting trying to run continuously which is resulting servo failures ,repeated timing belt cut issues.Kindly help me resolve this issue.since i am not familiar with servo controllers.Model used A5 II minas servo MADKT 1507 and contol mode in position control setting.
  21. Dear Friends,       I want to set my servo controller overload setting as per my machine load requirement since all my servo installed in my machine over travelling and hitting trying to run continuously which is resulting servo failures ,repeated timing belt cut issues.Kindly help me resolve this issue.since i am not familiar with servo controllers.Model used A5 II minas servo MADKT 1507 and contol mode in position control setting.    
  22. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  23. Hi, I'm trying to set up PLC (CJ1G) to control servo motor. I'm using position control unit CJ1W-NC413, servo relay unit XW2B-40J6-2B and smartstep R7D-AP02H servo drive. I'm reading through manuals and feels little overwhelmed with information. Everything is probably there, but it's going to take lot of effort to put it together. Can I found example program somewhere? EDIT: When I put jumper to pin 25 (X axis RUN), motor shaft is locked and motor is holding position, so wiring should be correct. When I try to run a program, I can see that parameters are changing in CX-position, but servo is not moving. Please see attached picture
  24. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  25. Hi guys, I am trying to connect AB compactlogix 1769-L30ER through Ethernet cable to my laptop. I use Rslinx version 3.9 When I enter IP address it can find the CPU without any problem but it does not show the I/O. When I check the driver diagnostic, it says: Can't set port type to 288: no harmony object for this Ethernet I should mention that my OS is windows 7 and I turned off firewall as well. So, what does it mean and how I can get rid of this message? Thanks