Search the Community

Showing results for tags 'servo control'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 123 results

  1. C200HW-MC402.pdf View File C200HW-MC402-E Motion Control Unit Operation Manual Produced June 2001 Submitter IO_Rack Submitted 03/09/16 Category Manuals
  2. C200HW-MC402.pdf

    Version 1.0.0

    19 downloads

    C200HW-MC402-E Motion Control Unit Operation Manual Produced June 2001
  3. Beginners Servo Help Required.

    I have been programming Omron plc's for a while but have not used any servo drives. I have customer who is free issuing the following equipment for a project he wants programmed.: cj1m cpu21, r88d-gt04h, r88d-gt08h, r88m-g40030h, r88m-g7503h-s2. The small drive is connected to a simple ball screw moving a stop. The second drive is connected through a gear box and chain drive full details not known to date.  I have read the cj1 manuals and will be generally using  pls2 commands for the position movements.  Are the drives plug and play? If I connect the drives leaving the parameters as out of the box defaults should the drives operate using the pls2 command. In this condition I assume it is 10000 pulses per rev of motor. I can scale positions with maths in Plc and send the required pulses. Any guidance appreciated to confirm I am on the write track. I assume I could also use the electronic gearing parameters. Any examples using 5mm ball screw!    
  4. Hey guys, first post!  Friends at Practical Machinist sent me over here b/c we were stumped.   I have a Mitsubishi 500M control CNC machine.  There is a section of the ladders that i don't understand, and Mitsubishi couldn't help, and the OEM is defunct.  I do not have a hardcopy of the ladder circuits. I have an output , [Y13], that i can't get to turn on because of an internal relay | M453 |       see pic 1 When i searched for relay M453, it seems as if it's in some sort of array function.  see pic 2 None of the relays from M448 thru M512 ever turn on.  I understand that all these are controlled thru this circuit, but i have no clue what is going on with the R registers, and how the heck these internal relays can be turned on. Can you guys help explain?   Thanks!
  5. Sequencer Input

    I have a program using the SQO instruction. However, I am looking to control my program with a sequencer input. I have never used the sequencer input before and I have 16 sensors to move cylinders using the sqo.
  6. Hello Dears, I am studying to control position via Mitsubishi device Now, I have Q172 CPUN and MR-J2M(MelServo) to control position. But, I didn't find manual that explain command and parameter to do it and it has the example to do it. who have experience to control position, pls help me to overview it. Thanks so much!
  7. Hi... i want to ask about QD75D4, how to change rotation direction in positiont data ? If position data number 1 is CCW and position data number 2 is CW.   I try give value 100 (hope run CCW) and -100 (hope run CW) on posiition length but not respond.   Parameter axis #1 Control system = 2:INC linear axis   Any setting mistakes ?   Thank you
  8. Please suggest me about these issues: Issue: No Rotation 1.     The motor links are slack or release. 2.     Distant issue is stuck in the glide. 3.     The motor load is extreme. 4.     The bearing are shabby. Issue: Overheating 1.     The rotor is in part demagnetizing cause extreme motor present. 2.     Motor voltage is exceeding the highest value. 3.     The duty cycle is extreme.  
  9. Control Code in ST file

    I forgot how to do this. If I put in let's say 1234569632<cr><lf> how do I store the carriage return line feed along with the number in my ST file??? 1234569632(chr$13)(chr$10) something like this, but can't remember. Thanks
  10. Good day, I´m helping with small project and currently i am stuck because of this problem. And I hope you can help me out. I´m using PowerFlex 525 connected with AB CompactLogix 1769-33ER PLC via EtherNet/IP. Connection is working, I can read and write values from/to 525. To configure both devices i´m using RSLogix 5000. 1) First problem occurs after I loaded configuration to 525 and it´s, that 525 keeps overwriting values of Accel and Decel Time 1. It happens when i directly change parameters in Module Properties (online) or after I upload configuration to device. It happens even if i set parameters directly to 525 with its HMI panel. - I kinda get around this problem when i use Accel/Decel Time 2 for Step logic, but if i send direct reference value motor still jump to it and that is not good, especially when changing direction of rotation. 2) Second problem is that I cant get Speed Sources and Start References right. Usually Is working only option 1 and others are not, or they are doing something else that they should. For better imagination this is what i want to do: I have 3-state switch (left = 1 ON(DigIn TrmBlk 02), 2 OFF; center = 1 OFF, 2 OFF; right = 1 OFF, 2 ON(DigIn TrmBlk 03)), In center position I want to control 525 with EtherNet (already working when: Start 1 AND Speed 1 = EtherNet/IP). In left position I want to control motor directly with Drive Pot and In left position a want to start Step Logic (which i have already set) - Funny thing, If I set Start 1 = Ethernet, Speed 1 = Step, Start 2,3 = DigIn, Speed 2,3 = Drive Pot then in all three position motor goes in Step logic.. Or when i get left and right position working then Ethernet is blocked.. and this kind of things.. I Attach print-screen of my current settings, if you need something more just, tell me. Thank you for your time, and I hope someone will be able to help me.
  11. Automation professionals, I would like to read the display values of a red lion DP700 in a control logix PLC. I was able to successfully integrate both devices through EtherNet / IP and I am geting the corresponding values in a DINT register in the PLC. But the problem is that the value in the PLC register is not in the same format as in the DP700 display. The display reads the length of a product in inches like 288.484 etc. Where as the value in the register is a 10 digit number like 1133526516. For sure, there is a definite correlation between these two values but I am not able to figure out the exact relationship as a function of a formula. I have given below 25 data pairs for your analysis. I tried to find out the scaling factor (slope and offset). The scaling that I found fit the first 10 records but did not fit the remaining 15 records Can you help me to find out the relationship between the ? # DP700 PLC register 1 288484 1133526516 2 288627 1133531202 3 288631 1133531333 4 288739 1133534872 5 288741 1133534937 6 288742 1133534970 7 288746 1133535101 8 288757 1133535461 9 288776 1133536084 10 288796 1133536739 11 241060 1131482972 12 241043 1131481858 13 241027 1131480809 14 241032 1131481137 15 241055 1131482644 16 241038 1131481530 17 241078 1131484152 18 241025 1131480678 19 241030 1131481006 20 241037 1131481465 21 241040 1131481661 22 241023 1131480547 23 241053 1131482513 24 241041 1131481727 25 241077 1131484086
  12. Sinamics G-120 Drive on Profinet

    Dear Friends, In my present project, I have a S7-1500 PLC & 3 Nos, Sinamics VFDs(PM-240s) with Profinet ports.(CU-240E -2PN) The drives and PLCs are on the same Profinet network. I wish to know the essentials of controlling the command and speed reference of these drives directly from the PLC on profinet. Reading the help in TIA portal got me nowhere its all about Telegrams and things that I haven't figured out yet Thanks for looking in; I shall greatly value all help and advice.
  13. B&R plc, motion control, CNC

    Hi all. I have a B&R PP420 panel, some I/O on the X2X and 4 Acopos servodrives /servomotors. Successfully created and tested 4 axes, they work OK, control via NCtest or X2X IN, or PP420 display. But creating CNC system is the problem... On NCtest, I have errors, and no move. Error 7742: ACP10_MC FB error or aborted Info: Axis Index [0] Info: ACP10_MC FB error number [29226] Info: Command aborted [0] Info: ACP10_MC FB number [1] = MC_BR_MoveCyclicPosition (cyc. pos.) On SDM, axis error: 32274 Network coupling: The broadcast channel was not configured Can someone help? Thanks.svinaga@yahoo.com Foto errors.pdf
  14. CJ1W-TC001 PID question

    What is Omron naming convention for PID settings? I need to adjust the upper MV limits for PID running on CJ1W-TC001 installed on CJ1M-CPU13. Looking at the CJ1W-TC001 Operation Manual I am not really sure which values would these be. I guess Omron naming nomenclature is a bit different than what I am used to. It seems that the Manipulated Value Monitor is just feedback, which value would I need to set or modify to adjust the upper MV limit?
  15. Is it possible to read (and maybe write) the software limit values of a G5 servo from NJ code? It appears that PDO entry 607D would allow this, but how can I read/write to it? I don't seem able to map that entry to I/O. Thanks.
  16. Looking for a servo user manual.

    I'm looking for a user manual for the R88D-KN50F-ECT-L 5kW linear servo motor drive with EtherCAT. I have found Omron manual I577-E1-02, but this seems to only cover drives up to 3kW (R88D-KN30F-ECT_L.) It may be that there are no huge differences between a 3kW and a 5kW model, but I would like to have a manual that covers it if possible. Is there a more up to date version somewhere? Thanks.
  17. Hello All, I want to read data from a Control Logix PLC, into a PLC5/60, using Ethernet and a MSG instruction in the PLC5. When verifying the MSG instruction in the PLC5, I get an error message. "Target Address in invalid". Once I figure out how to do this I need to replicate it in another PLC5. Scope is to read the status of 4 paint pumps controlled by the CLX. If any of the 4 stop, the PLC5 needs to know, because it is controlling the paint application equipment. Source data resides in a Control Logix 1756-L63. The tag is INT type, 4 elements long, and the name is PUMP_STS_B2. The IP address of the CLX is 4.2.6.230. There are 2 ENBT cards, one in slot 1, and the other in slot 3. 4.2.6.230 is slot 3. PLC2,5 / SLC Mapping has been created in the CLX. File=421 Name PUMP_STS_B1 and File=422 Name Pump_STS_B2. The file mappings represent a binary file created in each of the PLC5's B421:0~4 in Booth 1, and B422:0~4 in Booth 2. The PLC5/60 is Enhanced series E model using the Ethernet side card. The IP address of the PLC5 is 3.26.5.61. I also created MG file types in each of the PLC5/60. MG420:0~19 in each processor. This was necessary to use the MSG instruction in the PLC5. I have searched the forums for examples of how to do this with no solid results. I am trying to follow the best practices of reading the data into my PLC so anyone who follows can tell where it is coming from. While the IP addresses are not closely related they should be able to communicate. I say this because all of our PC's are on the 4.2.6.XXX network on a 255.255.252.0 sub net and we have no issue communicating with the 3.26.5.61 IP address. Any help and advice would be greatly appreciated. Regards, Mike Carter
  18. I have an application using Kinetix 6500 servos and Compactlogix PLC. The app requires a change to the MasterPositionFilterBandwidth(MPFB) at particular times during gearing motion depending on the circumstances. This value can be changed instantly using an SSV instruction but I have found the new MPFB value does not take effect until the Axis is stopped or turned off. Once either of these has occurred, the new MPFB value becomes active on the next gearing motion instruction. Can anyone help me with how I can make this MPFB value take effect immediately?
  19. I have a 2 axis control that runs a pair of identical servo drives. as of late I have been getting reports from the operators that the two motors, while jogging forward will suddenly run in the reverse direction at a high rate of speed. There is not a reversing function on these axes in an way. I am suspecting there may be a problem in the analog output of the module causing an inversion of the signal which in turn causes the motors to run in reverse. This setup has been in operation without any instance of this happening for around 5yrs before any issue with out of control runs. All cabling has been checked and is properly shielded and grounded.
  20. I'm having a bit of difficulty with the MSG function on a logix5000. I'm simply trying to get a REAL value ("BH5_Flow") out of another logix5000 and assign it to a tag in the PLC. I've created a MSG function and created a new tag "BH_5_Flow_MSG" for the message, and created "BH5_Flow_M" for the value that will come from the MSG function. When I click the "..." button to bring up the config, I put the following in: Message Type: CIP Data Table ReadSource Element: BH5_FLOWNumber Of Elements: 1Destination Element: BH5_FLOW_MIn the PATH tab, i then put the following in: Path: LocalENB, 2, [iP ADDRESS OF SOURCE MACHINE]When I test the edits, I then get the ERR bit activate with error 16#0004 when the message rung runs. Anyone got any ideas where Im going wrong? I've practically copied another MSG instruction from further up the ladder but it doesn't seem to work
  21. Hello guys, i would like to know if is possible keep always active the run command in a vf drive and for stopping the motor only send 0 reference. It´s possible??? because I want to program a ramp function in my plc for start and stop one motor. could someone tell me how to do this type of control please?.
  22. Dear experts, I have been trying to flash parameter to QD75MH1 module from PLC. Every time I monitor the servo via GX-configurator QP, I find 0 error, 0 warning but in the history tab it shows "start not possible(108)". But when I did it by flashing the parameter by GX-Configurator QP(Specially invalidating forced stop option" it works fine and servo motor jogs. can anyone help me to write the forced stop value from PLC program?
  23. Hi, I have a problem with my BC9020 and hope that someone can help me. I managed to set the IP adress of my PLC in the 10.2.5... add a root, run a program and make the PLC working for a while. I then tried another program, a new one... and now that I want to re-read the first program, Twincat System Manager doesn't allow me to enter in the "run mode" and stays in "config mode". It also has lost the IP address I set (10.2.5.....) and came back to the 172.16.22... (manufacturer settings) I cannot determine if the problem is in the PLC Control or In System Manager... This is my method to change the IP *** IP config *** 1) Reset the PLC First I place the end terminal next to the PLC. I set the DIP switches 1,6,7 to ON, power on the PLC and power off. I set the DIP switches 2,6,7 to ON, power on the PLC and power off. I set the DIP switches 1,2,6,7 to ON, power on the PLC and power off. 2) Set my PLC on the same AMS than my own IP (172.16.22...1.1) 3) In System Manager, add a new route 4) change the setting in I/O Configuration -> I/O Device -> Device 2(BX9000) -> clic on BX9000 define "set IP Address" to Manual define " IP Address" to 10.2.5...., the AMS change automatically. Press the configuration button and then Ctrl+F4 (run mode) This method worked but seems not to be the best... If you have any Ideas ? or questions? Thank you in advance Gregi