Search the Community

Showing results for tags 'sample blocks for s7 1200 plcs'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 51 results

  1. Sample blocks for S7 1200 plc's

    Hi experts, please share the sample blocks for the EDITABLE TIMER block it should be editable from HMI(Siemens). And also motor run hour block. Actually i am having all blocks in tia v12 version and sadly i dont have the old software to convert it again. So please share the blocks that it shoud be work in TIA V14 for s7 1200 plc's. Please note that the blocks should use add instructions to calculate the time because i don't have much memory.
  2. Hi, to start, I'm very new to Siemens PLCs, but quite experienced on others (mainly ABB). I'm looking to set up a profinet network between an ABB AC500 PLC and an S7-1200. The goal is to transfer variables from an existing S7-1200 (owned by the customer) to my new AC500. It is required that I do this without having to stop the S7-1200. I can set up the AC500 as a profinet device, and have the S7-1200 remain as the controller, but this requires a config change on the S7-1200, which means I'd have to stop the PLC. I tried setting up the ABB as a profinet controller, but I'm having trouble finding a GSDML for the S7-1200 to allow me to do this.  Can anyone advise me on the best route to take to solve this problem? Thanks in advance.
  3. Tia Portal Programming Help PLEASE

    Hello I am having some difficulty writing code for a specific function using Tia portal and a S7-1200. I 10 Digital inputs and 1 analogue output set for 0-10V. When 1 DI is high I need the AQ to be at 1V, when any 2 DIs are high I need the AQ to be at 2, When any 3 DIs are high I need the AQ to be at 3V and so on.... I just can't work out the best way to do achieve this.   For a bit more info the to what the project entails the digital inputs are all coming back from DOL starters for woodworking equipment at workstations. When one of these starters is turned on a signal is sent back to the PLC DI card, this open a solenoid in extraction pipework and also increases the frequency at a VSD to extract the dust. So when more workstations are in use the higher the frequency of the VSD will be and the faster the motor will run allowing adequate extraction at all stations
  4. Optimized Blocks

    Hello everyone, Are there any alternatives to WinCC at the moment that can handle using optimized blocks. In most other SCADA software, while importing tags, the option to optimize blocks should not be selected as they cannot import in this format. Ignition by Inductive Automation has a driver that can be purchased to solve this problem. I wanted to know if there are some other solutions to this issue.  Thanks!
  5. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  6. S7-1200 timer

    Hi All I am struggling to get a TON in TIA v15 to work properly (s7_1212). I have tried reading what i can but still dont understand why what i have is not working.  I have attached a screen shot. I am trying to achieve a bit that is active for 1 scan cycle and resets every second. Coil1 is just staying active however and not resetting the timer.  What i have written works in Connected Components Workbench and other plc software i have used. What am i doing wrong? Thank you in advance. Trevor  
  7. Hello! I am using S7-1200 PLC 1212C AC/DC with configured Modbus TCP Server. I can already read/write Inputs/Outputs (Coils) and Memory Words. However I'd like to read/write Memory BITS. Is it possible? If so, how? What addresses should I use in TIA portal? And which function codes on client side? Thanks in advance!
  8. Hello! I am beginner in PLC world, also in SIEMENS PLCs. I managed communication over private network. Now I have a problem that I get same values on all inputs. Picture below shows my configuration of driver and data monitor. First picture shows values when input I0.0 is in state 0. Second picture shows values when input I0.0 is in state 1. Physically on PLC only input I0.0 is forced to 1, input I0.1 stays 0. But data monitor shows both inputs as state 1. Where is problem? Is problem in PLC program, TIA portal? I saw some guys using DataBlocks but I am not skilled enough to use it. Third picture shows simple PLC program on my PLC. Please help. Thanks in advance!
  9. Hello! I am trying to connect my PLC with SCADA. I am using S7-1200 1212C CPU (RELAY outputs). My SCADA system is iFIX 5.8 with driver S7A. I am trying to establish connection via GPRS router (TCP/IP). Port being used is 102 (default by S7A driver). In my company we have private network, SIM card in GPRS router gets static IP (set by RADIUS server)  which is 10.247.XXX.XXX. My PLC has IP 192.168.0.10 set in Project. I am not sure what am I doing wrong. How to correctly set IP address in PLC to communicate in private network via GPRS router with static IP? I already enabled TCP port 102 in my router but I am not sure to which IP should I enable it because I am not sure if IP address set in PLC is correct. Should I use some communication blocks in program? I also enabled PUT/GET function (see attached pictures). Please help. Thanks in advance! :)  
  10. Internal function block variables

    I have a function block where the first internal variable is showing as address H1420 in the Global Symbol table. When I add another retained variable to the function block then save and compile the code, the variable address in the global symbol table shifts from H1420 to H1488.  I need to retain the address as I will be downloading code and I need to ensure the address if H1420 stays with that variable.    Can anyone help with this?
  11. Have a micrologix 1200R 1762-L40BWAR.  If anyone could help with providing the following information: Need a communication port with single receptacle that will mount through the door of electrical enclosure and then the communication cable (6 to 10') that will go from the com. port to the micrologix. Thanks
  12. Does anyone have an example piece of ladder logic, created on a Micrologix 1200, using ASCII to READ and Write to a serial device?  I am building a ladder on a Micrologix 1200 that will send data to an old CNC once a certain ASCII instruction is received on the PLC.  For example, when the machine spits out an ASCII "1", the PLC will see the "1" and send out a three digit number depending on a sequence of discrete inputs.   Thank you,
  13. S7-1214C All LED Blinking

    Hi everyone. Recently I get a S7-1214C ac/dc/rly plc, whenever i connect ac power all the indicating LED i.e 'Run/Stop , Error & Maint' start to blink. I can't upload or download any program. In TIA Portal V13 only accessible node is not shown. Anyone encountered the same problem? Please help me. Thanks in advance 
  14. hi there is a 1215c and a fatek B1 plc here. 1215c as master and fatek as slave. i want to read 10 16bit words from Fatek to 1215c and i use Modbus rtu 485. i have a problem with what comes from Fatek To 1215C. thx 2018-08-25_11-56-16.mp4
  15. Hi,  I'm new to TwinCAT 2 and i'm upgrading a long time design (hence the TwinCAT 2 reference), to read a more sensitive torque signal.  I'm using a Beckhoff CX1030 as my PLC Controller.  I needed to add 'homing' to my motor sequence and confirmed with Maxon, im using the function blocks correctly and in the correct sequence to establish my 'absolute zero'/'home' position.  The motor has an output to write to:  ControlWord, which tells the motor that the position it is sitting in is '0.'  My program compiles, it runs, it writes each function block, but it's not seeming to get back to the test run opMode, even though i tell it to and the function block performs the 'Write' function.  it's stuck at zero and not reading an analog input signal from my torque sensor.  so im getting an artificial torque reading through every test.   i think this is related to my tare motion.  I start the program, home the motor, get into profile velocity mode, tare my sensor, enter profile position mode, go back to position 0, then back to profile velocity mode, run a test, sample data, go back to 'home' or '0.'  I wonder 1st, is my variable not linked properly through the system manager?  2nd, i set a boolean variable to set the 4th bit to 1 in my control word write (setting the 4th bit high will set my current position to absolute zero), but did i not connect the program to the main sequence properly?  looking to read a valid signal again and see that my motor moves back to 'home' each time.  Do i not need to home the motor after the tare, since the tare nulls out the torque value after the tare? after this i need to program my sample period, instead of it being fixed, as it is currently written and then use my home position as my trigger to start sampling.... Beckhoff applications department is overloaded, currently and can't help and this is all beyond the knowledge of the general support line.  I've gotten fairly far, on my own, but of course, the project is under a time crunch.   Does anyone know twincat well enough to help guide me?
  16. Hello everybody. I need to learn PLC programming. I already have some experience with Ladder language and PLCSIM so now I need a real PLC to do more practice. I was going to buy the following unit: 6ES7211-1BE31-0XB0 http://www.eibmarkt.com/isroot/eibmarkt/Files/DatenblattE/NS6102812.pdf It has 6 Di, 4 DO (Relay) and 2 AI, that's more than enough for me to do some practice. Do you think it would be a good idea to buy it? Or maybe this PLC doesn't have some important component or device needed to work properly? (my company will give me the software). Thank you to anyone will help me. Have a nice day, Edoardo
  17. HELP! Wiring 1214C DC/DC/DC CPU

    I am currently finishing my A.S. in Engineering Technology.  My Capstone course is to wire up a complete S7-1200 system using a 1214C DC/DC/DC CPU.  There have been no courses that have explained exactly how they are wired.  Only programming, which I am pretty good with.  There is a 120VAC to 24VDC power supply.  They want it to be wired to switches and lights for a simulator.  I am just not sure exactly how the I/O's are wired.  Is is sinked or sourced?  As far as I know, one sends the ground to the output, and one sends the 24v to the output.  I would love to speak with someone on how to wire this, as once I graduate, this is what I want to be doing, but I am stuck in a hard place as none of my classes taught us how to wire the PLC's and even worse, the programming class was all about AB PLC's.  I have not learned about Siemen's at all.  They should be pretty close to the same, but I know there has to be some differences.  Also, how they have it set up, there are 2 power supplies on the plastic panel just to the left of the picture.  This seems to me as this is a sinking I/O.  Am i off?
  18. Hello All,   I hope this post is not against any forum's rules. If so please delete.   I would like to invite everyone interested to have a look at my website, which is purely about TIA Portal and everything related: TIA Portal how to   There you can find articles, tutorials, tips and videos.   Hopefully someone will find it helpful. There are more materials coming so be sure to subscribe to Newsletter   There is also: Facebook Fanpage                          Facebook Group                         Twitter                         YouTube   Regards, Robert Jankowski
  19. Any body having sample program. Please share.   
  20. Profibus Function Blocks for Q2ASCPU for Melsec ST Lite RIO inter-connection. Please assist in advising the attainment of such blocks - if any existing. Thanks
  21. Hi all, I will be starting on my MSc in automation in a couple of days so for that reason i have obtained a S7-1200 series 1211AC/DC/RLY PLC. This is a new area for me as i have been working in offshore since i graduated from my BSc a couple of years ago. I watched some Youtube tutorials on how the programming is done and i am ready to try it out for myself, but i have encountered a little problem.   Problem: I am using the X1 P1 PROFINET (LAN) port as a connection to my PC, this turns the Green Link light on and the Rx/Tx lights blinks orange. Now to the problem, i cannot connect to the PLC through the TIA portal, no matter what settings and connection types i use in the PG/PC interface box. I have had no luck finding leturature adressing how to configure the PC/software and get a connection to the PLC. Do any of you have a PDF or link which can help me through this problem?  Hardware: S7-1200 series 1211AC/DC/RLY 6ES7 211-BE40-0XB0 S C-J5PN 1614 2017 FS:05 Software: TIA Portal Version 13 STEP 7 Professional V13 WinCC Basic V13   Thanks   Best regards   Dennis    
  22. ESATR / EGATR Commands

    Good morning folks, I've browsed this forum often enough over the past few years that I think it's time I finally signed up.  Lots of good ideas and advice that I've benefited from and I hope to return the favour some day. So on to my question.... I'm currently knee deep in a project using a CJ2M PLC and I have to send and receive chunks of data over Ethernet/IP.  To do this, I'm using the ESATR and EGATR commands (set / get attribute).  I would like to know if these commands finish execution (ie. the ethernet port completes the transaction) even if the input conditions to the command are no longer true.  Specifically, if I use the "port ready" system flag (A202.00 is an input to my FB in this case) as a condition to trigger the ESATR command, this bit will go low once the port becomes busy (ie. during execution).  So will that interrupt the completion of the ESATR command resulting in an incomplete transaction and data loss?  I've looked through the help files on the command but don't get a clear picture of how it behaves. Perhaps the attached JPEG shows more clearly what I mean. Thanks, PC
  23. need help for TIA V13

    Hello Everyone,  Our machine with PLC CPU 1214c, was program last year using TIA V13 professional. Now i need to add some Expansion module for additional sequence, but i only have here a TIA V13 basic. When i tried to search the hardware; yes it can be searched, but it will not upload the existing hardware (CPU+ other modules).  My question is, if the s7-1200 PLc was programmed by TIA v13 professional , does it can only  be edit  by TIA v13 professional? is there any chance that  the basic version can edit the programmed.    Thank you all in advance for your answers...
  24. I have a c-more HMI and an Allen-Bradley 1200, is it possible to set them up with two AB 1764-NET-IAC+ to have my computer monitoring the PLC at the same time, I have established communication from my computer to the PLC through the IAC, but I haven’t been able to integrate the HMI, is it even possible?. This is been setup for training purposes, any help would be appreciated.
  25. Analog module configurations

    hai everyone im new to this forum, i hope this forum will clear all my doubts about plc Ok Guys my doubt is How  to connect two, three, four wire sensors to S7 PLC's? Please help me guys im new to PLC Controlling Thank you.