Search the Community

Showing results for tags 'remotely access fx series plc data'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 121 results

  1. Lets say I worked in a factory that made multiple models of parts. I need to run data tracing on the off shift due to certain models only running on 2nd and 3rd shift. I want one data trace to capture one group of bits at Model 1, Then reset the Data Points and run again for Model 2, Model 3 and so on. So the Bits that I am mapping with the trace need to change.  I can change the trigger easy enough with my program. I see in the manual the CPU has a "separate memory area" for trace settings. Can this area be accessed from the Program so I can set my bit addresses to monitor to a word or E_?   See attached pic for clarification of what I aim to change through the program.   
  2. Not able to establish DDE connection

    Good day to all, I am trying to establish DDE communication between my PLC (1769-L23ER) and MS Access via RSLinx Classic Gateway (3.9) over Windows Server 2012 R2.  On my developing PC (Windows 7), there isn't any issue at all. But when I port the codes over to Windows Server 2012 R2, MS Access is not able to establish DDE communications with the PLC.  I was wondering what went wrong. The error message from MS Access is "MS Access can't find the specified application and topic because it can't open the DDE channel, err.Number is 282. The code for getting the channel is as follow OpenRSLinx = Application.DDEInitiate("RSLinx","PLC-D") I was wondering was there anything I have miss out. eg. Configuration of the server, path settings, etc.. Any help is welcome. TIA Cheers CY
  3. Device point error between Parameter and PLC

    Hello all, I am a beginner with PLCs programming. I have an issue on GX Developer programming software from Melsoft trying to program my Mitsubishi Q-series PLC. CPU is Q03UDCPU. When the program is written and I try to upload it to the PLC, with the write to PLC window, I check -Program -- MAIN and -Prameter -- PLC/Network/Remote, click EXECUTE and a message appears : "Device point that is set in parameter is not match the device point in PLC". I can't fix it. In Parameter - PLC Parameter - Q parameter setting (window) - I/O assignment tab : I have (see image). Whe I use CHECK button it says there is no error. The X41 input device is plugged on slot 1/00. I am making this folowing the instructions a PDF I found on the Mitsubishi electric's wesite : Q-series basic course (for GX Developer). Thanks for the help, A. S.
  4. Hi, I have a a few substations and I´d like to have a local SCADA in each of them. What is the best scada to use with reasonable price? Does anyone know if there is a solution without the need to have a PC for each substation? Thanx
  5. Dear Everyone can help     i have a batching system of about 12 materials and i need to generate a report for all batches in the day in runtime, i tried using SQL with Cicode but sometimes i can't find some material's data or to be Zeros. did any one here know a way to do that?? vijeo citect 7.4 thank you
  6. Modbus Addressing in Weintek HMI

    Modbus addressing in Weintek HMI to poll data from Temperature sensor through RS485. In my system i have connected Temperature sensor to I/O Scanner has output in terms of RS-485 which directly connected to COM3 Port pin. No. 6 (as Negative) & 9 (as Positive) of HMI (Model No: MT8071iE) and HMI connected to PC via ETHERNET. I want to read temp on HMI screen via MODBUS protocol. So, can you please provide me instruction about addressing of MODBUS register in Easy-Builder Software so can read data of corresponding register. Because when i do compile i got an error like " Device no Response". I hope i will get reply from your side as Fast as possible to overcome this problem. Thank you.
  7. Delta eserver problem

    Hi Guys, Im using delta eserver to get data from access and there is an error. How do you solve this? Eserver is installed on windows server 8  
  8. Cimplicity Auto Report Generation

    Dear All, I am having a problem with my cimplicity Auto Report Generation, When I Click on Generate Report, it shows "0 values collected" does anyone knows what's possibly could gone wrong here ??
  9. Hey everyone! New member here, and this site has always been a big help!  I try to help other folks too, but a lot of guys are super quick on here.   I've got a problem using some obscure components. I inherited a sensor network at work that uses Panasonic S-Link and I need to read them from a Q-Series. Panasonic makes a module that slots into the Q Series called an SL-VMEL-Q that I have.   My question is:  Did I do everything correctly on my Mitsubishi side? I put it into the parameters as an intelligent module with 64 points and I put the correct address in for the start I/O. Is that all I have to do?  This is the first time I used a module that wasn't on the drop down list when you add one in GX Works 2.   I can read and write to the buffer memory, but I can't get the unit to send to or receive from the sensors. I think the problem is that there is no end unit on the S-Link line (I don't know if it's just a terminating resistor or what), but it previously worked without one, so I can't be certain.
  10. Dear sir, i want sample program for modbus tcp for q series plc
  11. Hi everyone,  I am trying to use Kepware to communicate with my PLC setup which is the iQ-R Series R08PCPU.  I read the documentation which is available at https://www.kepware.com/getattachment/3daf1ac3-5c76-49ce-bbfe-f0fb1015f6cc/mitsubishi-ethernet-manual.pdf I read through the setup for Kepware and the setup procedure for iQ-R series but it still didn't work.  From the documentation, it said something about "using special ladder logic to enable ethernet communications is required.", I couldn't find anything about this online.  Here what I did in addition to the documentation: - Enabled IP Packet Transfer - Ping the PLC's IP Address which was successful Does anyone have any idea what I didn't do to establish that communication between Kepware and R08PCPU?  Thank you in advance. 
  12. Mitsubishi GX Developer

    Hello all ... i am a new plc user.. i am using D500 for taking value as it is a latched register.  i am taking value for a flow meter. i have two questions. 1. how totalizer is calculated from flow rate as my flow rate is in m3/h. 2. the value of register is gone upto 32000 approximately... i want that this value to go on.. i mean how 32 bit register is declared in plc .. a
  13. Please assist me with the following; regarding the ME96SSHA-MB Power meter data transition with Melsec-Q series PLC; We acquire to read various values on dedicated Modbus storage address registers at the simultaneous into a Melsec-Q series PLC via Modbus (TCP or RTU)  for calculation purposes. Naturally, since the reading of these variables are to provide accurate instantaneous results, it is a requirement that these values are to be read at one scan.   However, as can be seen below, there is a gap in address register range – of which, if all of these are scanned simultaneously, yields an exception error when read. This error is only avoided by scanning these data sets separately – which is not ideal for our application – since accuracy in calculations is imperative.
  14. Please assist me with the following; regarding the ME96SSHA-MB Power meter data transition with Melsec-Q series PLC; We acquire to read various values on dedicated Modbus storage address registers at the simultaneous into a Melsec-Q series PLC via Modbus (TCP or RTU)  for calculation purposes. Naturally, since the reading of these variables are to provide accurate instantaneous results, it is a requirement that these values are to be read at one scan.   However, as can be seen below, there is a gap in address register range – of which, if all of these are scanned simultaneously, yields an exception error when read. This error is only avoided by scanning these data sets separately – which is not ideal for our application – since accuracy in calculations is imperative.
  15. Mitsubishi GX Works Bugs??

    Hello I have been using GX Works 3 for a while now and I have discovered a couple of things, maybe bugs. I have not had any training for the software or hardware so maybe I did something wrong. 1 Labels. If you sort a global label table into any order other than the unsorted order that appears by default you are unable to create, delete or edit any labels. Our Mitsubishi representative discovered that if you click on the column header between 'Data Type' and 'Class' the order does not change but now editing is available. This, it turns out is a really bad idea. It seems the position the label was in when it was created is preserved, I think this is the unsorted order you get by default. If you sort the list and then delete a label it is possible that the label that should be in that position is also deleted. I have attached a small project to demonstrate this. Open the Global Labels notice the order they were created. Now change the sort order, click on the column header I described earlier to make them editable and then delete the label in position 1. For a while I thought this was the only problem but recently there has been a number of instances where I have created a label, given it a carefully selected address only to discover that it is being overwritten by another variable. I have not been able to work out exactly what is going on but I believe it is connected to the sort order of the labels. Also if you sort the order and change an address, have you changed the address of another label? The only solution I have found is to keep label tables very short so they are managable without having to sort the order, that is probably good practice anyway 1 Axis software limits. I have been using a number of axes in pairs, in incremental mode as caterpillar feeders, using FX5U-40SSC simple motion modules. I had a problem that the axis synchronised to follow would suddenly stop moving, the customer was having to power down the machine and start again. This problem persisted for months with Mitsubishi scratching their heads unable to fathom it out and ultimately stating that the problem must be in my code somewhere. It was suggested by the customer that it may be getting to a software limit, I showed the customer that the software limit was disabled in the setup and it was confirmed by Mitsubishi that it was not the problem. guess what, it is a problem. Once the actual position reached the limit of the double word memory it would stop moving. The solution is the take the servos out of synchronisation in order to set the position (datum) to zero every cycle. Unfortunately the drives do not always re-synch on the first attempt so you have to keep trying till it does, this now causes slight variations in cycle times but it works. Andy EDIT: I have since been informed that to disable the software limits they must be set to zero. This implies that the Enable/Disable setting is invalid and the limits are defaulted to their respective max values. Surely a default to zero would be more appropriate.     Label Test.gx3
  16. Fuji Wsz plc

    Please send Fuji Wsz plc software download link  
  17. There have been many good discussions on the applicability of cloud-based solutions for manufacturing and process control systems. On one side, some people have concerns regarding security and control of the information, on the other side, there are identified benefits enabled by cloud systems. From VMS minicomputers to DOS and Windows, from ArcNet to Ethernet, it is inevitable the industrial automation systems shall adopt the technologies that are getting predominant in IT general use; the current environment that I am calling the “Cloud-iPad era” is no different; therefore the practical discussion is not if those new technologies will be applied in the industrial environment, but how. This paper is not intended to join the conceptual discussion about the cloud, but just to present a few simple practical examples, where cloud technologies are already enhancing industrial automation solutions and enabling new business opportunities. CloudPracticalApplications.pdf
  18. Was wondering if anyone can tell me whether it is possible to use the Red Lion Graphite displays to remotely log into your system via Ethernet for programming.  Can it be used as a bridge to other Ethernet devices connected to it?
  19. CP1L connected with scanner symbol DS-4308 reading 2D data matrix,  with RS-232 on board CP1W-CIF01 Hi all, need some help because I can't read the information. Let me explain, I have a PLC, " CP1L-L14DR-D " with a RS-232 option borad " CP1W-CIF01 " , a scanner Symbol DS-4308, and I'm trying to read a data matrix 2d barcode (I don't know if that matters). so I build a cable with the next configuration, (one side male and the other female) PORT CONFIG PIN OUT SCANNER CABLE RJ-50 TO RS-232 PINOUT Maybe I'm missing a connection? a bridge? power supply ? ground?   in the program, I only have this to check the communication,       When my reception flag complete (A392.06), my instruction RXD is going to execcute, reading in D1500 the data. if is any error in communication (A392.04) or overflow (A392.07), my port is going to restart (A526.00) (ignore w0.03) with the followign config: (9600, 7,2,E, RS-232C, End code: Received Bytes 3       and I'm reading only, data on D1500 and D1501, and the data makes no sense.   with the configuration of End Code: CR, LF,          can't make it work, I read nothing. and if I change the END CODE: Received bytes to 4,      don't work. and my flag A392.04 go to ON.   PLC HAS 4 PIN SWITCH, ALL ARE OFF The configuration on the scanner is setting to default and then config to RS-232 Standard.   So, what I'm missing?  bad connections? plc don't support? scanner config? program?      
  20. Hello All, What are the methods to get the monitoring data from A series PLC? I know its not supported any more, interface modules are not available...,    So the basically,   If I want to write customer software (may be embedded) what is the protocol I need to follow? I am connected to CPU unit by the way, there is no other modules except few digital and analog interfaces on PLC. Thank you in advance for your direction, direction in any way would help!
  21. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  22. Cable pin configuration required.

    Required cable PIN configuration for Nexgen 1000 series PLC, MS-40M-E, NT11-SF121B-EV1 , GT1020-LBD.  
  23. Hello everyone, I am working with a NB10W HMI connected to a PLC NJ by Ethernet protocol, I would like to know where to start regarding the sending of data from the PLC to the HMI. I have a 50x15 array and should show all those values in the HMI for read / write. How to proceed? I started working with PLC for a while. I'm using Sysmac Studio to programm the PLC and NB designer to the HMI.
  24. Hello everyone, I need the help to do setting of datalink between CJ2 and LOGIX-5324ER. The Allen bradley PLC was programmed by contractor and I have no software of it, so I am doing the network setting in CX-one network configurator. I tried to do the instruction in the Quick Start Guides on Downloads section here under Omron, but I couldn't find the option to register tags in network configurator. Is there anything wrong here? or is it possibly because of that they not support to do a datalink in these version of PLCs? They appeared like these in the pictures.
  25. GX Works2 Q Series TCP issues

    Hey guys, been looking around for a solution and I was brought here.  I'm a programmer at a place that just put in a bunch of these Mitsubishi Q series QJ71e71-100 ethernet controllers.  I wrote a TCP server in Java to try and talk to them.  I'm trying to get data sent over from a little GOT1000 test terminal.  The zp.open command is working fine and i'm seeing a good syn-ack handshake, and if i push some text to the plc from the program I get a response (even if it is always the same nonsense).  but when i try to use the zp.send it fails, I get error C1A6 on the ladder program and the q series lights up the comm error light.  I know I'm being super vague here, I was just hoping to gain some insight.  I don't much know what to expect from this forum if you guys are active or if my question even has an answer but i've been banging my head against the wall for days now.  I'm just using a tutorial program from the q series manual and a super basic tcp handler in java.  If there's any other information I can provide let me know.