Search the Community

Showing results for tags 'relay communication'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 124 results

  1. I am trying to get the communication going between EZ3 EZAutomation Panel HMI and Omron NJ501-1300 PLC. I am currently using Modbus TCP/IP as a protocol. Has anybody figured out a way to do that? Or is there a better way to do this communication between HMI and PLC ? Right now I am using MTCP_Client_Connect function block to connect with HMI but it dont seem to be working. The IP address is correct along with Port no. I am still fuzzy about the Station address of NJ and the function code of the NJ for Modbus purposes. If anybody could help me out I would really appreciate it.
  2. Hello everyone, I have difficulty to setting up the GSM configuration or the serial RTU configuration so that I allow you with another RTU. I use Schneider CPU Modicon M340 in conjunction with RTU communication NOR0200H and a Modem Schneider SR02 MOD02. This is the first time I'm working on this kind of project, want to help me, I'm stuck and I need a solution, thank you for your time.  
  3. Hi guys. I have 1 cj2m cpu33 reciving 3bits of info from 3 other plcs (all similar type cj2m cpu 34-33) The problem is that 2 bits are ariving the third one is not. See the pictures i uploaded:   I do not know these instructions, in the other cases it was working. However i noticed that the output plc had a different adress with D950. I changed the adress to D804 as you can see on the pictures but still not reciving the data.  I guess i will have to configure somwhere else also. All i found (https://www.myomron.com/index.php?action=kb&article=1416) on internet that i have to open this datalink tool from the integrator. When i actually do that of course i just get an error: FATAL Error. Cannot read the file.   How can i make this work? Is the other way to constantly send this one bit with ethernet? Any sollutions, advices are welcome!
  4. S7-1500 FW v 2 / Profinet issues non-Siemens devices

    Hello: Has any body encountered Profinet IO cyclic communication establishment problems between the latest S7-1500 PLC with firmware 2.0 or later and non-Siemens Profinet devices which had previously passed conformance testing campaigns? Thanks for your comments.    
  5. Has anybody tried communicating Allen Bradley 5069 Compact logix PLC with Red Lion HMI ?  I am unable to communicate them in spite of adding AB tags via L5K file which gives me no error. I am able to see all the tags in Crimsion 3.0 software in development mode.  However, PLC & HMI are not communicating with each other. I am able to ping to both, using the same program in PLC of which I generated L5K file.  I think it may have something to do with the driver as 5069 is a new line of PLC Rockwell come out with only in 2016.   
  6. Socket communication with Micro820

    Hi everyone ! I have a little project wich involves communication between two Micro820 controllers via TCP/IP. To do that, I started to work with TCP/IP socket. Within CCW (Connected Components Workbench), I tried to create a new socket instance using the instruction SOCKET_CREATE and set the socket address to 127.0.0.1:21. Basically, my computer through the FTP port. The problem was that it couldn't create a new socket instance (error variable is set to TRUE and status is set to 4, wich I don't know the meaning) because I didn't have a server-side application that listens to TCP/IP socket requests. That said, I found an open source application called SocketTest that listens for TCP/IP socket requests on a specified IP address and port. So, I started a listener on the following address : 127.0.0.1:21, but the error variable is still set to TRUE and status is still set to 4. So, my questions are : Is my IP address OK ? Is my port number OK ? What means the status code 4 ? Is SocketTest doing what I think it does ? Do I need to do something else before using the SOCKET_CREATE instruction ? Thank you in advance for your help !
  7. Serial communication of Micro830

    hello everyone, I'm trying to connect PC with Micro830 with RS232 cable for transfer serial data. However, the PLC can not receive the character from PC. I used ARD function block to read the characters from PC.  there is no error and the output of ARD function block is 0 when I debug ladder programme. the serial communication state LED illuminated once I send a character from PC to PLC. the channel of input is 2 which is the embedded serial port. I use an adapter from USB to RS232. Email: jeremietang531@gmail.com      
  8. Good day  I require some assistance with the configuration setup (GX Works 3) for FX5u PLC inter-communication (PLC to PLC), over Ethernet (using the built-in Ethernet port). The purpose of the inter-connection is data exchange. (Values stored within the PLC storage registers such as words and bits).  Does anyone perhaps support files on this such as a procedure or example? Thanks
  9. Hello,    I have a Cognex insight 5100 camera connected to Allen Bradley L62 processor. The is working fine since the last year but sometimes the I/O module faults out with error code 16#0022. I looked online it look it needed a Ethernet cable change ( I did that but no results).  Then I looked at the firmware in the I/O module and firmware in the camera and I found a difference. The firmware in the camera is 4.06 and the firmware of I/O module in the PLC is 4.005. Can anyone help me resolve the communication issue ? I want to know how to downgrade the camera firmware or change the revision in the PLC ( which I cannot )    Thanks in Advance 
  10. Hello,    I have a Cognex insight 5100 camera connected to Allen Bradley L62 processor. The is working fine since the last year but sometimes the I/O module faults out with error code 16#0022. I looked online it look it needed a Ethernet cable change ( I did that but no results).  Then I looked at the firmware in the I/O module and firmware in the camera and I found a difference. The firmware in the camera is 4.06 and the firmware of I/O module in the PLC is 4.005. Can anyone help me resolve the communication issue ? I want to know how to downgrade the camera firmware or change the revision in the PLC ( which I cannot )    Thanks in Advance 
  11. Good afternoon fellow members,I once again ask for your help to know if any of you have struggled with similar issues. For the past year and a half, Every 1-2 months we seem to be losing communication with one of our PLC's/racks. We have in the rack a 1756-EN2T card (revision 3.006) that will flash as if it is communicating and status OK (green LED), yet we will be unable to ping it and our operator interfaces go into error. We could also not open the web browser page of the EN2T card, nor connect to the PLC/rack through RSLogix5000. As this happened over the weekend, the local electrician was called and he tried cycling power to the rack and there was no change after it came back on (not sure how long he left power off to the rack though). The problem seemed to be fixed after we told him to pull the EN2T card out of its slot and then re-insert it.We verified the CIP cinnections for this card and it is around 98 to 101 CIP connections out of a max of 248, so not too high. the card's CPU usage is 24-29%, so no indication of problems there. EN2T Card is set to auto-negociate, just like all the other cards we use at all of our plants. Has anyone ever experienced a similar problem?Thank you in advance for all your help and knowledge-sharing!
  12. Hi, I have the following configuration where 4 PLC panels, with each having a Q12PH CPU and QJ71E71-100 module. All these QJ71E71-100 are connected to a HUB using straight cable. From the HUB one connection is going to an I-Fix SCADA which is already communicating with all 4 PLCs using MC protocol. I want to send data from 3 of this PLCs to the 4th PLC in the same network using fixed buffer communication. Can anyone provide a sample program for the same. Send and Receive side. I am using GX Works 2 for programming. Your help is very much appreciated.
  13. delta hmi communication speed

    Hello, i have DOP-07s411 delta hmi and i want to interface it with microcontroller using modbus (RTU) protocol over RS485( 8 bit data,1 stop bit, parity none,19200 baud rate). i have good speed of communication if i do not use macros. But as i place background macro(background macro is only 4 lines ) it slow down and  updates the display at every 3 seconds. i cant able to figure out what is the problem. I want to update display of  HMI very fast.Please help me to troubleshoot the problem.
  14. Hi,  I'm trying to test the serial communications with my Micro820. I acquired a 2080-SERIALISOL so I could have "someone" to talk to. I want to use RS485, so I figured that I'd have to connect: Modbus pin 1 (D+) to serialisol pin A1 (+485) Modbus pin 2 (D-) to serialisol pin B4 (-485) Modbus pin 3 (GND) to serialisol pin A2 (GND) Now when it comes to CCW, the thing gets a little harder. I know I need to use the MSG_MODBUS block (in fact I need 2, one for the modbus and another one for the serialisol), and I guess I specify the interface I'm using on the TargetCfg field (data type MODBUSTARPARA). But how do I figure out that the Addr (UDINT) and Node (USINT) values are for my Modbus and Serialisol? Or am I doing it wrong? Does anybody know of any place where I can get some more guidance or even a funcional ladder program? Thank you in advance
  15. Mitsubishi communication error

    Dear all,   I have Mitsubishi FX1S Series PLC while i am downloading program , i am not able to do it and i am getting error. please find attached image and please help me to solve it.
  16. Hello,  I am a newbie to the Omron world. We have a new machine come in made on Omron PLC, we are trying to get it connected to our OPC server so that the server can read and write tags via ther Ethernet/IP protocol. We have given out ethernet card 10.14.9.187 IP and the NJ501-1300 controller is on 192.168.250.1. But still our OPC server cannot see the tags/variables. I dunno if we have to add the ethernet communication card to the network configurator and add the tag sets ?  We are also getting a tag resolution error on sysmac studio while being online.    Thanks Pratik 
  17. L3 Serial Communication

    Hello,   I am looking for examples on using serial communication with a WMS inside Studio 5000.  Sample programs would be ideal. And I would like to get some information on what blocks need to be used. e.g. Send, and Receive   Thanks!
  18. Master/Slave Communication

    Hello guys, I am using Fatek PLC's to communicate with each other as a Master & Slave through zigbee which is connected through RS485. And I succeed. But the issue is that I have to communicate each other at a distance of about 2km where zigbee out of range to each other. I am bit confused here; 1) whether I use RF booster? Does it work? 2) Should I introduce extra PLC as a repeater between master slave? But this(extra added) PLC repeater also become as a master(Master Repeater).or any idea? Most important I can using Fatek Protocol or Modbus RTU or Modbus ASCII prootcol.
  19. Hi All, We have an old machine using a Mitsubishi Fxo-30MR/ES and I will be replacing the PLC with a FX3S-30MR/ES.  This old machine would power some led's on a panel mounted PCB using the PLC outputs.  The 24V from the PLC output would go to the PCB board where a resistor would drop the voltage for the LED.   This PCB is damaged I would like to avoid getting a new PCB made and instead power some panel mounted LED rated for 24V directly form the PLC output.  I guess these panel mounted LED have a built-in resistor.  Power consumption for the LEDs are 20mA at 24V volts.  The 24V power supply has plenty of capacity for this. Are there any issues with doing this? I have attached the spec sheet for the panel mounted LED (I will be using the 24V versions).   Panel Mounted LED.pdf
  20. FX3U For GXworks2 and WinCC Flex

    Hi, Is there any way in order to monitor both PLC(GXworks2) and HMI(WinCCFlex) using only 1 port from the PLC(FX3U)? I have tried it but I'm not able to communicate the other application(one at a time only).   Thanks!
  21. S7-300

    Has anyone ever use a Allen Bradley 9300-ENA card with a Siemens S7-300?
  22. Hello, I am currently installing a PLC control panel and due to space constraints, we will need to install the Panelview 600 HMI separate from the Micrologix. We purchased a 50ft Allen Bradley communication cable, but 50ft will not be long enough. We have about 70 to 75ft of conduit between the panel and the HMI. I would like to know what options we have for this connection. I read that for serial connection, we shouldn't go past 50ft. I understand the Micrologix 1100 has an ethernet connection and the Panelview does as well, but I'm not sure what changes would be needed in order to communicate through the ethernet port, instead of the RS-232 port. Any suggestions will be greatly appreciated.   Thanks, JCG
  23. GE PLC PCM

    The topic is based on "How to configure a PCM module in GE PLC". One new query in PCM. To configure this PCM Module some procedure is to be followed in CMD prompt. Initially once ''READY'' line displayed. Query to this topic is if ''READY'' line repeats below persistently in CMD prompt, then solution is ______???? 
  24. Hi again I browse through half a dozen mitsubishi manuals but turn up nothing for mitsubishi plc cross-communication. In this project there are about six L-06 plc:s. All are on the same ethernet network already, communicating nicely with the SCADA system. Per today information is (temporarily) exchanged via the SCADA system. Here is another hole in my knowledge. Namely how to correctly setup communication between these plc:s. I plan to continuosly exchange some 50 bytes of information. I would be grateful for some pointers and/or perhaps a reference to a manual. Cheers to all of you //
  25. PLC won't connect with PC

    Dear sir, My problem is I connected with PLC with cable and uploaded the program and it's working nice, but when I removed my cable and connected the monitor panel it have communication error, I connect my PC again it won't see the PLC, the PLC functions I/O is work but I can't connect with PC or monitor panel.  So if their any reset for communication port or the port is damage?