Search the Community

Showing results for tags 'pressure sensor'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 13 results

  1. Hi Everyone..I'm having hard time to read Analog Sensor. I've try to read the manuals about expansion module, but still having hard time to understand it. My PLC is CP1E-N30DR-A connect with Expansion CP1W-MAD44 and I'm trying to connect with pressure sensor Omron E8F2-B10C that in a certain pressure will trigger to open a Digital Valve. is there something wrong with my setting for range? I do the setting in 4-20mA (0-5V) I attached my Program and Picture while running, the program is only for reading the pressure sensor. the result is  -600 to +600, is there a way to earn the actual result? I've tried Scaling and APR, But didn't understand, is there a guide/tutorial for it as well?   Cheers.. Albert TEST.cxp TEST.cxp
  2. Hi guys....first post here. It's been about 6 years since I worked heavily with PLC's and automation, but I'm getting back into it. I was hoping you might be able to help me with an issue I've noticed at work.  Problem:  The sensor we use just reads if there's something there, or not. A make or break if you will. When boxes are pushed together and there is no gap between them it thinks there's a jam (after 6 seconds) even when the boxes are moving past (as they should).  A jam stops the conveyor belt requiring someone to physically move the boxes to clear the sensor and restart the equipment.   I'm trying to find a sensor that will see the distance changes from box to box (mounted on the side of the conveyor). Only when there is a true jam and the distance isn't changing will it send a jam signal.  I've tried researching sensors and have been overwhelmed by the endless possibilities and combinations (not all of which I understand).  We are currently using an Allen-Bradley 42EF-P2RJB-A2H It would be ideal to have a similar style plug, but it isn't a deal breaker.  Here's an idea of what I'm dealing with. (The actual conveyor the jams are occurring on is a decline belt, not a roller accumulator.) There are varying box sixes, but they are all packed together. Creating a gap between boxes or using metering belt is not an option here. Thank you for any help/guidance you can offer! -Steve
  3. Hi,  I'm new to TwinCAT 2 and i'm upgrading a long time design (hence the TwinCAT 2 reference), to read a more sensitive torque signal.  I'm using a Beckhoff CX1030 as my PLC Controller.  I needed to add 'homing' to my motor sequence and confirmed with Maxon, im using the function blocks correctly and in the correct sequence to establish my 'absolute zero'/'home' position.  The motor has an output to write to:  ControlWord, which tells the motor that the position it is sitting in is '0.'  My program compiles, it runs, it writes each function block, but it's not seeming to get back to the test run opMode, even though i tell it to and the function block performs the 'Write' function.  it's stuck at zero and not reading an analog input signal from my torque sensor.  so im getting an artificial torque reading through every test.   i think this is related to my tare motion.  I start the program, home the motor, get into profile velocity mode, tare my sensor, enter profile position mode, go back to position 0, then back to profile velocity mode, run a test, sample data, go back to 'home' or '0.'  I wonder 1st, is my variable not linked properly through the system manager?  2nd, i set a boolean variable to set the 4th bit to 1 in my control word write (setting the 4th bit high will set my current position to absolute zero), but did i not connect the program to the main sequence properly?  looking to read a valid signal again and see that my motor moves back to 'home' each time.  Do i not need to home the motor after the tare, since the tare nulls out the torque value after the tare? after this i need to program my sample period, instead of it being fixed, as it is currently written and then use my home position as my trigger to start sampling.... Beckhoff applications department is overloaded, currently and can't help and this is all beyond the knowledge of the general support line.  I've gotten fairly far, on my own, but of course, the project is under a time crunch.   Does anyone know twincat well enough to help guide me?
  4. SMC pressure sensor

    Hi! Allen bradley PLC RS Logix 5000 I have a problem with a SMC pressure sensor (ISE30A if I remember correctly). When I monitoring the raw data from the ananlog module, I get about -7710 value, when the smc display shows about 0. There are another SMC pressure sensors too, and if the sensors displays shows 0 then the values what I get form the analog module is about 0 too, so the others work properly. But this one don't.  I already check the wiring. I have no clue waths the problem. Any idea from anybody? Thank you for your help.
  5. PID regulation PT

    Hello   Does someone have a good way to control pressure using PID in cx-programmer? I got two pumps and one PT(4-20mA) Half the year only one pump need`s to run (about 3bar)  but in the season (i work in a fabric) two pumps need to be running (about 4bar needed) except in the night. I`m going to use HMI for adjusting the setpoint so there is no need for any clock/date for this to change itself. The question is how to get one of the pumps to shut down when the need for pressure is not so high. And get the pumps to change "main" pump sometimes so one pump is not running all the time.   Hope this was understandable    
  6. Actuator Sensor Interface

    I first saw AS-i at a factory this week and am trying to figure out what Allen Bradley modules can interface it. I am not finding anything, does AS-I go under some different name?
  7. Hello! Does anyone have experience of using tooth gear pulse sensors. I am looking for this kind of sensor for the machine, we are building. My problem is that the sensor we are using is not suitable for North American markets (UL-standard is not aproved) and now I am searching sensor like this. I am not sure is inductive sensors good enough for measuring this, the one that we have been using is magnetic field pulse sensor.
  8. I'm looking for some general information about different types of vibration/temperature sensors. What type, brand, model number, etc. will best fit my application.  Scenario: I want to monitor the vibration and temperature of multiple motors and gearboxes for a large overhead conveyor system. If an oil leak occurs and temperature increases, I want to see a temp. alert via a HMI. If a something mechanical fails, I want to see a vibration alert via a HMI.  I've looked into sensors that stick to the outside housing of the motors or gearboxes via a magnet. My concern is justifying the temperature readings. How accurate would a sensor that reads an "ambient" temperature be (compared to a thermocouple on the motor coil itself or some sort of probe)? Also, would the location of the magnet  on the motor or gearbox drastically affect the temp. or vib. readings? Has anyone had success with a similar setup? If so, what devices did you utilize? Are these systems truly beneficial?  I'm currently considering Banner's wireless products...
  9. Hi, Recently, we replaced our old digital temperature transmitter with a Baumer Flextop 2201 digital temp transmitter. The application of the digital temp transmitter is for a hydraulic press and the output is fed to the Siemens S95-U plc. The Flextop was able to react properly promptly when there is increase in temperature but whenever there are sudden drops in temperature it is slow to react. The analog transmitter (dial) was already at 25 C when the hydraulic press was shut down while the Flextop was still at 35 C. We used a three wire configuration for this. Does this have to do with our wire configuration? I know there are 2 wire ,3 wire, and 4 wire configurations for 4-20 ma sensors but I'm not sure what are their differences among them. Please see attached configurations below.     Thanks,
  10. Version 1.0.0

    77 downloads

    Temperature measurement usind Arduino Nano, RTD PT100 sensor,  4-20 mA current loop transmiter, and a python app for visualization
  11. View File Temperature measurement using Arduino Nano, RTD PT100 temperature sensor and 4-20 mA transmitter Temperature measurement usind Arduino Nano, RTD PT100 sensor,  4-20 mA current loop transmiter, and a python app for visualization Submitter Absolutelyautomation Submitted 04/01/16 Category Other PLC Demo Software
  12. Hello, I am new to this forum and I am looking for some help. I have to create a block mover system using the controllogix , I know that I must use a SQO as I have done this process without a Flex I/O on a SLC 500 before. Currently I am getting a error while dealing with the array can anyone show me an example of a SQO in 5000?   Thanks
  13. CP1E-N40 + CP1W-TS102

    Hi ! I have a question regarding the handling of the signal from the TS102 connected to my PLC.   I downloaded a .pdf  LINKED from "my omron", read it and put together a small program just to test the expansion unit and sensors. But I cant get any readings from the sensors and can't figure out why. I have never used a TS102 expansion unit before and would be glad if someone have an idea of what I'm doing wrong. Everything is brand new, so I'm quite sure I am the problem here..... If someone have an answer and maybe even an programming example to upload I would really appreciate it. Best Regards!  PT100 sensor test 3.cxp