Search the Community

Showing results for tags 'powerflex'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 12 results

  1. Hello,  I got Allen-Bradley  1769-L36ERMS, AB Powerflex 755 and 20-750-S3 safety card.  According to: https://rockwellautomation.custhelp.com/app/answers/detail/a_id/946912 „"There is NO Integrated Motion / CIP Motion support with 20-750-S3 safety card” so I want to run hardwired emergency shutdown system.  How can I configure this module with safety card in PLC?
  2. Communication error

    Hey Guys,    This is my first time on a forum like this! but i need a hand with something if someone could point me in the right direction.   I have a Powerflex 40 drive communicating over Ethernet/IP to a switch, That drive has four Powerflex 4's connected to it thru DSI connection. They seemed to be wired correctly and seem to be sound connections but when someone on the production hits an E-Stop it removes power from this bank of drives. (Which is standard here) . However, when they power back up i get an F081 Error (Comms lost) on the master drive and one slave. Also, the port light on the 20-comm-e(Powerflex 40) is faintly flashing about every 5 seconds and is the only light on. In this state, none of them communicate. However, when i unplug the DSI cable, the 20-comm-e powers back up to normal operation. I then plug the DSI back in and everything works fine.  Should i start replacing parts or is there some parameters/other wiring i could check?   Thanks guys.
  3. I have G310 and need to communicate with a AB PowerFlex 753 via Ethernet (20-COMM-E). I have tinkered with the Allen-Bradley drivers, which appear to be a MSG function, with no success. Has anyone done this?
  4. PowerFlex 4m

    hey people, I recently buy powerflex 4m, i need a some help, i wanted to autorun when power up it, i had set the a433 parameter to 1, but it still not autostart when power up.  Should I set the A451 [Auto Rstrt Tries] to 1 or....? I really need it to better work, if anyone can help me please. thank you
  5. Just wondering if I need to set up two Motion Groups to specify the direction of travel along 1 AXIS? (Forward and Reverse) If not, how do I specify direction when using motion instructions (specifically MAM) with incremental motion. 
  6. Hello All! This is my first post so please give my descriptions some lee-way please:P I am having trouble finding a solid example of ladder logic which integrates a: PowerFlex (755 in this case) Rotary Incrematal Encode ( or any encoder for that matter) A Prox to reset the resolution at specific points along the axis Also, can I use the standard Motion Instructions (MAJ,MAS,MAM etc) to control the movement sequences of the PowerFlex or are they only meant for use with Servos? I am working on automating a Lumber Treatment Process. The movements will have to move tens of thousands of pounds.. Therefore I would like to use the PowerFlex as a Torque Limiter to control a 15HP squirrel cage motor on a massive gear reduction. I have the distances and pulses per distance traveled from the mechanical engineering guys.. I'm just having problems integrating! After using the Setup Wizard for PowerFlex how can I go about actually inserting movement instructions for the drive into my ladder logic? Some more info on different movement profiles.. I've also included my attempt at trying to piece this together thus far.. Any input would be welcome! (StellaPLC) https://sites.google.com/site/lyncedrgb/eva/rslogix The actual drive and PLC are not available to be me at this time.. could this be an issue while trying to write this motion control program? (obviously not testing & troubleshooting portion) Tugger Speeds Freq. ACCEL TIME DECEL Time E-Stop Decel Torque % of max Notes   VERY SLOW 15HZ 0.5s 0.5s 0s 100     SLOW 30HZ 1s 1s 0s 100 Restricted to slow speed within 3m of ends of transfer deck   HAUL 60HZ 5s 5s 2.5S 100 Max torque limit 250% of FLA   EMPTY TRAVEL 120HZ 2s 0.5S 2.5S 30 Torque Limited to 25%  
  7. Hello world, how was your day?, hope would be fine: Here's my issue: I got a boiler, controlled by a "Compact logix L43" the protocol used is ethernet IP, There are four (4) Power flex 400 installed, Catalog number: ( 22C-D022N103 ) with the Ethernet/IP adapter "22COMM-UM-E",  then, one of them was having hardware problems with the Communication, but NOT THE ADAPTER (22COMM-UM-E), because I did test it in another drive, and actually works fine, the problem is in the drive. After checking parameters and connections, we decide to replace the drive for a POWER FLEX 525 with built in Ethernet/IP hardware. Here's my question:  Do I need to modify the PLC programm to connect the new drive WITHOUT ADAPTER or just I need to set the old powerflex 400 IP address and subnet mask to my new POWER FLEX 525?. In fact, my real question is: Are the registers that the PLC it's actually writing/reading to/from the drivers with the adapter, the same as for the POWER FLEX 525 with built in Ethernet/IP connection?. Hope this information could help you to help me :). Have a NICE DAY!.  
  8. PF 525 "Pos Redefine"

    Hi Everyone, I have a PowerFlex 525, in Velocity Mode with a Encoder Card "25-ENC-1". We are controlling this drive via TCP/IP with a 1769-L32. Through the PLC if I try to toggle the Bit for "Pos Redefine" in A560 [Enh Control Word] it instantly turns back to 0. But through the Parameter List Editor I am able to toggle A560. For My function I need to have the drive in Velocity Mode, If I change the drive to Position Mode I am able to toggle "Pos Redefine"   Any Thoughts would be great      
  9. Hello. I have a 1756-L72S with a 1756-EN2T and an ethernet network of point I/O and three Powerflex 755's.  I'm having trouble with the Powerflex 755.  Only one of them shows up as "running" status, the other two have this status in the status field of RSLogix/Designer.   All 3 drives are the same, and as far as I know, they have the same setup.  On all three drives, I physically entered the IP address on the HIM module.  Then I added the three drives to the Ethernet device tree in the same way (with the exception of different IP addresses of course).  I can ping all 3 drives. The only thing I can think to mention is that the all three drives have firmware version 12.001, and the PLC (v20.13) only has firmware version 9 selection for the 755 drives.  I'm surprised even one of them showed up as connected, so that's a little strange to me.  I would've thought with electronic keying set to "compatible" I would need to down grade the drive firmware.  But in any case, one of the drives seem to be running status, so I didn't think this version mismatch would cause the error I'm seeing.      
  10. emergency stop of powerflex 755

    Dear all, i would like to stop my system in emergency case, it should be stop immediately. my drive is power flex 755 and communicate with PLC control logix via ethernet (port 13). So in control word from PLC to drive, i see a bit is "current limit stop". what does it mean, what kind of stop? can i use it to stop my system (moving item is too heavy, near 200kg)? Thanks in advance,
  11. Good day, I´m helping with small project and currently i am stuck because of this problem. And I hope you can help me out. I´m using PowerFlex 525 connected with AB CompactLogix 1769-33ER PLC via EtherNet/IP. Connection is working, I can read and write values from/to 525. To configure both devices i´m using RSLogix 5000. 1) First problem occurs after I loaded configuration to 525 and it´s, that 525 keeps overwriting values of Accel and Decel Time 1. It happens when i directly change parameters in Module Properties (online) or after I upload configuration to device. It happens even if i set parameters directly to 525 with its HMI panel. - I kinda get around this problem when i use Accel/Decel Time 2 for Step logic, but if i send direct reference value motor still jump to it and that is not good, especially when changing direction of rotation. 2) Second problem is that I cant get Speed Sources and Start References right. Usually Is working only option 1 and others are not, or they are doing something else that they should. For better imagination this is what i want to do: I have 3-state switch (left = 1 ON(DigIn TrmBlk 02), 2 OFF; center = 1 OFF, 2 OFF; right = 1 OFF, 2 ON(DigIn TrmBlk 03)), In center position I want to control 525 with EtherNet (already working when: Start 1 AND Speed 1 = EtherNet/IP). In left position I want to control motor directly with Drive Pot and In left position a want to start Step Logic (which i have already set) - Funny thing, If I set Start 1 = Ethernet, Speed 1 = Step, Start 2,3 = DigIn, Speed 2,3 = Drive Pot then in all three position motor goes in Step logic.. Or when i get left and right position working then Ethernet is blocked.. and this kind of things.. I Attach print-screen of my current settings, if you need something more just, tell me. Thank you for your time, and I hope someone will be able to help me.
  12. Hello everybody, I am connecting my DCS digital output (115VAC) to AB PowerFlex 753 Digital Input. We are using the 20-750-2262D-2R I/O option in the powerflex which is 115VAC I/O with 2 Analog In, 2 Analog Out, 6 Digital In and 2 Relay Outputs. My question is, what is the current or power consumption of the PowerFlex DIs at 115VAC. I need to specify the right fuse size for my digital output. Thanks,