Search the Community

Showing results for tags 'omron cj2m vb javascript fins ethernet/ip'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 340 results

  1. Mad42 analog setup

    I am trying to setup a MAD42 analog card up in a cpu33 omron controller.   I need input 1&2 setup for 0 to 10 volt and can't get it to work. Any help is appreciated. 
  2. Hello everyone! Briefly introduction, I would like to communicate and test the following hardwares: 1- Omron CP1E (using an Option Port CP1W-CIF11) ; and 2- Arduino Nano using MAX485 RS485 transceiver. The CP1E will operate in "Modbus-RTU simple master" as illustrated in image 01. The arduino will be in slave mode address 1 and the library used is "SimpleModbus NG" ( https://github.com/angeloc/simplemodbusng/tree/master/SimpleModbusSlave ). Taking the sample in official manual ( https://industrial.omron.eu/en/services-support/technical-tools/downloads#cp1e ) , pages 248-253 in the "CP1E CPU Unit Software User's Manual" (Image 04) describes a sample communication to an "Inverter Slave". I want to use the Arduino Slave as the Inverter Slave just to be sure that all previous steps are correct. Therefore, I would like to know: 1- As illustrated in Image 02, Am I missing any resistors? 2- Should I connect the GND to the FG? 3- In this scenario, the DIP switch setup should be as illustrated in image 03? Only DIP4 is OFF. 4- Can I test it just forcing A641.00 and checking the DM Area Data, as shown in Image 05? The code used in it is the following: // Wiring: Arduino and MAX485 // RX0 - RO // TX1 - DI // D2 - DE/RE #include "SimpleModbusSlave.h" enum { REGISTER_0, REGISTER_1, REGISTER_2, REGISTER_3, REGISTER_4, REGISTER_5, REGISTER_6, REGISTER_7, REGISTER_8, TOTAL_REGS_SIZE }; unsigned int holdingRegs[TOTAL_REGS_SIZE] = { 0, 1, 2, 3, 4, 5, 6, 7, 8 }; void setup() { modbus_configure(&Serial, 9600, SERIAL_8N1, 1, 2, TOTAL_REGS_SIZE, holdingRegs); } void loop() { modbus_update(); }   Any answer can be helpful. Thank you for your time!   Regards, Jose.  
  3. I have a cpu33 that I had issues with a bad battery and it loaded from memory card.  The version on the card was old so I decided to download the latest version from 2 days ago to it.  When I did, I lost communication through ethernet.   Can't connect through usb either.   The thing that baffles me is that I can ping the plc at the address and I get a reply.   Any help/suggestions would be greatly appreciated as I am not familiar with omron plc's at all.  Also on the display it cycles through Er HE 1P 07.
  4. I using easymodbus library to connect and read data from 3 PLCs CP1L but it run unstablely, sometime it disconnect and i cant re-connect PLC, it give error time out when i try to reconnect when it happen, i restart PLC and everything back to work. Someone please help me. I am new with modbus and omron
  5.  Hi all. I have a question about how to set up the motor in rotary mode. My application will be a basic rotary table driven by a servo motor without gearbox between. So, in my servo drive axis settings, I select the motor as a rotary mode. then I defined the maximum position setting value for 360 degrees, and minimum to 0. So far so good. But the problem comes when I want to make an absolute move using the mc_moveAbsolute to move 360 degrees. Whit this settings the error "target position settings out of range " will come up. So, what is the solution to rotate 360 degrees without generating this error? if I set up the maximum value to 361 degrees and then if I rotate 360 the error will not occur and the motor will rotate 360 degrees as I aspected, but it's this correct ? or there is another way to do it? Thanks  
  6. PC send data to PLC

    Hello, i'm newbie for plc. i want to ask about PC/computer send data to PLC CP1E with serial communication (RS232). my wiring cable is: PC                         PLC 2                             2 3                             3 5                             9 4&6    7&8                               4&5 and if i send data from PC to PLC, my indicator in COMM is blinking. i think the cable have no problem. but if i send data from PC to PLC, the memory is not same as what i send and whatever i send data, the memory didn't change. i will attach my ladder diagram. what should i do?    New folder.rar
  7. Hallo, i want to connect PLC Omron CP1E to indicator weighing scale with modbusRTU connection and i have a CP1W-CIF11 module to connect indicator with CP1E. ,but I have no experience in RTU modbus communication in the PLC. How do i start?   *i just need output: 1. Coil (Reference No = 0. Output bits) for input switch with address 3 (Tare). 2.Input Status (Reference No = 1) for output lamp with address 17 (stable) 3.Input register (Reference No = 3) to read data with address 5 (gross weight) 4. holding register (Reference No = 4) to write comparison data with address 17(over) page 85 - 94 in attachment     ad4402_manual.pdf
  8. Omron Servo Encoder

    Hello All  I am new to PLC programming , i have a question regarding omron PLC and High speed counters. I am using Cp1H-XA model plc . I connected HSC port 0 with a encoder and i was able to get the speed of the encoder using PRV2 instruction. Now i am trying to connect the second  encoder from the servo motor that i am using to HSC port 1. I am getting the PV signal using PRV instruction . Is there a way to calculate the speed of the servo encoder connected the HSC port 1 using PRV command , since i can't use the PRV2 command for the servo encoder .   Thanks in advance .
  9. Graphic Operational Controller

    Please give me the steps how to communicate GOC with Laptop using Ethernet and serial port I have using Codesys for Programming
  10. Hi everyone,  I am trying to use Kepware to communicate with my PLC setup which is the iQ-R Series R08PCPU.  I read the documentation which is available at https://www.kepware.com/getattachment/3daf1ac3-5c76-49ce-bbfe-f0fb1015f6cc/mitsubishi-ethernet-manual.pdf I read through the setup for Kepware and the setup procedure for iQ-R series but it still didn't work.  From the documentation, it said something about "using special ladder logic to enable ethernet communications is required.", I couldn't find anything about this online.  Here what I did in addition to the documentation: - Enabled IP Packet Transfer - Ping the PLC's IP Address which was successful Does anyone have any idea what I didn't do to establish that communication between Kepware and R08PCPU?  Thank you in advance. 
  11. How to set Homing parameter slot with _sHOMING_REF data. Please suggest me to setting MC_HomeWithParameter instruction or show example for using MC_HomeWithParameter instruction. Thank a lot
  12. Hi, I want to sent simply frame using FB mady by JPV from Omron France. It should send just frame  01030FA60002273C  to slave #1 When I check Multiway - it seems that frame is OK, but slave no reply. I checked different soft to monitor serial port and frame looks different - some bytes are sent twice.  I attached   screenshot and you can see the difference - Can you explain why it happened. Both frame I got when I set W30.0 in PLC and I saw just one blink LED Hmm I also attached screenshot from my serail port configuration. I tried also diiferent set of CP1W-CIF11 dip switches, but the same effect. Any clue??? thanks in advance                 
  13. I have a AB CompactLogix L43S with 1768 ENBT Ethernet/IP module. I would like to talk to a TCP/IP device (such as my laptop) from the PLC. How can I do this without using RSLinx? 
  14. I have a line that I'm integrating that requires the main machine (Q13UDVCPU) to communicate via the built in Ethernet port with 3 different up and downstream machines using FX3G controllers with FX3U-ENET modules.    We are using GX Works 2 software. So far I'm having no luck with the Mitsubishi documentation, or online.  Some (old) sources say it is not possible, I hope that is not the case. What I could really use is a working example program to look at and dissect.  But any help would be appreciated.
  15. Greetings everyone. I'm new here. Hoping to get help to operate the Omron V400-R2 barcode to the Mitsubishi QJ71C24N so that they can communicate the two devices with the correct method. PLC: Mitsubishi: Q03UDVCPU; barcode: Omron V400-R2; serial communication module: QJ71C24N. I use RS 232 communication cable, I have tried using predefined protocol and non protocol procedures but still can't communicate the two devices. I really appreciate your help.
  16. Compare data RS232

    Halo, my name is Riandanu, I connect PLC Omron CP1E to weighing scale, and its done. i think i dont have problem between PLC and weighing scale. And i want to ask about, how to compare value from weighing scale ?  example : from the picture you can see value of weighing scale is " ST,+00160.66  g", and i want to compare it with 180 or 150 to give output on to lamp. Thankyou Riandanu       PLC to ek-i.cxp
  17. Design Improvement Ideas : I currently use a 24v DC slipping brake (either Clarke or Warner) to prevent a reel of film from over-rotating - With Previous motion controllers - i have used timers at first then progressed to using a Virtual axis and a switch to make my pulse from NX- Digital output card to a Solid State Relay  (PSWITCH command for anyone familiar with TrioBasic) and this has worked pretty well. I have the same physical setup on a new piece of machinery but am now using NJ and Sysmac - Have used a TOF and TON in inline ST to control brake and it sort off works - brake can feel a bit lumpy and can chatter and bounce a bit adn am worried about the reliability when the machine is running and the controller is doing more. (brake cycle time t#10ms and tried at 100ms also) I did try using the Time Proportional Out FB - but this was far worse than the above. I think i will try my luck at created a new virtual axis e.g. Rotary Mode - min 0 max 1000 Run with MC_Move_Velocity when Machine is running and use an MC_digital Cam Switch to create my output Pulse. I am new to the Forum and trying to get more involved with others rather than working in Isolation - so wondering if anyone has any suggestions or thoughts  or have done anything similar in SS? Thanks in Advance,
  18. Hi, "CJ2M-CPU32 PLC" CX Programmer V: 9.63 I'm working on one of the projects where I'm using DT function for comparing the daily, monthly and yearly water flow. I'm able to get daily totalizer but having difficulty while having totalizer for monthly and yearly basis via using DT function. Can anyone guide how can I link the calendar with DT function subjected that every month is with different numbers i.e. 30,31 and 28/29 days. How can I add exact flow rate into monthly totalizer? note: 1 pulse = 1m3 (I'm not having problem for pulse count etc- its just with monthly & yearly totalizer while using DT function).   Thanks
  19. CP-1E Error

    Hello,  I am using Omron CP-1E PLC and expansion module 16ER and tc module.  When plc operated alone it goes to run mode when expansion module is connected either 16ER or TC module plc ALM/ERR led turned on.  
  20. Anyone know any free libary to communication with FX3u-enet-adp, please help me ? Note: I've used mx Component , it work very well but it is too expensive and I dont even know it can work in windows server 2012/2016 or not.  one more question, Is there otherway to make program run in other computer without install mx compoment, it is very huge to install in every client computer Thank for reading and sorry for my bad english  
  21. I am trying to connect a CJ2M-CPU31 to a Watlow EZ Zone limit controller. I set up the tags in the PLC, imported them into Network Configurator for EIP, set up the tag links and downloaded. I am getting a d9 error on the CPU display. The error is not there constantly, it will display the error and additional info, then flash the last octet of the IP address for a few seconds like it's happy. Then the NS light flashes red a couple of times and the d9 error is displayed again. Attached shows the status of monitoring the processor. The fact that the connection tab is showing 00:0000 as the status and not showing an error code is confusing. I am not seeing any data on the PLC side when online, so they don't appear to be talking. Any ideas on what my issue may be? Thanks for any input.
  22. Communication error

    Hey Guys,    This is my first time on a forum like this! but i need a hand with something if someone could point me in the right direction.   I have a Powerflex 40 drive communicating over Ethernet/IP to a switch, That drive has four Powerflex 4's connected to it thru DSI connection. They seemed to be wired correctly and seem to be sound connections but when someone on the production hits an E-Stop it removes power from this bank of drives. (Which is standard here) . However, when they power back up i get an F081 Error (Comms lost) on the master drive and one slave. Also, the port light on the 20-comm-e(Powerflex 40) is faintly flashing about every 5 seconds and is the only light on. In this state, none of them communicate. However, when i unplug the DSI cable, the 20-comm-e powers back up to normal operation. I then plug the DSI back in and everything works fine.  Should i start replacing parts or is there some parameters/other wiring i could check?   Thanks guys.
  23. Hello all, I have a Omron 3G3MX2-AB004-V1 Inverter (VSD) connected via EtherCAT that I need to reference (home) and also perform a relative move. I am looking for a Function Block with the following Inputs/Outputs for my Omron NX1P2-1140DT1 PLC for use in Sysmac Studio. Inputs - Takes the Encoder signal as a Position obtained via a Motion Control Axis (setup as an Encoder axis) - Takes a Homing sensor input (Sensor triggers on each conveyor belt cleat) - Take either a Reference or RelativeMove signal (to Home the inverter or MoveRelative respectively) - Takes the distance to move for a RelativeMove Outputs - Forward - Reverse - Velocity - Done - Busy - Error Has anyone done this before from a PLC FB for this inverter who could help me please? Many thanks, Richard
  24. I recently had an issue where a system shipped to a customer's site with a mismatch between the IP address loaded into the CJ1W-ETN21 card and the node dials on the card itself.  We had been testing the settings of the card by pinging the address and had assumed if the node dials were wrong we would not be able to ping the card.  As we just found out that is not the case! Both our quality department and our customer's end user were able to ping the Ethernet card, but the end user could not establish FINS communications because the node dials were not correctly set. Is there a way to test that the dials are correctly set?    Thank you!!!
  25. cpm1a and ns5

    how to connect cpm1a to ns5 hmi? cant do it