Search the Community

Showing results for tags 'omron cj2m timer'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 252 results

  1. I using easymodbus library to connect and read data from 3 PLCs CP1L but it run unstablely, sometime it disconnect and i cant re-connect PLC, it give error time out when i try to reconnect when it happen, i restart PLC and everything back to work. Someone please help me. I am new with modbus and omron
  2.  Hi all. I have a question about how to set up the motor in rotary mode. My application will be a basic rotary table driven by a servo motor without gearbox between. So, in my servo drive axis settings, I select the motor as a rotary mode. then I defined the maximum position setting value for 360 degrees, and minimum to 0. So far so good. But the problem comes when I want to make an absolute move using the mc_moveAbsolute to move 360 degrees. Whit this settings the error "target position settings out of range " will come up. So, what is the solution to rotate 360 degrees without generating this error? if I set up the maximum value to 361 degrees and then if I rotate 360 the error will not occur and the motor will rotate 360 degrees as I aspected, but it's this correct ? or there is another way to do it? Thanks  
  3. PC send data to PLC

    Hello, i'm newbie for plc. i want to ask about PC/computer send data to PLC CP1E with serial communication (RS232). my wiring cable is: PC                         PLC 2                             2 3                             3 5                             9 4&6    7&8                               4&5 and if i send data from PC to PLC, my indicator in COMM is blinking. i think the cable have no problem. but if i send data from PC to PLC, the memory is not same as what i send and whatever i send data, the memory didn't change. i will attach my ladder diagram. what should i do?    New folder.rar
  4. TIA TP1500

    Hi all, I have communicated my tp1500 with Ab 1400 B series..the proble is I have setted setpoint of timer is 30min Accum...so I read my timer pv in hmi in that time ##will shows in hmi in that case I cross checked my program its twr running properly.   Another how to set date for tp 1500
  5. Hello, I want to count rotation time or cycle. I am using bellow code in the picture. If I set timer 10 ms, when counter working well, but I set timer 1 ms the counter working same how set timer 10 ms. I have question in my code is slow timer or counter and somebody give me advice how need count the rotation ms accuracy.    
  6. Hallo, i want to connect PLC Omron CP1E to indicator weighing scale with modbusRTU connection and i have a CP1W-CIF11 module to connect indicator with CP1E. ,but I have no experience in RTU modbus communication in the PLC. How do i start?   *i just need output: 1. Coil (Reference No = 0. Output bits) for input switch with address 3 (Tare). 2.Input Status (Reference No = 1) for output lamp with address 17 (stable) 3.Input register (Reference No = 3) to read data with address 5 (gross weight) 4. holding register (Reference No = 4) to write comparison data with address 17(over) page 85 - 94 in attachment     ad4402_manual.pdf
  7. Omron Servo Encoder

    Hello All  I am new to PLC programming , i have a question regarding omron PLC and High speed counters. I am using Cp1H-XA model plc . I connected HSC port 0 with a encoder and i was able to get the speed of the encoder using PRV2 instruction. Now i am trying to connect the second  encoder from the servo motor that i am using to HSC port 1. I am getting the PV signal using PRV instruction . Is there a way to calculate the speed of the servo encoder connected the HSC port 1 using PRV command , since i can't use the PRV2 command for the servo encoder .   Thanks in advance .
  8. How to set Homing parameter slot with _sHOMING_REF data. Please suggest me to setting MC_HomeWithParameter instruction or show example for using MC_HomeWithParameter instruction. Thank a lot
  9. how to set up timer in st

    Hello all I m new in st programming in omron I want to use timer in st please help me regarding this
  10. Hi, I want to sent simply frame using FB mady by JPV from Omron France. It should send just frame  01030FA60002273C  to slave #1 When I check Multiway - it seems that frame is OK, but slave no reply. I checked different soft to monitor serial port and frame looks different - some bytes are sent twice.  I attached   screenshot and you can see the difference - Can you explain why it happened. Both frame I got when I set W30.0 in PLC and I saw just one blink LED Hmm I also attached screenshot from my serail port configuration. I tried also diiferent set of CP1W-CIF11 dip switches, but the same effect. Any clue??? thanks in advance                 
  11. Greetings everyone. I'm new here. Hoping to get help to operate the Omron V400-R2 barcode to the Mitsubishi QJ71C24N so that they can communicate the two devices with the correct method. PLC: Mitsubishi: Q03UDVCPU; barcode: Omron V400-R2; serial communication module: QJ71C24N. I use RS 232 communication cable, I have tried using predefined protocol and non protocol procedures but still can't communicate the two devices. I really appreciate your help.
  12. Hello everyone! Briefly introduction, I would like to communicate and test the following hardwares: 1- Omron CP1E (using an Option Port CP1W-CIF11) ; and 2- Arduino Nano using MAX485 RS485 transceiver. The CP1E will operate in "Modbus-RTU simple master" as illustrated in image 01. The arduino will be in slave mode address 1 and the library used is "SimpleModbus NG" ( https://github.com/angeloc/simplemodbusng/tree/master/SimpleModbusSlave ). Taking the sample in official manual ( https://industrial.omron.eu/en/services-support/technical-tools/downloads#cp1e ) , pages 248-253 in the "CP1E CPU Unit Software User's Manual" (Image 04) describes a sample communication to an "Inverter Slave". I want to use the Arduino Slave as the Inverter Slave just to be sure that all previous steps are correct. Therefore, I would like to know: 1- As illustrated in Image 02, Am I missing any resistors? 2- Should I connect the GND to the FG? 3- In this scenario, the DIP switch setup should be as illustrated in image 03? Only DIP4 is OFF. 4- Can I test it just forcing A641.00 and checking the DM Area Data, as shown in Image 05? The code used in it is the following: // Wiring: Arduino and MAX485 // RX0 - RO // TX1 - DI // D2 - DE/RE #include "SimpleModbusSlave.h" enum { REGISTER_0, REGISTER_1, REGISTER_2, REGISTER_3, REGISTER_4, REGISTER_5, REGISTER_6, REGISTER_7, REGISTER_8, TOTAL_REGS_SIZE }; unsigned int holdingRegs[TOTAL_REGS_SIZE] = { 0, 1, 2, 3, 4, 5, 6, 7, 8 }; void setup() { modbus_configure(&Serial, 9600, SERIAL_8N1, 1, 2, TOTAL_REGS_SIZE, holdingRegs); } void loop() { modbus_update(); }   Any answer can be helpful. Thank you for your time!   Regards, Jose.  
  13. Compare data RS232

    Halo, my name is Riandanu, I connect PLC Omron CP1E to weighing scale, and its done. i think i dont have problem between PLC and weighing scale. And i want to ask about, how to compare value from weighing scale ?  example : from the picture you can see value of weighing scale is " ST,+00160.66  g", and i want to compare it with 180 or 150 to give output on to lamp. Thankyou Riandanu       PLC to ek-i.cxp
  14. Design Improvement Ideas : I currently use a 24v DC slipping brake (either Clarke or Warner) to prevent a reel of film from over-rotating - With Previous motion controllers - i have used timers at first then progressed to using a Virtual axis and a switch to make my pulse from NX- Digital output card to a Solid State Relay  (PSWITCH command for anyone familiar with TrioBasic) and this has worked pretty well. I have the same physical setup on a new piece of machinery but am now using NJ and Sysmac - Have used a TOF and TON in inline ST to control brake and it sort off works - brake can feel a bit lumpy and can chatter and bounce a bit adn am worried about the reliability when the machine is running and the controller is doing more. (brake cycle time t#10ms and tried at 100ms also) I did try using the Time Proportional Out FB - but this was far worse than the above. I think i will try my luck at created a new virtual axis e.g. Rotary Mode - min 0 max 1000 Run with MC_Move_Velocity when Machine is running and use an MC_digital Cam Switch to create my output Pulse. I am new to the Forum and trying to get more involved with others rather than working in Isolation - so wondering if anyone has any suggestions or thoughts  or have done anything similar in SS? Thanks in Advance,
  15. Hi, "CJ2M-CPU32 PLC" CX Programmer V: 9.63 I'm working on one of the projects where I'm using DT function for comparing the daily, monthly and yearly water flow. I'm able to get daily totalizer but having difficulty while having totalizer for monthly and yearly basis via using DT function. Can anyone guide how can I link the calendar with DT function subjected that every month is with different numbers i.e. 30,31 and 28/29 days. How can I add exact flow rate into monthly totalizer? note: 1 pulse = 1m3 (I'm not having problem for pulse count etc- its just with monthly & yearly totalizer while using DT function).   Thanks
  16. CP-1E Error

    Hello,  I am using Omron CP-1E PLC and expansion module 16ER and tc module.  When plc operated alone it goes to run mode when expansion module is connected either 16ER or TC module plc ALM/ERR led turned on.  
  17. I am trying to connect a CJ2M-CPU31 to a Watlow EZ Zone limit controller. I set up the tags in the PLC, imported them into Network Configurator for EIP, set up the tag links and downloaded. I am getting a d9 error on the CPU display. The error is not there constantly, it will display the error and additional info, then flash the last octet of the IP address for a few seconds like it's happy. Then the NS light flashes red a couple of times and the d9 error is displayed again. Attached shows the status of monitoring the processor. The fact that the connection tab is showing 00:0000 as the status and not showing an error code is confusing. I am not seeing any data on the PLC side when online, so they don't appear to be talking. Any ideas on what my issue may be? Thanks for any input.
  18. Hello all, I have a Omron 3G3MX2-AB004-V1 Inverter (VSD) connected via EtherCAT that I need to reference (home) and also perform a relative move. I am looking for a Function Block with the following Inputs/Outputs for my Omron NX1P2-1140DT1 PLC for use in Sysmac Studio. Inputs - Takes the Encoder signal as a Position obtained via a Motion Control Axis (setup as an Encoder axis) - Takes a Homing sensor input (Sensor triggers on each conveyor belt cleat) - Take either a Reference or RelativeMove signal (to Home the inverter or MoveRelative respectively) - Takes the distance to move for a RelativeMove Outputs - Forward - Reverse - Velocity - Done - Busy - Error Has anyone done this before from a PLC FB for this inverter who could help me please? Many thanks, Richard
  19. cpm1a and ns5

    how to connect cpm1a to ns5 hmi? cant do it
  20. Here is a link to a thread on a recent post showing how to communicate serially to an Omron PLC using VB.Net. This uses the Omron Host Link serial protocols. (C-Mode Commands) It will read 10 DM registers and display them on the form.   http://accautomation.ca/implementing-the-omron-host-link-protocol-vb-net/ Here is the source program that can be downloaded. Other links: VB6 Program: http://accautomation.ca/how-to-implement-the-omron-plc-host-link-protocol/ VBA Program: http://accautomation.ca/how-to-implement-the-omron-host-link-protocol-part-2-vba/ Regards, Garry www.accautomation.ca
  21. Retain Memory CJ2m-CPU31

    Hi All, Just to verify if the "memory card" , in attached document Page 4 highlighted area ,  provides Omron CJ2M CPU21 to retain memory when powered off? If yes, for how long can the memory lasts without being charged? Isit capacitor or battery? Thanks in advance. Regards, Summer cj2m-cpu31.pdf
  22. Hi, I have some trouble with a CJ2M-CPU33. My client did a backup to memory card earlier today, and after this we did some changes through remote link. Now the client wanted to restore the previous backup to the PLC and has done so, but the system would not function correctly. After going online on the PLC it seems like the PLC is stuck in "Stop/Programming Mode". When trying to change to "Monitor" or "Run" mode a dialog comes up containing the following message: "Failed to change the operating mode. The operating mode may be still changing in the PLC."  - All the dip switches are set to off after restoring backup - The PLC has been rebooted  - I have downloaded the application again through CX-programmer  - Verified that the PLC is set to start up in "Monitor mode" But nothing helps. The same message comes up when trying to change the operating mode.  Hoping anyone can help to resolve this issue as it is very critical for us and the client. In advance, thanks for any tips or help received. Best regards Stian
  23. Hello         I'm new for PLC, I need to set pump turn ON/OFF  in 4 time/day every day => [8:00-8:10]a.m, [11:00-11:20]a.m, [2:00-2:10-14:10[p.m, [5:00-5:20]p.m ** I have Omron PLC CP1E-N30 , Could you advise me, please ?  
  24. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  25. I am using CJ2M PLC.I want switch on a output for certain time by a timer and holding bit if interlocks satisfied.If interlock not OK timer has to hold the time and output should be off. if again interlocks OK again output has to ON upto balance time completion and has to give timer done output for reset holding bit.please suggest.