Search the Community

Showing results for tags 'motion controller upgrage'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 54 results

  1. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  2. Please help find a controller. We require a controller for 8 nema 23 stepper motors. Must have pulse direction and at least 8 axis or more (16 would be nice). Must have kinematics for linear and circular motion. Must be able to use gcode such as G01 X10 Y10 Z10 A10 B10 C10 U10 V10. Must have axis parameters for all 8 axis eg velocity, rotations, etc. We also need the drivers. Must be reasonably priced under $1000 or so. We found Dynomotion KFLOP which can do 6 axis and we kind of made it work for 8 axis. It is super cheap at around $250 plus KStep drivers so under $1000 total with free software, unfortunately, it can not do kinematics for 8 axis. 
  3. Hi everybody I have a elau c400 controller trying to connect it to a mc-4 pacdrive. But I realized that the wd led on my c400 is on and it can be a fetal error. Anybody has this experience? Regards.
  4. i want to connect omron vision controller fh l550 with Soft PLC (IPC) from Siemens  through Ethernet or  RS232c interfaces, should i use a unit for the communication or can i directly connect the Omron Controller with IPC ?  the IPC is connected with other devices via profibus .
  5. Mitsubishi PID controller design help

    Dear all, I need help in design of PID controller in Mitsubishi PLC fx3u, I what should be parameters for initial, and how to start and stop auto tuning.
  6. Bonjour, Hello, I use a l33erm automaton and a Kinetix servo motor . This servo motor drives an engine with a chain moving in steps of 100 millimetres (there are 15 steps on the chain ) At each top of a cell this motor advances by 100 millimetre. in reality it advances from about 0 to about 100. Sometimes it is 100,002 times to 99,997 (this is important further) and when I give it a top it goes back to about 100 (100,003 times to 99,996) And so on and so forth up to no problem, I use a MAM with an absolute type of movement. It works.     However, this does not work any more after a rearmament following an emergency shutdown. if it is a 100,002 no problem at the next top the chain advances one step But when the engine is shut down at 99,997 and I give it the order to go to 100 it advances only by 0,003.  This only happens after an emergency stop (or door opening). Thank you for the help you can give me excuse my English this is a machine translation Un séjour sans faille
  7. Hello,, I have motion controller A series A172SHCPUN,, I have written the program ladder into the CPU, but I can't write the motion program.. i dont have the program to open file the program motion and I want to ask if I have the software SW3RNC-GSVE, my os computer is window XP, Can it be installed? and is the cable transfer used the same as the ladder transfer program cable (SC09)?
  8. Hello everyone, Working in Automation for the first time as a Co-op student so i'm fairly new to PLC's and the Automation field in general. I've recently been tasked with converting a RSlogix 5 program from an old PLC 5 project into a Studio5000 project. I referenced the manual (I'll attach link below), and had no issues using the RSlogix Project Migrator tool that I downloaded off the Rockwell website. My problem is that once I convert the program, my I/O tags that were originally sequenced in octets(0-7, 10-17, 20-27, ...) from the RSlogix 5 program, are switched into a sequential scheme in Studio5000 that just increments them in order (1, 2, 3, 4, ...). I hope this make sense, but basically the first seven tags match between the projects, but then I:010 in rslogix 5 is equivalent to I[8] in 5000, I:011 is I[9], and so on and so forth. Has anyone had this issue before and found a way to have Studio5000 keep the original octet scheme? I don't see this normally being an issue, but the customer has specifically asked that the I/O tag names be kept the same as the original program. Thanks for any help. - Ben   Converting PLC-5 reference manual link: https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/1756-rm085_-en-p.pdf
  9. Hello, I have an interesting problem that no one in our company can really answer for me.  We are using Drive Logix with a powerflex 700S phase 2 drive and controlling a machine that rotates 360 degrees, sits for a moment, then return back to zero degrees.  We are using the MAM instruction to tell the drive to run the motor to its desired degree.  The problem we seem to face, is when they change jobs, the weight changes and we have to adjust speeds in order to get the machine to rotate back up to 360 degrees.  Otherwise, the motor stops short.  It usually never faults or alarms, it just stops short.  For example, they might run it and it will stop at 240 degrees or 315 degrees rather than the 360.  My question is, why doesn't the drive continue to push the motor to 360 degrees?  Why wouldn't the drive fault out on something like over current?  It seems that it just stalls and stops.  Sometimes, the machine will be running great, but on occasion (1 or 2 times a shift), the machine will stop short again.  I am curious what causes this and how I might be able to fix this to force the drive to continue to try and get to that desired degree. Thank you for any help or input!
  10. hello everyone,,,, I want to running the motor in 100 rpm but how to setting electronic gear to control speed in servo motor HG-SR502,, does anyone know how?
  11. Pls help set up QD75P4N

    Good day sirs,  i am a newbie at this motion controller setting. I would kindly like to ask for an assistance from all of you. i copied all the necessary data that i have on this project. I installed the wiring correctly i am able to Jog the servo motor. But when i try to Jog the motor Using GXWorks 2 i wasn't able to do so because its not showing any movement on the Mr J4 and the motor it self. is there any settings that i should have change? thank you for the time if you will need any information i am willing to give it thank you   I have also attached the GXworks program and the servo conifiguration   Please help me thank you project 1.gxw Servo 1.mrc2
  12. 1756-L55/A Controller

    Respected Friends, Good day. I face a serious issue please help me to fix the problem.  We have a 1756-L55/A controller with 1756/M13 A memory card. after 2 or 3 months the program washout and the LED status on the controller are following 1. RUN --- SOLID GREEN 2. I/O--- OFF 3. RS232 --- SOILD RED 4. OK --- SOLID RED 5. BAT-- OFF 6. FORCE-- OFF  At that time CONTROL NET MODULES OK Light for Chanel A and Chanel B are also blinking and communication not established via control net and serial port AB-DF1. I switched off the power supply and after 10 second again power up the controller then OK LED becomes solid green.  i download the program and its run fine. But the problem is still there. In the controller properties the major fault shows  TYPE 01 [ POWER UP FAULT] CODE 60 [NON RECOVERABLE FAULT] what are the possible reason for wash out the program from the memory?  At that time version 16.03 firmware installed and the rslogix program convert from version 10 to version 16.03.  Is 1756 L555/A with 1756/M13 A support the version 10 firmware? i ask because the original program is in version 10 if its supported then i update the firm ware and download the original program.   Hope you will help me in this issue. Regards
  13. From PM this morning

    Fairly new programmer doing first analog section in project at new job. Im using NCF motion with parameter for torque control to send the torque values  a+8 (leftmost word) and a+9 (right most word) to CX programmer. From there is where I get confused will I just simply be moving both cio 108 and 109 to to a D register?? or will I have to combine the a+8 and a+9 to make a Dword??? and then taking that value to HMI broken line graph. sorry again for creeping in your inbox but ive been looking online for 6 hours. would greatly appreciate any help
  14. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  15. Hi,  I'm new to TwinCAT 2 and i'm upgrading a long time design (hence the TwinCAT 2 reference), to read a more sensitive torque signal.  I'm using a Beckhoff CX1030 as my PLC Controller.  I needed to add 'homing' to my motor sequence and confirmed with Maxon, im using the function blocks correctly and in the correct sequence to establish my 'absolute zero'/'home' position.  The motor has an output to write to:  ControlWord, which tells the motor that the position it is sitting in is '0.'  My program compiles, it runs, it writes each function block, but it's not seeming to get back to the test run opMode, even though i tell it to and the function block performs the 'Write' function.  it's stuck at zero and not reading an analog input signal from my torque sensor.  so im getting an artificial torque reading through every test.   i think this is related to my tare motion.  I start the program, home the motor, get into profile velocity mode, tare my sensor, enter profile position mode, go back to position 0, then back to profile velocity mode, run a test, sample data, go back to 'home' or '0.'  I wonder 1st, is my variable not linked properly through the system manager?  2nd, i set a boolean variable to set the 4th bit to 1 in my control word write (setting the 4th bit high will set my current position to absolute zero), but did i not connect the program to the main sequence properly?  looking to read a valid signal again and see that my motor moves back to 'home' each time.  Do i not need to home the motor after the tare, since the tare nulls out the torque value after the tare? after this i need to program my sample period, instead of it being fixed, as it is currently written and then use my home position as my trigger to start sampling.... Beckhoff applications department is overloaded, currently and can't help and this is all beyond the knowledge of the general support line.  I've gotten fairly far, on my own, but of course, the project is under a time crunch.   Does anyone know twincat well enough to help guide me?
  16. Hello i'm new in all things about plc, i do a project for school and i use a festo fc 34 plc. The plc is programmed via serial port RS232 my pc not support a serial interface and i use a RS232 to usb adapter. when a try to download the program to plc give me a error: "ERROR: Cannot access controller".  What i do wrong.  Thank you in advance and sorry for my English. Have a nice day.
  17. RS logix 5000 motion control

    Hi Guys! I have a problem with Motion axis move (MAM) command. There is an Allen bradley servo motor what is working well. But I need to add a new program section, wich is in  a specified moment, the axis should move a certain distance. I think I need to use the mam command, just I dont know how can I configure the motion control part. I need to make a new tag ? or what ? I need to use a user define ? PLS help me.   
  18. All, I am using Keyence CV-X422A vision controller for my application. It is interfaced with Siemens S7-1500 PLC on PROFINET. I am able to communicate with Vision controller through PLC logic command and status IOs. There is some communication issue in updating the o/p values from Camera Controller. I have tried with & w/o Handshake Mode with these settings. The camera display shows the reject but camera never turns ON the NG Status o/p. I tried different things told by Keyence Tech support but none of them worked.  He told me to have you enable the “Result ACK Flag” in the bit allocation area and send  a signal to it. Then trigger it again with a no good part and see if that fixes the issue. I tried setting the “Result ACK Flag” to 1 after I get the “Command Complete Flag” for the trigger signal that I sent. Sometimes this works but still it is not reliable. Do I need to send only a pulse to “Result ACK Flag”? Anyone here has ever faced similar issue?  Thanks for your help. AP
  19.   Hello, I want to regulate the temperature by a thermocouple type T with an OMRON control module TC001 / 2/3 and a CJ2M CPU14 series PLC using CX-Programmer as a programming environment. Could you provide me with an example project? Thank you for your help.
  20. Hello, is there a way, to edit E5CC-T temperature controller internal program, using CP1L-EM PLC, connected to temperature controller via rs-485 communication? I can't find any information about doing it. I know that i cat change these programs, using CX-Thermo, but that is not an option. I need to do that, using only PLC..
  21. I'm making this thread, continuing from my previous one (Newbie Screwed Up) where I received tremendous help from those on this forum.    I now have the AB 5/04 working, but the Panel Mate 1700 doesn't seem to communicate with the 504.  The HMI connected to this brick is a Cutler Hammer Panel Mate Pro 1700.  It lights up,  the touch-screen buttons somewhat react to touching (might take a few strokes to react), but the functions do not react with the 5/04.  I called the equipment manufacturer, and they basically said it is all obsolete equipment, no longer supported, etc. and we are SOL. But, for a mere $100K, we can send the unit back, and they'll install all "modern" control units !! Not an option.   I get it that the unit is 10+ years old, but has very low cycle times on it.  (maybe 400 hrs)   It's my understanding that the  HMIs are just that....a means of the operators telling the PLC what you want it to do. So, my question .... is there an off the shelf software package that would emulate the Panel Mate 1700?  All I need to "control"  is to advance or retard two sets of heat seal rollers (via PacSci stepper motors), actuate two separate hole punch solenoids, and an air solenoid for a knife....it's basically a packaging machine.  I do have a program called PMConfig , but I don't see any communications buttons or icons in that software, just screen shots of what shows up on the HMI, icon selection, change fonts / colors, etc.  So, I'm looking for a resolution to make new(er) HMI (or even just a cheap a$$ laptop)  with affordable software, and easy interface to communicate with the now functioning 5/04.  Thanks for the input.
  22. Looking for some servo application help. Software: I have GX works 2, GT Designer, and GX Developer.  Hardware: PLC L06CPU-P, GOT2000 HMI, MR-J4-350B servo amps, HG-JR35JK motors, LD77MS2 Pulser I have (2) AC servos that will simply move an aluminum frame backwards and forwards using a FESTO belt mover and I have a servo gear reducer 20:1. I have a "simple motion module"and all of this hardware and software, plenty of time, and would really like to finish this project off. But this is my first servo and my first hmi project. I have some experience with Omron, Mitsubishi, and Allen-Bradley plc's, and consider myself novice at best. Any sample programs or help getting me started would be greatly appreciated!  
  23. Trouble Wiring a Simple LED with a Micro820 Controller

    Hi everyone, Recently, I started working with the Micro820 Controller Embedded I/O. My project is simple : when the output _IO_EM_DO_00 is set to true, an LED light turns on. But, even though it's super simple, I can't make it work. Here's my setup. If you need more information, feel free to ask anything !
  24. controller is not coming online with rslogix 5000, but i can ping the ip from the pc. getting the error message says "controller failed to come online - error 701-8004250B" appreciate ur help.
  25. Hi Here's a question I'm about to ask Omron.. as soon as I can figure out who to ask.. It's complicated asking support.. their web email form doesn't make complex questions easy. Here's the question: Can the NJ CPU program a LinMot linear motor to make the "Random Sea"? The NJ has a mixed protocol.. Ethernet/IP and EtherCAT (CoE),  and claims to be a "Motion Controller".    I doubt Motion Control is available on it's Ethernet/IP line.. but the EtherCAT might be another story.   Certainly The Omron NJ is a Motion Controller for Omron NJ series drives.. However, how well does it work with LinMot? Here's the curve.  Imagine a LinMot Linear motor continuously moving, never really stopping, following a real-time, mathematically generated curve, moving positive then negative, at random frequencies and random amplitudes. Almost never repeating a motion sequence. looks something like this: Yet, after a while the motion history fully represents the spectral distribution of energy on the surface of the ocean. Spectrum analyzers can display it, and mathematics can define it..  I just have to make that sea in a model scale…    (Time scales by the square root of the scale factor) And keep the water in the tank: https://www.youtube.com/watch?v=SQd6YzBWVvI The big question is: Can the Omron NJ get a LinMot Linear Motor to do this? … LinMot thinks YES.. but, isn’t sure. Yes there are ways to “connect" LinMot to The NJ.. EtherCAT (CoE), Ethernert/IP but… there is nothing in the LinMot drive that can create or store a predesigned Random Sea .. Only a Motion Controller, generating real time motion commands, by running  mathematical equations, "on the fly” can do that.   If the NJ is a true “Motion Controller”, and the LinMot C1250-DS-XC is implemented as an “axis” by Symac Studio, which it is…       Then, there may be hope. Closed loop, PID feedback remains with the LinMot drive, with special settings in LinMot Talk … Homing might have to be done with the NJ .. or by Digital I/O’s What do the Omron experts out there think?  Can this be done? Thanks much, Regards, Michael