Search the Community

Showing results for tags 'motion axis move'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 40 results

  1. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  2. Hi All, I have an AB servo TLY-A110T and 2097-V31PR0-LM Kinetix 350 drive. I thought that it was fully configured and ready for tuning, but when I issue a MSO it immediately starts to spin the shaft (no load yet). This lasts about a second until a Physical Axis Fault, Excessive Velocity Error occurs. I've double and triple checked the feedback and power wiring, and everything looks right. Is there anything else I can check? What can I do to trouble shoot this if I can't even give an MSO? Any insight is greatly appreciated.
  3. Bonjour, Hello, I use a l33erm automaton and a Kinetix servo motor . This servo motor drives an engine with a chain moving in steps of 100 millimetres (there are 15 steps on the chain ) At each top of a cell this motor advances by 100 millimetre. in reality it advances from about 0 to about 100. Sometimes it is 100,002 times to 99,997 (this is important further) and when I give it a top it goes back to about 100 (100,003 times to 99,996) And so on and so forth up to no problem, I use a MAM with an absolute type of movement. It works.     However, this does not work any more after a rearmament following an emergency shutdown. if it is a 100,002 no problem at the next top the chain advances one step But when the engine is shut down at 99,997 and I give it the order to go to 100 it advances only by 0,003.  This only happens after an emergency stop (or door opening). Thank you for the help you can give me excuse my English this is a machine translation Un séjour sans faille
  4. Hello,, I have motion controller A series A172SHCPUN,, I have written the program ladder into the CPU, but I can't write the motion program.. i dont have the program to open file the program motion and I want to ask if I have the software SW3RNC-GSVE, my os computer is window XP, Can it be installed? and is the cable transfer used the same as the ladder transfer program cable (SC09)?
  5. Hello, I have an interesting problem that no one in our company can really answer for me.  We are using Drive Logix with a powerflex 700S phase 2 drive and controlling a machine that rotates 360 degrees, sits for a moment, then return back to zero degrees.  We are using the MAM instruction to tell the drive to run the motor to its desired degree.  The problem we seem to face, is when they change jobs, the weight changes and we have to adjust speeds in order to get the machine to rotate back up to 360 degrees.  Otherwise, the motor stops short.  It usually never faults or alarms, it just stops short.  For example, they might run it and it will stop at 240 degrees or 315 degrees rather than the 360.  My question is, why doesn't the drive continue to push the motor to 360 degrees?  Why wouldn't the drive fault out on something like over current?  It seems that it just stalls and stops.  Sometimes, the machine will be running great, but on occasion (1 or 2 times a shift), the machine will stop short again.  I am curious what causes this and how I might be able to fix this to force the drive to continue to try and get to that desired degree. Thank you for any help or input!
  6. hello everyone,,,, I want to running the motor in 100 rpm but how to setting electronic gear to control speed in servo motor HG-SR502,, does anyone know how?
  7. hallo everyone ...i use mitsubishi Q00UJCPU and QD77MS2.. i try to make a speed control program and the speed wants to be changed during servo operating, i use dedicated instructions ZP. PSTRT1 (axis 1) and have tryed but it was only successful to change speed with "change speed control" function once ... is it like it? cannot change "change speed control" many times when servo operations?
  8. Pls help set up QD75P4N

    Good day sirs,  i am a newbie at this motion controller setting. I would kindly like to ask for an assistance from all of you. i copied all the necessary data that i have on this project. I installed the wiring correctly i am able to Jog the servo motor. But when i try to Jog the motor Using GXWorks 2 i wasn't able to do so because its not showing any movement on the Mr J4 and the motor it self. is there any settings that i should have change? thank you for the time if you will need any information i am willing to give it thank you   I have also attached the GXworks program and the servo conifiguration   Please help me thank you project 1.gxw Servo 1.mrc2
  9. From PM this morning

    Fairly new programmer doing first analog section in project at new job. Im using NCF motion with parameter for torque control to send the torque values  a+8 (leftmost word) and a+9 (right most word) to CX programmer. From there is where I get confused will I just simply be moving both cio 108 and 109 to to a D register?? or will I have to combine the a+8 and a+9 to make a Dword??? and then taking that value to HMI broken line graph. sorry again for creeping in your inbox but ive been looking online for 6 hours. would greatly appreciate any help
  10. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  11. Hi,  I'm new to TwinCAT 2 and i'm upgrading a long time design (hence the TwinCAT 2 reference), to read a more sensitive torque signal.  I'm using a Beckhoff CX1030 as my PLC Controller.  I needed to add 'homing' to my motor sequence and confirmed with Maxon, im using the function blocks correctly and in the correct sequence to establish my 'absolute zero'/'home' position.  The motor has an output to write to:  ControlWord, which tells the motor that the position it is sitting in is '0.'  My program compiles, it runs, it writes each function block, but it's not seeming to get back to the test run opMode, even though i tell it to and the function block performs the 'Write' function.  it's stuck at zero and not reading an analog input signal from my torque sensor.  so im getting an artificial torque reading through every test.   i think this is related to my tare motion.  I start the program, home the motor, get into profile velocity mode, tare my sensor, enter profile position mode, go back to position 0, then back to profile velocity mode, run a test, sample data, go back to 'home' or '0.'  I wonder 1st, is my variable not linked properly through the system manager?  2nd, i set a boolean variable to set the 4th bit to 1 in my control word write (setting the 4th bit high will set my current position to absolute zero), but did i not connect the program to the main sequence properly?  looking to read a valid signal again and see that my motor moves back to 'home' each time.  Do i not need to home the motor after the tare, since the tare nulls out the torque value after the tare? after this i need to program my sample period, instead of it being fixed, as it is currently written and then use my home position as my trigger to start sampling.... Beckhoff applications department is overloaded, currently and can't help and this is all beyond the knowledge of the general support line.  I've gotten fairly far, on my own, but of course, the project is under a time crunch.   Does anyone know twincat well enough to help guide me?
  12. RS logix 5000 motion control

    Hi Guys! I have a problem with Motion axis move (MAM) command. There is an Allen bradley servo motor what is working well. But I need to add a new program section, wich is in  a specified moment, the axis should move a certain distance. I think I need to use the mam command, just I dont know how can I configure the motion control part. I need to make a new tag ? or what ? I need to use a user define ? PLS help me.   
  13. Compare not working

    We have this logic (on a CP1E) the desired outcome is as follows: When a bad part is detected, force the operator to index the machine 6 times, using a holding register to prevent a power cycle from resetting the count. once 6 cycles are recorded output that the bad parts are removed AND reset the count to zero.   What has actually happened so far: the count has gone to 6 and not reset. I have used CX Programmer to set the H0 value to zero but the compare still says it's equal (to 6)   I have read everything i can get my hands on regarding holding registers and compare functions and i can't see what is wrong. I have no formal training on this so i'm sure it's something simple. can anyone point me in the right direction?   Thanks guys    
  14. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  15. Looking for some servo application help. Software: I have GX works 2, GT Designer, and GX Developer.  Hardware: PLC L06CPU-P, GOT2000 HMI, MR-J4-350B servo amps, HG-JR35JK motors, LD77MS2 Pulser I have (2) AC servos that will simply move an aluminum frame backwards and forwards using a FESTO belt mover and I have a servo gear reducer 20:1. I have a "simple motion module"and all of this hardware and software, plenty of time, and would really like to finish this project off. But this is my first servo and my first hmi project. I have some experience with Omron, Mitsubishi, and Allen-Bradley plc's, and consider myself novice at best. Any sample programs or help getting me started would be greatly appreciated!  
  16. Hi Here's a question I'm about to ask Omron.. as soon as I can figure out who to ask.. It's complicated asking support.. their web email form doesn't make complex questions easy. Here's the question: Can the NJ CPU program a LinMot linear motor to make the "Random Sea"? The NJ has a mixed protocol.. Ethernet/IP and EtherCAT (CoE),  and claims to be a "Motion Controller".    I doubt Motion Control is available on it's Ethernet/IP line.. but the EtherCAT might be another story.   Certainly The Omron NJ is a Motion Controller for Omron NJ series drives.. However, how well does it work with LinMot? Here's the curve.  Imagine a LinMot Linear motor continuously moving, never really stopping, following a real-time, mathematically generated curve, moving positive then negative, at random frequencies and random amplitudes. Almost never repeating a motion sequence. looks something like this: Yet, after a while the motion history fully represents the spectral distribution of energy on the surface of the ocean. Spectrum analyzers can display it, and mathematics can define it..  I just have to make that sea in a model scale…    (Time scales by the square root of the scale factor) And keep the water in the tank: https://www.youtube.com/watch?v=SQd6YzBWVvI The big question is: Can the Omron NJ get a LinMot Linear Motor to do this? … LinMot thinks YES.. but, isn’t sure. Yes there are ways to “connect" LinMot to The NJ.. EtherCAT (CoE), Ethernert/IP but… there is nothing in the LinMot drive that can create or store a predesigned Random Sea .. Only a Motion Controller, generating real time motion commands, by running  mathematical equations, "on the fly” can do that.   If the NJ is a true “Motion Controller”, and the LinMot C1250-DS-XC is implemented as an “axis” by Symac Studio, which it is…       Then, there may be hope. Closed loop, PID feedback remains with the LinMot drive, with special settings in LinMot Talk … Homing might have to be done with the NJ .. or by Digital I/O’s What do the Omron experts out there think?  Can this be done? Thanks much, Regards, Michael
  17. MR J3 A SERVO

    I want to run MR J3 A type 10 nos servo without using network, I'm to run servo using hardwired.please name motion controller to run 10 servo on hardwired..  
  18. Hi every body! Now I use a Q-motion controller Q172DSCPU with advanced synchronous control method. I try to synchronize 4 axes with Axis1 as command generation axis. The problem is that the command generation axis current value is not be cleared to zero after restarting the cycle. It should be cleared to zero to be kept within stroke limit during the process. Thanks in advanced  
  19. Version BA LBR iiwa V5

    24 downloads

    KUKA: IIWA is a collaborative robot with 7 axis, built in force sensors on all axes, built in mastering tool etc.
  20. View File KUKA: IIWA (collaborative robot, 7 axis) KUKA: IIWA is a collaborative robot with 7 axis, built in force sensors on all axes, built in mastering tool etc. Submitter panic mode Submitted 02/16/17 Category Robots and Servos
  21. Version BA KR QUANTEC PA V6

    21 downloads

    KUKA: Quantec palletizer
  22. KUKA: Palletizer (including Arctic) View File KUKA: Quantec palletizer Submitter panic mode Submitted 02/16/17 Category Robots and Servos
  23. hI.. I've asked for this in the past and, so far, haven't been very lucky.  Most of the projects I run into have 4 or 5 axis, lots of analog and sensor input.. or don't have the HMI part of the "Machine" I have a nice NJ 101-1000 with the NA 7 inch HMI.. along with a R88BD-KNA5L-ECT servo and a 50W  G5 motor.. type  R88M-K05030H-S2.  All On a nice rack with power supplies and some EtherCAT I/O  (It all functions .. even "MC Test Run" gets the motor to jog ..    But.. no way to "home" it.... The motor is in "rotary mode"   but... it's NOT got an Absolute encoder.. it's a incremental... sniff!     I just want it to stop on zero ..Or anywhere, and call it zero ... and make moves plus an' minus in degrees, that's all....  I assume I have to send it some signal (push button) while it's spinning that tells it it's in "Proximity" to home and it then it does something which makes it end up on zero.    I've homed a lot of linear motors (LinMot) an' they are very easy to work with.    But, Omron has 10 different homing modes .. and they aren't very well explained.  Well, they aren't explained at all in that 502 page user manual... you have to already know how to do it, in order to understand the explanation... Example:  Take the "Home Proximity Input Signal"  .. I can imagine what it might do, to help control a move to home.  I can even imagine what's making the signal .. and that somewhere there is a place where the homing parameters are set... like the "axis setting table"  .. but, it's not a Global Variable, or a Data Type .. I could imagine it gets into the system from the CN1 I/O connector? or some I/O somewhere? But.. I grow weary of imagining how this system actually works..  Building a simple working project, from a tutorial, or even downloading a simple working project (.smc2 file) and making the minor adjustments to fit my equipment ... would make all the difference in the world.   I've searched Omron's Libraries of .smc2 files.  Haven't found any yet that aren't on the level of "Top Gun" (a seriously complicated project for a 1-week training class) ... Oh there are several.. related to IAG object files .. but those Library files are not "working projects" intended to serve as a Tutorial.. they are limited projects, ready to be configured with IAG Object files, and "your" programming ... So that you can write the programs you need "faster"... which is nice... but, no help here. Somewhere out there.. is a nice simple .smc2 project file where you get to control a simple motor from the HMI  ..Preferably using an NJ CPU and a NA HMI .. home the motor.. jog the motor and input a few "go-to" positions... sigh!..   Like you would do in a One or Two Day class...   This kind of thing should be already be available in the Sysmac Library ... Thanks much for listening..  sorry about the rant.  
  24. RSLogix Tag Name Confusion

    I am trying to learn the logic of a process at my new job. There are tag names that I can't make sense of because they end with _xva, _xvb, _xvu, _xvd, _xvo, _xvc, _zsm, _zsu, _zsc, _zso, _zsd and so on and so forth. I know they are associated with motion, but I need to make better sense of them. There are no descriptors. What do they mean and is there a resource available that I can reference?
  25. Greetings, I'm here in my home lab trying to acquire a working knowledge of UDT's.  I've had to work with them in the past in large existing programs and they were a pain to track down and find out what IO they were really controlling.  I have a decent understanding of what they are and I've created several to play with here using my softlogix processor and a digital flex IO rack. My issue starts when i'm trying connect my UDT's to the physical IO.  it looks like I cant use a simple move instruction (which would be way too easy and exactly what I need)  I have a flex IO 8 point output.  Local:1:O.Data[0] I have a UDT consisting of (see attachment) Valve001  Valve001.Out     Valve001.Out.OPEN     Valve001.Out.CLOSE   Valve001.In     Valve001.In.OPEN     Valve001.In.CLOSED I have a copy instruction set to copy Valve001    to Local:1:O.Data[0]     Length 2 that allows the Out.Open and Out.Close UDT's to control bits 0 and 1 of the 8 bit output . .... great. Now I have another UDT setup to control lighting... Door   Door.Out.OPEN   Door.Out.CLOSE I want to control bits 2 and 3 I make another copy instruction in a line before the original copy instruction that states Copy Door to Local:1:O.Data[0] Length 4 but i'm really just fighting for the same 2 bits that the valve controls.... how can I control bits 2 and 3 for the door/lighting logic using these UDT's?   and that's not yet getting into having physical inputs moved/copied to the UDT input bits. thanks!!