Search the Community

Showing results for tags 'micrologix 1200 fault led blinking'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 103 results

  1. Hi my problem may have a simple solution but i cant work it out. I need to use the Divide function but it wont let me use a decimal point in either Source A or Source B. Is there a way to use a decimal point in Logix 500 Math instructions? Im using an AB Micrologix 1400 PLC. Can you only use math instructions with whole numbers? is there a way around this? Thanks James
  2. S7-1214C All LED Blinking

    Hi everyone. Recently I get a S7-1214C ac/dc/rly plc, whenever i connect ac power all the indicating LED i.e 'Run/Stop , Error & Maint' start to blink. I can't upload or download any program. In TIA Portal V13 only accessible node is not shown. Anyone encountered the same problem? Please help me. Thanks in advance 
  3. Communication

    good evening. Someone can give tips on how to configure and physical the application with the following items: Advanced Interface Converters (AIC +), PanelView800 2711R-T7T A and MicroLogix 1500 Programmable Controllers My doubts are about the configuration of the communication, and I have doubts about the physical environment and protocol to be used.  
  4. hi there is a 1215c and a fatek B1 plc here. 1215c as master and fatek as slave. i want to read 10 16bit words from Fatek to 1215c and i use Modbus rtu 485. i have a problem with what comes from Fatek To 1215C. thx 2018-08-25_11-56-16.mp4
  5. Hello :I'm the creator of an Android HMI app,  I recently added Ethernet/IP connectivity with MicroLogix and SLC AB PLCs, but I have only been able to test it with a MicroLogix 1100.I'm really not sure if it works with SLC or with other MicroLogix models.If someone could try it, I would appreciate it. To access the test, from the Android device, open this https://play.google.com/apps/testing/com.suppanel.suppanel on the web browser and install the Beta version.On the application you have to open the "EIP MicroLogic SLC Test" panel that contains some instructions. Thank you very much !
  6. Hello everybody. I need to learn PLC programming. I already have some experience with Ladder language and PLCSIM so now I need a real PLC to do more practice. I was going to buy the following unit: 6ES7211-1BE31-0XB0 http://www.eibmarkt.com/isroot/eibmarkt/Files/DatenblattE/NS6102812.pdf It has 6 Di, 4 DO (Relay) and 2 AI, that's more than enough for me to do some practice. Do you think it would be a good idea to buy it? Or maybe this PLC doesn't have some important component or device needed to work properly? (my company will give me the software). Thank you to anyone will help me. Have a nice day, Edoardo
  7. Micrologix 1400 Float TAG

    Hello,  I have a micrologix 1400 plc connected to a length measurement gauge. The gauge sends an analog value to the plc to an analog input. I convert the value into a dimension and send it to F8:0. but I need this value in three different steps in the program. Since i just have one element of float (F8:0) is there anyway i can store the value in a different location or create more floating point tags eg. F8:1. F8:2 ?    Thank You   
  8. Good evening(here at least),    I am working on a senior design project that requires the use of a PLC. Due to budget we've had to settle for an older Micrologix 1000 from Allen Bradley. I've managed to get the software running and connect with the programming port. The problem I have right now is trying to decipher how I would connect a load cell(Such that it causes a condition change at a certain weight). Ideally I would want a load cell amplifier connected to an analog input, but I don't think the 1000 has support for that. Would it be possible to use something like the HX711 amplifier(digital output) to be read on one of the input pins of the micrologix? I wanna say the pins don't read a pulse modulated input and I can't seem to register for the AB knowledgebase as the site gives me a web error. I'd appreciate any feedback.  Thanks in advance.  
  9. ENCODER IN MICROLOGIX 1400

    Dear Sir, Kindly Tell me how to use encoder with micrologix 1400. Thanks
  10. HELP! Wiring 1214C DC/DC/DC CPU

    I am currently finishing my A.S. in Engineering Technology.  My Capstone course is to wire up a complete S7-1200 system using a 1214C DC/DC/DC CPU.  There have been no courses that have explained exactly how they are wired.  Only programming, which I am pretty good with.  There is a 120VAC to 24VDC power supply.  They want it to be wired to switches and lights for a simulator.  I am just not sure exactly how the I/O's are wired.  Is is sinked or sourced?  As far as I know, one sends the ground to the output, and one sends the 24v to the output.  I would love to speak with someone on how to wire this, as once I graduate, this is what I want to be doing, but I am stuck in a hard place as none of my classes taught us how to wire the PLC's and even worse, the programming class was all about AB PLC's.  I have not learned about Siemen's at all.  They should be pretty close to the same, but I know there has to be some differences.  Also, how they have it set up, there are 2 power supplies on the plastic panel just to the left of the picture.  This seems to me as this is a sinking I/O.  Am i off?
  11. 1756-RM2 allen bradley

    Hello everyone, my name ia alif from indonesia i have redundancy module 1756-RM2 controllogix5000 Allen bradley. On the module, fault codes appear as EG12. What is it means ?   I have already search in the user manu but there is no explanation about this fault codes.     Thank you
  12. Hello All,   I hope this post is not against any forum's rules. If so please delete.   I would like to invite everyone interested to have a look at my website, which is purely about TIA Portal and everything related: TIA Portal how to   There you can find articles, tutorials, tips and videos.   Hopefully someone will find it helpful. There are more materials coming so be sure to subscribe to Newsletter   There is also: Facebook Fanpage                          Facebook Group                         Twitter                         YouTube   Regards, Robert Jankowski
  13. Hello,  As the title indicates, we have a micrologix 1400 that has been installed for a long time.  Recently it faulted out on 71h and was in Remote Mode.  Do these PLCs revert to Remote Mode when in a fault condition?  We placed it back in Run Mode and everything worked fine, but how did it get to Remote Mode in the first place? Thanks,  J 
  14. I have a "paddle wheel" style flow meter that I am trying to wire to my Micrologix 1400. It is a three wire device and there is a tag on it that says it can run at 6-36VDC. So, naturally, I thought to wire this to one of the HSC inputs of the Micrologix directly. I hooked the ( + ) on the meter to 24V, ( - ) on the meter to common, signal to the oscilloscope, and ground on the scope went to common. I see a small 60Hz sine wave @ like 5mv when the wheel is not turning. When the wheel is turning I get a small square wave but in the same mV range. It is not a nice smooth square wave either its all jumbled up with the 60Hz sine wave.  I hooked this thing up to a transmitter and scoped the signal and ( - ) in parallel with the wheel - I get a nice smooth square wave signal when the wheel turns. It is only at 4.5V though. My questions are? Why does't the paddle wheel give me what I am expecting directly? Also, what is the voltage range on the pulse that a micrologix will see? I am assuming that it will not count a wave with a 4.8V amplitude.... Thanks for your help in advanced! neech   
  15. Hi all, I will be starting on my MSc in automation in a couple of days so for that reason i have obtained a S7-1200 series 1211AC/DC/RLY PLC. This is a new area for me as i have been working in offshore since i graduated from my BSc a couple of years ago. I watched some Youtube tutorials on how the programming is done and i am ready to try it out for myself, but i have encountered a little problem.   Problem: I am using the X1 P1 PROFINET (LAN) port as a connection to my PC, this turns the Green Link light on and the Rx/Tx lights blinks orange. Now to the problem, i cannot connect to the PLC through the TIA portal, no matter what settings and connection types i use in the PG/PC interface box. I have had no luck finding leturature adressing how to configure the PC/software and get a connection to the PLC. Do any of you have a PDF or link which can help me through this problem?  Hardware: S7-1200 series 1211AC/DC/RLY 6ES7 211-BE40-0XB0 S C-J5PN 1614 2017 FS:05 Software: TIA Portal Version 13 STEP 7 Professional V13 WinCC Basic V13   Thanks   Best regards   Dennis    
  16. Encoder Interrupt Help

    Hey guys, I am working on an application that tracks irregularly spaced PET bottles on a conveyor line and then blows them into boxes waiting on the side of the conveyor. I believe I have working logic, but I am having issues with the encoder at operating conveyor speeds. I believe the best logic for my project is to use a photoeye to detect the presence of a bottle (a one-shot makes sure it is only detected once), and then "store" the "presence" of the bottle in a binary file using an encoder pulse to trigger a BSL function. Using this logic, the bits in the file are analogous to a real, physical location on the conveyor, and I can just monitor specific addresses in the file where my real-world air nozzles are located. My current problem is that as my conveyor speeds increase, the PLC begins to miss pulses from the encoder. During my initial set-up, I took data at very slow speeds to experimentally determine how many pulses were between the photoeye and each air valve, but when I run at full speed, I only detect about 70% of the pulses detected at slow speeds. Not good. Althought the "skipped pulses" seem to be proportional to the detected pulses at slow speeds. I am using an encoder that only runs at 60ppr, so I would think that my PLC (MicroLogix 1200) can handle this...I did the math before I purchased the encoder and thought I found the pulses to be infrequent enough that the PLC wouldn't miss any. My 2 trains of thought: 1) I need to use an interrupt for each encoder pulse since they occur so quickly (utilizing an EII), which I am not fluent in. I can find instructions to intitially configure the EII file, but I am unsure of how you are supposed to correctly set up the ladder logic to utilize the interrupt. 2) There is an electrical issue. The encoder I bought uses pull-up resistors. The resistor value I selected only drops the detected voltage to 14V from 24V. Is it possible that the encoder does not spend enough time in the "off" state at high speeds because of this high voltage value? OR does the usage of a resistor introduce a time-lag into the system which further complicates the issue? Any help would be appreciated, Thanks!
  17. Major Fault

    I have a compact logix with a major fault. Please see my attached file for the complete fault message.  Code 20 array subscript too large. or control data type to large or invalid. Has anyone observed this issue before.  The PLC is a compact logix model.  Every time, the controller is switched from program to run the major fault occurs within 5 seconds.  The fault can be cleared but then it comes back in a few seconds.  I have been told by my tech that no program changes have been made.  Could there be a hardware/wiring issue? Thanks much Document_1234.pdf
  18. need help for TIA V13

    Hello Everyone,  Our machine with PLC CPU 1214c, was program last year using TIA V13 professional. Now i need to add some Expansion module for additional sequence, but i only have here a TIA V13 basic. When i tried to search the hardware; yes it can be searched, but it will not upload the existing hardware (CPU+ other modules).  My question is, if the s7-1200 PLc was programmed by TIA v13 professional , does it can only  be edit  by TIA v13 professional? is there any chance that  the basic version can edit the programmed.    Thank you all in advance for your answers...
  19. Hello all, I am still fairly new to this forum and PLC's in general. I am trying to connect a EA9 touch panel via Ethernet to an Allen Bradley Micro Logix 1400 PLC. I am using Ethernet over serial because I need the serial connection to program while using the touch panel. I have given the Panel the IP Address 192.168.1.20 with a subnet mask 255.255.255.0 and I have given the PLC the IP address 192.168.1.10 with a subnet mask 255.255.255.0. The panel is not communicating with the PLC and I have very little knowledge on the subject, anyone's help would be greatly appreciated. The picture on the top is from the PLC and the picture on the bottom is from the C-More program for the panel.
  20. I'm trying to ramp up from zero to enable a NJ calculated random curve to never produce a negative position point:                                                     Calling the move "Offset", and using a MC_MoveAbsolute fb, the idea is to trigger the curve generating ST to start when the move reached 50mm.  (Wanted the variable "Ready" to go TRUE at the end of the ramp to 50mm)  .. Then, MC_SyncMoveAbsolute fb would continue from there, sending streaming position data to the LinMot Linear motor. As seen above. But, there's a problem.  Initially, I used the MCMoveAbsolute.Done to start the ST curve move sequence, which also ramps amplitude from zero, over a period of 3 seconds: Offset + [(a number that goes from 0 to 1.0 in 3 seconds) * (the mathematically generated position curve)]   The result is a "clunk" at the transition of the end of the ramp and the start of the curve. Not sure when "Done" happens... started to think perhaps it's when the fb is finished making the command to move, and not when the move has actually finished. So I tried an IF_THAN:                    That was kinda silly, because the ramp final position never reached 50mm ... "Ready" never set to TRUE ...  close, but no cigar. So the next step was use a Round instruction that actually monitors the position of the slider: and a EQ instruction that compares the two, and issues a "Ready" command to start curve the curve program:                  This produced the Minor Fault:  Axis 0x543B0000 Motion Control Instruction Re-Exicution Disabled Now I'm thinking this can't work because "Ready" will only be TRUE when the the curve hits 50mm (which is quite often, after it starts running ... 50mm being the new zero) However, It did start the curve sequence.. but nothing moved because of the fault... Soooo.. The question is: How can I do a smooth transition from the end of an Offset move to the start of the curve?  Or.. better still...How is an "Offset" normally done to any curve generating routine? Thanks much, Regards, Michael PS:   Here's a look at what's happening when I tried using State Tracker... and something to compare actual position at the end of the Offset move, and the start of the random sea curve: https://www.youtube.com/embed/BdpvC1yyKxU?rel=0&controls=0&showinfo=0      RSStart is the variable that powers the Random Sea ST program, and the SyncMoveAbsolute fb that drives the motor.  Cycle time is 1ms.  Probably would be quieter if I could 500us .. but the NJ is only a 101-1000               FYI... Delta Motion's RMC75E Motion Controller can make the Random Sea using LinMot's B1100-VF drive .. as quiet as a mouse.  But then, I think that controller has a cycle time of 1us!   Wondering if there's a problem with Direction or BufferMode:    _emc_Direction#_mcNoDirection or _eMC_Buffer_Mode#_mcAborting ????  Thanks for any ideas on the "Clunk" ... I may have to live with the "singing" ... sniff!  .... or use a Delta Motion Motion Controller ..      
  21. I have a c-more HMI and an Allen-Bradley 1200, is it possible to set them up with two AB 1764-NET-IAC+ to have my computer monitoring the PLC at the same time, I have established communication from my computer to the PLC through the IAC, but I haven’t been able to integrate the HMI, is it even possible?. This is been setup for training purposes, any help would be appreciated.
  22. I have been searching on how to import logic 500 tags to connected component workbench for panel view 800 project and striking out is there a way to do it? Project is to replace optimate  OM440  HMI connected to MicroLogix 1500 with a panel view 2711R-T7T. Replacing the controler is out of the question at this point. Tom
  23. Hello, I am currently installing a PLC control panel and due to space constraints, we will need to install the Panelview 600 HMI separate from the Micrologix. We purchased a 50ft Allen Bradley communication cable, but 50ft will not be long enough. We have about 70 to 75ft of conduit between the panel and the HMI. I would like to know what options we have for this connection. I read that for serial connection, we shouldn't go past 50ft. I understand the Micrologix 1100 has an ethernet connection and the Panelview does as well, but I'm not sure what changes would be needed in order to communicate through the ethernet port, instead of the RS-232 port. Any suggestions will be greatly appreciated.   Thanks, JCG
  24. Have a red lion HMI G306A connected to a micrologix 1500 plc. Communication working. I want to be able to change screen through plc as well as have plc be able to read what acreen is active. Had an old panel view hooked up and can use an integer to do this one for active screen and one for screen change called for from plc. Thanks for the help on this.
  25. Ethernet Global Data Comms Fault

    Hi All, We have a 4X Rx3i PLCs that use Ethernet Global Data (EGD) to talk to each other. At the moment we a facing EDG communication fault being generated and it trips the entire pumps What the likely causes of EDG faults: We have replaced PLC Ethernet Interface Modules-no fix We have tested the fiber optic cable-the readings show its OK Also,can someone explain what PLC heartbeat is?