Search the Community

Showing results for tags 'micrologix 1200 fault led blinking'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 97 results

  1. Tia Portal Programming Help PLEASE

    Hello I am having some difficulty writing code for a specific function using Tia portal and a S7-1200. I 10 Digital inputs and 1 analogue output set for 0-10V. When 1 DI is high I need the AQ to be at 1V, when any 2 DIs are high I need the AQ to be at 2, When any 3 DIs are high I need the AQ to be at 3V and so on.... I just can't work out the best way to do achieve this.   For a bit more info the to what the project entails the digital inputs are all coming back from DOL starters for woodworking equipment at workstations. When one of these starters is turned on a signal is sent back to the PLC DI card, this open a solenoid in extraction pipework and also increases the frequency at a VSD to extract the dust. So when more workstations are in use the higher the frequency of the VSD will be and the faster the motor will run allowing adequate extraction at all stations
  2. PLC occasionally going out of Run mode?

    Has anyone had an issue with Siemens plc's occasionally going out of run mode? I was doing some research and found that it could be due to a bad analog input. Is there a way to tell which input or output is causing this fault? I know I can create a hardware diagnostics error organization block but that only correct from what I've read.     Edit: I've added a screen shot of the diagnostics report. The fault that may be the problem is: Temporary CPU error: Serious firmware exception  CPU changes to DEFECTIVE mode (system reaction)  This plc / system was installed 2 year ago and we've had this problem occasionally since. I'm guessing the wrong firmware was used during the install. Will try upgrading firmware this weekend.   
  3. Stepper Motor Control

    can anybody Know how to control stepper motor using PLC
  4. Hey, I have a 1763 L16BBB...when I plug the 1762IF20F2 analog card in, I get a 0189h error code. Any help would be appreciated. Currently looking at doing a bootp on the plc to get online...no ip
  5. Hi All, I have an AB servo TLY-A110T and 2097-V31PR0-LM Kinetix 350 drive. I thought that it was fully configured and ready for tuning, but when I issue a MSO it immediately starts to spin the shaft (no load yet). This lasts about a second until a Physical Axis Fault, Excessive Velocity Error occurs. I've double and triple checked the feedback and power wiring, and everything looks right. Is there anything else I can check? What can I do to trouble shoot this if I can't even give an MSO? Any insight is greatly appreciated.
  6. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  7. S7-1200 timer

    Hi All I am struggling to get a TON in TIA v15 to work properly (s7_1212). I have tried reading what i can but still dont understand why what i have is not working.  I have attached a screen shot. I am trying to achieve a bit that is active for 1 scan cycle and resets every second. Coil1 is just staying active however and not resetting the timer.  What i have written works in Connected Components Workbench and other plc software i have used. What am i doing wrong? Thank you in advance. Trevor  
  8. faulted processor

    Hi I'm a bit new to Siemens, we;re an Allen Bradley plant...until now. we just got a brand new used press and it has a seimens controller on it. The press doesn't seem to have any manual functions so I as asked to move the cylinder, but I can't until I clear this fault. it won't do anything.  I'm told I'm working with an older processor, s7 300?I don't really know seimens that well.  I saved the diagnostics buffer as a text file and pasted it below. in case that helps solve my problem. I'm thinking it's just having trouble communicating with remote IO, but I'm not sure. I might be trying to communicate to a robot that used to be there that no longer is.  Diagnostic buffer of module CPU 314C-2 DP Order No./ Description            Component                         Version                        6ES7 314-6CH04-0AB0               Hardware                          5                              - - -                             Firmware                          V 3.3.11                       Boot Loader                       Firmware expansion                A 37.12.12                     Rack:                             0 Slot:                             2 Serial number: S Q-EDU050142014 Event 1 of 10:  Event ID 16# 2522 Area length error when reading Global DB, word access, Access address:    262 Requested OB: Programming error OB (OB121) Priority class:  1 Internal error, Incoming event 10:36:07.052 AM  04/17/2019 (Coding: 16# 2522  0179  0024  0106  0000  0000) Event 2 of 10:  Event ID 16# 2522 Area length error when reading Global DB, word access, Access address:    260 Requested OB: Programming error OB (OB121) Priority class:  1 Internal error, Incoming event 10:36:07.052 AM  04/17/2019 (Coding: 16# 2522  0179  0024  0104  0000  0000) Event 3 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     40 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.052 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0028  0000  0000) Event 4 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     36 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.052 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0024  0000  0000) Event 5 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     38 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.051 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0026  0000  0000) Event 6 of 10:  Event ID 16# 2522 Area length error when reading Global DB, word access, Access address:    262 Requested OB: Programming error OB (OB121) Priority class:  1 Internal error, Incoming event 10:36:07.051 AM  04/17/2019 (Coding: 16# 2522  0179  0024  0106  0000  0000) Event 7 of 10:  Event ID 16# 2522 Area length error when reading Global DB, word access, Access address:    260 Requested OB: Programming error OB (OB121) Priority class:  1 Internal error, Incoming event 10:36:07.050 AM  04/17/2019 (Coding: 16# 2522  0179  0024  0104  0000  0000) Event 8 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     40 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.050 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0028  0000  0000) Event 9 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     36 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.050 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0024  0000  0000) Event 10 of 10:  Event ID 16# 2943 I/O access error, writing P area, word access, Access address:     38 Requested OB: I/O access error OB (OB122) Priority class:  1 External error, Incoming event 10:36:07.050 AM  04/17/2019 (Coding: 16# 2943  017A  0020  0026  0000  0000)
  9. Hello! I am using S7-1200 PLC 1212C AC/DC with configured Modbus TCP Server. I can already read/write Inputs/Outputs (Coils) and Memory Words. However I'd like to read/write Memory BITS. Is it possible? If so, how? What addresses should I use in TIA portal? And which function codes on client side? Thanks in advance!
  10. Hello! I am beginner in PLC world, also in SIEMENS PLCs. I managed communication over private network. Now I have a problem that I get same values on all inputs. Picture below shows my configuration of driver and data monitor. First picture shows values when input I0.0 is in state 0. Second picture shows values when input I0.0 is in state 1. Physically on PLC only input I0.0 is forced to 1, input I0.1 stays 0. But data monitor shows both inputs as state 1. Where is problem? Is problem in PLC program, TIA portal? I saw some guys using DataBlocks but I am not skilled enough to use it. Third picture shows simple PLC program on my PLC. Please help. Thanks in advance!
  11. Hello! I am trying to connect my PLC with SCADA. I am using S7-1200 1212C CPU (RELAY outputs). My SCADA system is iFIX 5.8 with driver S7A. I am trying to establish connection via GPRS router (TCP/IP). Port being used is 102 (default by S7A driver). In my company we have private network, SIM card in GPRS router gets static IP (set by RADIUS server)  which is 10.247.XXX.XXX. My PLC has IP 192.168.0.10 set in Project. I am not sure what am I doing wrong. How to correctly set IP address in PLC to communicate in private network via GPRS router with static IP? I already enabled TCP port 102 in my router but I am not sure to which IP should I enable it because I am not sure if IP address set in PLC is correct. Should I use some communication blocks in program? I also enabled PUT/GET function (see attached pictures). Please help. Thanks in advance! :)  
  12. Have a micrologix 1200R 1762-L40BWAR.  If anyone could help with providing the following information: Need a communication port with single receptacle that will mount through the door of electrical enclosure and then the communication cable (6 to 10') that will go from the com. port to the micrologix. Thanks
  13. Does anyone have an example piece of ladder logic, created on a Micrologix 1200, using ASCII to READ and Write to a serial device?  I am building a ladder on a Micrologix 1200 that will send data to an old CNC once a certain ASCII instruction is received on the PLC.  For example, when the machine spits out an ASCII "1", the PLC will see the "1" and send out a three digit number depending on a sequence of discrete inputs.   Thank you,
  14. Square Wave Problem With Micrologix

    Hello all, this is my first post. I am using an AB Micrologix 1400 (1766-L32BXB Ser C FW 21). I was trying to generate a pulse train using the PTO instruction. I have modified PTOX funct. file. The ladder is just a simple XIO followed by PTO, (The Quick Start ladder from 1766-RM001). When I looked at the output waveform on my oscilloscope, I noticed that it wasn't a square wave. I decided to run it at several different frequencies to see how the wave form would change. At 10Hz i got a square wave. As I increased the frequency the falling edge became sloped and almost horizontal. Is this how the output should behave? The data sheet indicates a max frequency of 100kHz, but at frequencies over 150 Hz. The wave form looks like the output of SMPS. 
  15. LED status on MLC1200

    Hi, Can someone provide information about function and interpretation of each flashing or steady LEDs on MLC 1200. For example where to look for when Fault LED flashes during normal operation and so on. Thanks in anticipation that someone will help. Regards
  16. Hello, I'm new to PLC Programming, with just a simple course about the basics. I've got a micrologix 1400 PLC which seems to have had its program wiped when the battery was replaced. I've had the company that supplied the machine it runs send me the program for the PLC. However, I don't have any software to communicate with it, and download the program to the PLC. I was hoping some one here could help me out and direct me towards what I will need to do to get the new program installed on the PLC. Thank you 
  17. Hello I have a scenario that's been bugging me for some time now. The scenario consists of a Micrologix 1400 that I need to control it's output from modbus/tcp. In detail what I really need is to be able to manipulate the O0:0 through modbus/tcp. The PLC would be the master and I would be the slave that triggers the connection to the master. I'm using a Modbus-Client on my PC and that should be the slave. Any idea as to how I can manage that? Currently I can send data to the master but everything is "stored" on B10 and I have no idea how I could write directly on O0. Thanks a bunch guys. PS: I'm borderline noob. 
  18. 1785-L40E

    Trying to figure out a fix to a processor issue, I have 2 1785-L40E processors a series E and F. Both when inserted into the rack and powered up go straight to a solid red BATT and PROC light as well as a Solid amber Force light, they both wont even attempt to start a boot up sequence. When connected through DH+ and ENET there is no visibility to either of these processors. These are refurbished processors.
  19. Hi my problem may have a simple solution but i cant work it out. I need to use the Divide function but it wont let me use a decimal point in either Source A or Source B. Is there a way to use a decimal point in Logix 500 Math instructions? Im using an AB Micrologix 1400 PLC. Can you only use math instructions with whole numbers? is there a way around this? Thanks James
  20. Hi my problem may have a simple solution but i cant work it out. I need to use the Divide function but it wont let me use a decimal point in either Source A or Source B. Is there a way to use a decimal point in Logix 500 Math instructions? Im using an AB Micrologix 1400 PLC. Can you only use math instructions with whole numbers? is there a way around this? Thanks James
  21. S7-1214C All LED Blinking

    Hi everyone. Recently I get a S7-1214C ac/dc/rly plc, whenever i connect ac power all the indicating LED i.e 'Run/Stop , Error & Maint' start to blink. I can't upload or download any program. In TIA Portal V13 only accessible node is not shown. Anyone encountered the same problem? Please help me. Thanks in advance 
  22. Communication

    good evening. Someone can give tips on how to configure and physical the application with the following items: Advanced Interface Converters (AIC +), PanelView800 2711R-T7T A and MicroLogix 1500 Programmable Controllers My doubts are about the configuration of the communication, and I have doubts about the physical environment and protocol to be used.  
  23. hi there is a 1215c and a fatek B1 plc here. 1215c as master and fatek as slave. i want to read 10 16bit words from Fatek to 1215c and i use Modbus rtu 485. i have a problem with what comes from Fatek To 1215C. thx 2018-08-25_11-56-16.mp4
  24. Hello :I'm the creator of an Android HMI app,  I recently added Ethernet/IP connectivity with MicroLogix and SLC AB PLCs, but I have only been able to test it with a MicroLogix 1100.I'm really not sure if it works with SLC or with other MicroLogix models.If someone could try it, I would appreciate it. To access the test, from the Android device, open this https://play.google.com/apps/testing/com.suppanel.suppanel on the web browser and install the Beta version.On the application you have to open the "EIP MicroLogic SLC Test" panel that contains some instructions. Thank you very much !
  25. Hello everybody. I need to learn PLC programming. I already have some experience with Ladder language and PLCSIM so now I need a real PLC to do more practice. I was going to buy the following unit: 6ES7211-1BE31-0XB0 http://www.eibmarkt.com/isroot/eibmarkt/Files/DatenblattE/NS6102812.pdf It has 6 Di, 4 DO (Relay) and 2 AI, that's more than enough for me to do some practice. Do you think it would be a good idea to buy it? Or maybe this PLC doesn't have some important component or device needed to work properly? (my company will give me the software). Thank you to anyone will help me. Have a nice day, Edoardo