Search the Community

Showing results for tags 'high speed pulse output'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 62 results

  1. Best Practice Rack 0

    Is there any reason not to have input and output modules on the same rack as the processor and Ethernet cards? We have RIO’s and sometimes have networking outages, I want to move critical IO to Rack0 the same rack as the processor, is this bad practice?  I've seen architecture for BMS that only have Ethernet cards and processors in Rack 0... 
  2. Hello guys, I am running an application for packaging measurement using a sick DFS60B incremental encoder (programmable from 1 to 10000 PPR). In more detail, it passes packaging on a conveyor belt and we have created an inspection station and an expulsion station (defective packaging), so we use the encoder to check at specific points of the packaging for defects (we use special sensors to check defects). ) (there are four in total). However, the problem we are having is the following: When reading the encoder in the PLC, the same means that performs "jumps" and does not enter the windows (GRT and LES) created on the ladder, ie, as if it were not continuous. . I understand that because the VHSC24 card works at 1 MHz in counter mode, this type of problem should not occur according to our application is not even 100 KHz. For example, our case: Using 1000 PPR and the motor speed (coupling output) is 3600 RPM (in practice it is around 1750 RPM) the frequency is calculated as follows: F = (PPR X RPM) / 60. : F = (1000x3600) / 60 = 60 KHz, ie 60 KHz is much less than 1 MHz, I think this kind of problem does not occur. Application Info: . Studio 5000 V31 . PLC Model: Rockwell 1769 - L19ER-BB1B CompactLogix 5370 . Encoder Card: 1734-VHSC24 / C . Incremental Encoder: Sick, DFS60 up to 10,000 PPR and HTL Electrical Interface. Using a 200 mm circumference / perimeter wheel. . Motor Nameplate Data: 1670 RPM, 0.37 kW / 0.5 HP, 60 Hz . Inverter: Weg CFW500, Output Frequency 62 Hz. Card Settings we use RPI: 2 ms Type: Counter, but we already use it as Encoder X1 Store Count Mode: Disabled Filter: No Filter, but we use 50 KHz and 5 Khz filters in our tests. Counter Attenuator: 1 Wiring Diagram VHSC24 We turn on encoder A at input 0 and encoder Aret at input 1 In logic (Structured Text) Using the PMUL instruction to convert encoder (Pulse) data to mm scale. (Ladder) The window comparisons part (GRT and Les) and other part of the process. We emphasize that we performed the tests also only with the reading and comparison part of the data, excluding the other parts, precisely to verify the issue of Scan, but the problem persisted. If anyone here in the forum has some information that can help us, I would appreciate it.
  3. Control Panel

    Is it possible to view the values / states of all inputs, outputs and workbits (e.g. 64.00 through 64.15 on Omron CQM1 PLC) on a single screen or control panel within CX-Programmer software?  I'm trying to troubleshoot some ladder logic that I wrote and need to know the values of 5 or 6 inputs/outputs/workbits simultaneously.  Having to scroll up and down through my ladder logic repeatedly does not work well with code that changes state every 5-10 seconds or so. Any help is welcome.
  4. Using a AD041 and DA041

    Hi, I'm using a CJ2M CPU 33, and also a CJ1m Ad-041-V1 Analog Input and DA-041 Analog Output card.  I am using the Analog input to measure my current in my one heating application and  Ihave that reading and scaled correctly, but now  I want to use my Analog output to replace the Rheostat  we have in the system. I'm having some issues setting the range and getting voltage to vary. I also am a little new to Analog Outputs and don't know what I'm doing wrong. I have attached my program here. Any help would be greatly appreciated. Analog Heat.cxp
  5. Hi, I can’t find an answer to the following and I was advised to ask it here.I’m programming an Omron CJ2M with an MD212 high speed I/O card. I usually do all my programming in Structured text, simply because I like it a lot over ladder or sft.Now, if I want to read the hight speed counter (incremental encoder), I have to make a ladder section and use the PRV instruction to store the present value in a chosen location.The manual says the current PV is stored in A271, but I can’t get a readout there. Apparently the only way to read it is through this instruction.Does anyone know if there is an equivalent to the PRV instruction for Structured text? or another way perhaps? Again, when I check the actual memory adress, there’s no value there withouth the use of the PRV instr.
  6. I am controlling the powerflex 527 drive with MSO instruction, first setting the drive on and then running the motor with MAJ instruction. After MSO instruction, motor is rotating about 2 sec and then stops to wait the  MAJ. I have not find any solution for this. My configuration is frequency control, no feedback, sensorless. One hint i found from the rockwell pages but it did not help me. Rated slip speed is set to zero.  
  7. Omron Hardware

    Please let me know if it is allowed to sell PLC hardware on your forum. I accumulated lots of Omron hardware  that I want to get rid off. Here is the list, I have several of each type, asking $12 each plus shipping. All in working condition.  Base Unit C200HW-BI051 Base Unit C200HW-BC101 16 Point DC Input Module C200H-ID212 16 Point Digital Output Module 24VDC C200H-OD212 Power Supply Module C200-PA204    
  8. OD212 Card Outputs not powered

    Hello! I'm running into a problem with a malfunctioning OD212 output card on my PLC.  I figure the problem has something to do with my wiring, because I've put 2 different cards in with the same results. The card is unable to switch any of the relays I have as outputs although the indicator lights on it are functioning as expected. The setup it is in is: A PA202 power supply, followed by a CJ1M CPU13 CPU, 2 ID211 input cards, and 3 OD212 output cards. The bad card is the second OD212. All of the other cards work fine, it's just this one that's been having problems.  8 of the terminals on the bad card are hooked up to relays that each draw 0.02A and two more are attached to relays that draw 0.05A. So in total that's 0.26A if all the outputs are on at the same time (which they never will be.) I saw someone was having a similar problem to me on the forum, which was solved by switching out the PA202 supply, but that didn't work in my case. I don't think the problem lies with the PLC or the card's placement in the rack because I switched the card's position with the one next to it (output card 2 switched with output card 3) and tested that card (output card 3 in output card 2's place) without hooking it up to the original wiring and it worked just fine. However, I was still getting the same issue with the bad card even though it was in a different position, leading me to believe that I fried it somehow. Some other quirks of the bad card are that its outputs do not turn on and off with the indicator lights like how the other OD212s do. Below is a link to a video that shows this. The bad card has already been switched with the one next to it in the video - so it's on the end, but it's original position was second to last. https://youtu.be/wTvvGCHFpsc ( you may want to watch it at half speed ) So what I'm wondering is: how am I frying these cards / Is the problem easy to fix or will I have to send them to Omron? Thanks in advance!  
  9. Hello      I have a cj2m processor and md211 module and I want to read position from rotary encoders who are put on the stepper motors. I use high speed counters to count the number of(I made settings like in documentation) but every time I read velocity.   In first two picture I have 3 blocks for PRV function , I set port specifier [#0, #1 and #3] because on this ports I command 3 axis. Please help me!              
  10. Hi there, is somebody experience whereby the output of the 1769-OF4Ci is not responding on the value entered?.  Setting: 4-20mA Res: 0- 32767 - PID set whatever value I key in the output current remained.  please help. Ganie
  11. hallo everyone ...i use mitsubishi Q00UJCPU and QD77MS2.. i try to make a speed control program and the speed wants to be changed during servo operating, i use dedicated instructions ZP. PSTRT1 (axis 1) and have tryed but it was only successful to change speed with "change speed control" function once ... is it like it? cannot change "change speed control" many times when servo operations?
  12. I am new to Automation Direct software and how the programs are written. Can anyone explain how they handle the analog outputs? My processor does not support the IBox that makes life easier, so I am having to do it the old hard way. I understand most of the logic of how its done for sending data to one channel but I don't understand how the channel selecting works. Can someone give me a programming example or explain how that works? I am looking at the online manual that Automation Direct provides for you for the analog module but I am having a difficult time trying to wrap my brain around how they do their analog stuff ><
  13. PLC Mitsubishi High Speed Counting

    Dear friends, I want to calculate the flow with the help of a flow sensor that has 650 pulses per litre. My question is that can i do that with the help of plc FX1N ? can plc count such fast pulses and how .. need some help
  14. Hello I have a scenario that's been bugging me for some time now. The scenario consists of a Micrologix 1400 that I need to control it's output from modbus/tcp. In detail what I really need is to be able to manipulate the O0:0 through modbus/tcp. The PLC would be the master and I would be the slave that triggers the connection to the master. I'm using a Modbus-Client on my PC and that should be the slave. Any idea as to how I can manage that? Currently I can send data to the master but everything is "stored" on B10 and I have no idea how I could write directly on O0. Thanks a bunch guys. PS: I'm borderline noob. 
  15. About InverterRefresh

    Hı guys,  I will design new project  but I dont know that how can ı use  FB  at the   attachmend files ı wanna send   speed  referances  for 23 motors with rs 485  I will not use   start and stop  function  for ınverters with modbus   ıt  will be doing   probably  only speeds of the motors     1 )  Plc CP1EN40S DT1D     2)   hmı : nb7 twb0        3  ınverter s  :  V1000   VZABOP4BAA how can ı use registers numbers of the ınverters so ı need simple program    thanks for  everythings [767]InverterRefresh.zip
  16. High-Speed Counter Input

    Hi, I working on reading impulse from the input. I am using M8000 as a contact, on the coil [C235 K9999] and it is working fine on the lad, but the problem is I need to applicate sth like that in structure ladder but I dont know how. I found function on the image below but it is for FX3U. I know that 2-phase 2-count input use OUT_C(for example EN True| CCoil CC251| CValue K0) and then DMOV(for example EN True| s CN251| d D100), so is there any method to read impulses from the input? .Thanks in advance. PS I have Mitsubishi FX3G series.  
  17. Hello Everyone, I am struggling with interfacing Incremental encoder with FX5U PLC, Does anyone have parameter setting and sample program for same. i am unable to fetch counts...   Encoder: 500ppr, 24V line drive, A-B phase,  PFA datasheet
  18. Omron Servo Encoder

    Hello All  I am new to PLC programming , i have a question regarding omron PLC and High speed counters. I am using Cp1H-XA model plc . I connected HSC port 0 with a encoder and i was able to get the speed of the encoder using PRV2 instruction. Now i am trying to connect the second  encoder from the servo motor that i am using to HSC port 1. I am getting the PV signal using PRV instruction . Is there a way to calculate the speed of the servo encoder connected the HSC port 1 using PRV command , since i can't use the PRV2 command for the servo encoder .   Thanks in advance .
  19. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  20. ANALOGIC BIPOLAR OUTPUT - HELP

    Hello everyone,   I'm a student who recently started programming, and I could really use some help.  I have a CPU-31 CJ2M OMRON PLC and a ADO41-v1 analogic card. I need help programming an analogic scale with a bipolar signal -10V to +10V to then control a drive, which will then control the motor. If anyone could help me out of give me some examples I'd be really thankfull.   Thanks!
  21. Hi , I need to read encoder value on PLC / module QD62E and those value to be seen on the HMI , can anyoune tell me how to do it in to PLC in order that encoder start counting ?
  22. I am trying to connect a Delta ASDA-A2 Servo internal motor encoder to a Delta DVP28SV high speed counter input.  I was successful in connecting the servo to the plc on position mode with an external encoder connected to PLC high speed counter.  Currently having trouble in finding the correct wiring between the servo drive and the plc to count the pulses from the internal motor encoder.  Attached are some figures from the servo drive manual. OA --> X0 is obvious, tried s/s to GND, COM-, VCC and VDD... no result. Any suggestion would be highly appreciated.  
  23. CP1L

    Hello,     I have one question for everybody. I have aplication with pulce control output. I need control the position vit absolute position mode. My question is, it's possible make origin without move. ( It is possible make preset the origin ).      Thank you for your answear.      Regards Beny
  24. Gang, Hooking up an Automation Direct P2-32TD2P to an AC/DC LED and noticed the LED is always "on" a little bit. When the output is on, the LED is certainly on, but when the output is off the LED is still on by a fractional amount, not much but it's plainly noticeable the room lights are off. The CPU can be in Stop, no matter, power just has to be on. I think this has to do with the card's load disconnected error functionality. +24V and some fraction of amps is always present at the output whether the output is on or off. I talked with automation people at work who noted there is an Allen Bradley system that does the same thing, it caused them a problem, they had to use a relay or etc to make an off output actually be off. Has anyone dealt with this? I'm new to the Productivity software, but there doesn't seem to be a way to just turn it off in the IDE. It seems ridiculous to have to wire up transistors or relays just to have off be off. Thanks for any ideas.
  25. Hello, I have a cp1h-y20dt-d (sinking output) plc supposedly to be wired to a servo controller. The pulse control method is Pulse/Direction. I've did some manual research on the PLC and found the following diagram attached Untitled. Since the diagram above doesnt show which terminals does it connect to in the CP1H side circled red, I want to ask if those connections belong to the following diagram attached Untitled1? If so, assuming im planning to use only Pulse Output1 (Pulse/Direction method) from the PLC side, is the connection from the first diagram no.1=CCW0- , no.2=CCW1- , no.3=COM (connected to -ve) *Note: these diagrams are from omron's manual SYSMAC CP Series CP1H-X40D_-_ CP1H-XA40D_-_ CP1H-Y20DT-D CP1H CPU Unit Your replies would greatly help. Thanks and best regards, Summer