Search the Community

Showing results for tags 'flex IO'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 8 results

  1. Flex I/O Rack

    I am in the middle of doing a retrofit for a old PLC5 and i decided to upgrade it to a Control Logix. With how much I/O I was needing the price of the system was going to be very pricey. So I decided to use my main rack as a control logix and use Flex I/O for my remote racks. I have never put together a Flex I/O rack so I am unsure of what I need for this rack other than my I/O modules and a communication module. Could someone give me a list of what is needed for these systems? 
  2. Flex i/o outputs shorting

    Hello everyone! Im hoping someone could shed some light on a issue im having. Im having issues with a 1794 ow8 output module. This module is used to control 8 hydraulic cylinders that push biomass into a burner. The overall problem is that roughly once every couple months a output will short in the on state and force a coil on, activating the vavle full time and burning out the coil. Each seperate output is fused on the module with a 2a fuse and each modules incoming power is also fused at 2a. The output that is shorted did not blow its fuse. The 'ON' light is not activated but 120v still runs through it. Since each valve has 2 coils and one is forced 'on' the main fuse will blow once the second half of the valve is activated because the valve is fighting itself. It is not just this one module, this happens on other modules that serve the same funtion as well. This is a contractor installed system but they have been no help so im left trying to figure it out. Could my seperate inputs be fused too high at 2a for this type of card. These are parker valves 120v 60hz with a max 1500psi pushing wet hog/chips. Any suggestions would be really appreciated!
  3. Greetings, I'm here in my home lab trying to acquire a working knowledge of UDT's.  I've had to work with them in the past in large existing programs and they were a pain to track down and find out what IO they were really controlling.  I have a decent understanding of what they are and I've created several to play with here using my softlogix processor and a digital flex IO rack. My issue starts when i'm trying connect my UDT's to the physical IO.  it looks like I cant use a simple move instruction (which would be way too easy and exactly what I need)  I have a flex IO 8 point output.  Local:1:O.Data[0] I have a UDT consisting of (see attachment) Valve001  Valve001.Out     Valve001.Out.OPEN     Valve001.Out.CLOSE   Valve001.In     Valve001.In.OPEN     Valve001.In.CLOSED I have a copy instruction set to copy Valve001    to Local:1:O.Data[0]     Length 2 that allows the Out.Open and Out.Close UDT's to control bits 0 and 1 of the 8 bit output . .... great. Now I have another UDT setup to control lighting... Door   Door.Out.OPEN   Door.Out.CLOSE I want to control bits 2 and 3 I make another copy instruction in a line before the original copy instruction that states Copy Door to Local:1:O.Data[0] Length 4 but i'm really just fighting for the same 2 bits that the valve controls.... how can I control bits 2 and 3 for the door/lighting logic using these UDT's?   and that's not yet getting into having physical inputs moved/copied to the UDT input bits. thanks!!    
  4. Gentleman…   Does Rockwell have any simulation PLC code that mimics an SMC-Flex soft starter?  Since we are using those (as well as the E3+ and E300) I would like to develop a model environment for starting of several drives.  In a specific case, we may have 3 or 4 drives in a pool of drives in which only a subset must be running at any one time.  Development of ladder logic for starting and maintaining those drives running while considering various fault conditions and startup issues would be very helpful in our environment.  I would like to be consistent among various areas within our plant that we incorporate pools of drives, from 4 to 2.  Having the ability to test in the lab would be very beneficial.  Thank you, David
  5. Hello, I am new to this forum and I am looking for some help. I have to create a block mover system using the controllogix , I know that I must use a SQO as I have done this process without a Flex I/O on a SLC 500 before. Currently I am getting a error while dealing with the array can anyone show me an example of a SQO in 5000?   Thanks
  6. Greetings, I'm ok with RSLOGX 500 but am an absolute beginer with RSLOGIX 5000 and was wondering if anyone had any simple sample code just to study. I would love something using analog input and or analog output. thanks in advance.
  7. First of all im using a softlogix 5860 processor connected via 1784 PCIDS card to the 1794 devicenet adapter. my first module is a 16 bit DC input followed by a 16 bit output and finally my 2channel input/ 2 channel output. I can write code in 5000 for the digital IO's just fine and i have the .dnt file setup correctly with all lights green and i can see voltage change from rsnetworks when i monitor the input from the 1794 ADN (setup for 0-5v). From the reading i've done, i know i have to use block transfer msg and there is a sample file included with the version of rslogix that i have but its setup with different controllers and adapters. I've read anything i can get my hands on online from rockwell but the docs on these adapters only show the setup example using the ethernet IP version. in the ethernet IP version you can right click on the 1794 IP adapter in rslogix 5000 and add the module.... you cannot do this using the devicenet adapter. I can include my basic logix file but theres not much to it since I have no idea where to go from here. If anyone has ANY experience with this i would be forever greatful thanks in advance.ANALOG.zip
  8. Greetings, I'm about to begin a new job taking on a major operation drive by controllogix processors and tons of flex I/O modules.... its a big plant and a huge job to take on, and while i have alot of other automation experience and programing experience in other types of controllers i'm just learning PLC programing. The Good News is i have RSLOGIX 500 with a micrologix 1500 and RSLOGIX 5000 with a softlogix 5800 controller, a 1784 PCIDS devicenet scanner and a 1794 adapter with 16bit dc input a 16bit dc output and a 1794-IF2XOF2I 2 channel output 2 channel input to learn with. I have set the devicenet system up without the analog module, figured out rsnetworks enough to be able to write simple code enough to toggle outputs using the inputs.... the problem starts when i add the analog module. If i let rsnetworks scan on its own it finds the analog module but sets the I/O summary as 4input words (2 for the adapter and 2 for the digital input module) and 4 output words (2 for the digital output module and 2 for the analog module) however, it will not allow you to browse down to the bit level in the IO summary. IF however i go into the I/O summary of the 1794 and hit the defaults button it sets the input words to 5 (I/O only) and output words to 3(I/O only) If i download this to both the 1794 and the 1784 scanner my IO light goes red on the adapter and i get the errors listed in the log at the bottom of one of the screenshots im including. Anyone have any experience with this? anyone know what I should set the Input word / output word size to or what else i could be doing wrong? thanks so much in advance.