Search the Community

Showing results for tags 'explicit message'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 9 results

  1. Hi Everyone,   I'm having an issue with getting an OMRON CP1H with an EIP21 module using explicit messaging back and forth with an AB PLC.  I'm using a CompactLogix L16ER to test the setup in place of the future Micro850 that will be used.  I've used the Network configurator to set up tag sets with instance IDs for the consume/produced tags.  The data being transmitted is 240bytes in the form of an array of DINTs.  On the AB side I've setup a get and set attribute message with the setup as follows; Get Attribute (Read):  Service Code: 10 Class ID: 4 Instance ID: 111 (Matches Network Config) Attribute ID: 3  Set Attribute (Write) Service Code: E Class ID: 4 Instance ID: 101 (Matches Network Config) Attribute ID: 3 The MSG command executes as expected on the AB without error.  The get attribute works beautifully, but the set attribute completes with no response on the OMRON (no write).   Am I missing something here?  Thanks!
  2. Hi all,  At my work, we are unfortunately still using GX IEC Developer 7.04. All of a sudden I can no longer open any project at all with my GX IEC Developer. I can start the program just fine, but as soon as I choose a project to open I get "cannot initialize communication manager". And after this, I get another 2 "cannot restore parameter file. param.tmp not found" and "cannot restore transfer setup file! cnct.tmp not found!". Doesn't matter which project. And I have opened these earlier with no problem for years. I have tried reinstalling ALL Mitsubishi software on my PC. And restarting PC. I can't find a link to any other changes I have done on my PC either... Does anyone have any idea how to solve this? Best
  3. SLC 505 Message to TCP Port

    Hello I have a SLC5/05 and a Microscan MV40 smart camera which receives commands to a TCP port. Is there a way the LSC 5/05 can send a command to the camera using the MSG instruction or any other instruction? I would appreciate any advice 
  4. Version 1.0.0

    43 downloads

    This is an example (with code) on how to cycle user messages on the Keyence KV-D20 display. The code is written as a sub-routine that is easily incorporated into a Keyence KV series PLC. The code is proven to work - I've used it many, many times. A brief rung-by-rung commentary explains the basic operation of the code.
  5. View File Keyence KV-D20 How to Cycle User Messages This is an example (with code) on how to cycle user messages on the Keyence KV-D20 display. The code is written as a sub-routine that is easily incorporated into a Keyence KV series PLC. The code is proven to work - I've used it many, many times. A brief rung-by-rung commentary explains the basic operation of the code. Submitter pop29684 Submitted 10/04/16 Category Tutorials and Guides
  6. I am running a very large step based program on an NJ plc.  I have several status and alarm messages that I need to display on the screen during the auto cycle.  Right now I have set up unions in the PLC for the faults... but this is a very large program with a lot of possible faults.  I'm up to 9 16-bit array unions already.  It is just getting really cumbersome.   I would like to just write an INT to a data area for each fault and status message.  That way I can assign each step a 5 values to be used for faults and messages (ie: step one can use numbers 1-5, step 2 can use 6-10, etc) .  Then I want to have the NS display a message from the string table based on the value in the data area.  Is this possible?
  7. I am having issues trying to send an email using the message instruction and the ENBT module. Attached are snippets of my configuration of my message instruction and the error code that i am getting. I had IT look into it on their side and i shouldn't have any network switch configurations that is blocking the successful delivery of the message. Anyone have any ideas what could be the issue? Thanks!
  8. hi all, I have CPU 315 - 2 DP. I can't download program from S7 manager to CPU. I have message Help on Message 33:17075 Description: All stations on this subnet must have the same value for the transmission rate. The interrupt may not be assigned for other hardware components. The MPI addresses in the network must be unique, meaning each address may only be assigned once. The local Station address must also not be greater than the highest station address in the programmable controller. Remedy: Call the program "Setting the PG/PC Interface" in the Control Panel. Under "Properties" set the transmission rate used in the network and adjust the local node address to match your network. Set a station address for your programming device/PC which is not higher than the highest station address in the network. Shorten your HSA address to match the PROFIBUS addresses of the slaves used. i put all the interface setting PC/PG on default but i've the same message. what i must do ? please some help.
  9. Hello! I have a problem with Allen-Bradley High Speed Counter card 1734-VHSC24/C. I need to make changes to the configuration parameter .OnValue1 (DINT) during the system is running. Now, for changing the parameter value, I need to switch off the module and this can not be done during the line is running. I think that maybe this can be done using the explicit messaging. I could not find information for this from internet, so now I ask you to help me with this item. If anyone have experience or knowledge of this, please help me. I do no have experience using explicit messaging. My configuration: Studio 5000 Logix Designer V24.00, 1756-L71S V24.11, Ethernet/IP, 1734AENTR, 1734-VHSC24/C countermodule.