Search the Community

Showing results for tags 'ethernet modbus tcp'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 259 results

  1. Hi I am using a P342020 together with a HMID642 Magelis Panel. Using Unity Pro I have successfully downloaded a program to the CPU via USB. The HMI Panel powers up into 'Initial Start Mode' and is asking me to 'Download the system from your editor.' How is this done? How should the ethernet connections be made? between PC (with Unity Pro and Vijeo), M340 and HMI panel and where do I set all the IP addresses? I guess there is documentation somewhere but couldn't find it...! Regards   Andy
  2. Graphic Operational Controller

    Please give me the steps how to communicate GOC with Laptop using Ethernet and serial port I have using Codesys for Programming
  3. hello everyone,, I use the QD03UDV PLC and the modbus QJ71MT91 module, I want to test the module using modbus poll but it fails continuously, and when I upload the program to the LED notification PLC "COM.ERR." the module is ON ... but in GX Works2 I have no errors .. why is it like that, can someone help me?          
  4. CJ2M-CPU35 and LS drives

    Hello, I want to do communication between CJ2M-CPU35 and LS drives. I am new to Omron.I searched the manuals regarding protocol macro.but it's bit confusing for me.please send if anybody have the sample program and document so that I can do it.Please support. Also I need to communicate Citect SCADA with CJ2M-CPU35 on Ethernet, please send me the documents if you have. Thanks
  5. Good Day, I am seeing intermittent bUs (communication bus) errors on 3 VFD's simultaneously.  These are Yaskawa P1000's with CM092 Industrial Ethernet Cards. There are Stratix 5700 switches between the drives and the Controllogix 1756-L75 CPU.  Happens every day to every week -- intermittent. Reading parameter F6-98, it indicates a 'connection time out'.  I don't understand why I would receive this fault.  IGMP snooping and querier are enabled on all switches, if that matters. I do not have unicast checked but Yaskawa said that didn't matter.  Packet time is 100 milliseconds.  I welcome any input on what might cause this.  One Yaskawa tech said I should set speed to 100 Mbps (now set at 10 Mbps). Any help appreciated.
  6. PLC as Modbus Slave

    Is there any function for Mitsubishi PLC to perform as a Modbus Slave?
  7. hello.   I've been trying to communicate this omron plc CP1L-EM30DT1-D, with a yaskawa inverter cimr-vu4a0004faa. but i can't figure out how to make de correct mov or configuration in de DM. i need to run/stop, change frequency.    some help, please. :) 485PRUEBA.cxp 485PRUEBA.opt
  8. Hi All  I'm struggling to a PLC using WAGO's e!cockpit software which I am new to.  In the network tab when I click to select "ETHERNET" from the "Scan Settings" area all that comes up is a drop down with "update selection" which does nothing.  As a result I cannot scan for the PLC's on my network. Has anyone got any ideas on this issue.  I'm running on windows 10, could that be a problem?     
  9. Fuel tank level automatic report

    Hello, I have a fuel level reading system in a 2000 gallon diesel tank. the system has a slc 5 05 of rockwell. I need to connect the system to a printer located in an office 300 meters away from the tank. can someone give me lights about the type of printer I need and what communication technology to use, preferably wireless. Thanks.
  10. Hello.. I have hmi Proface GP-4301TW, USB type B cable and ethernet cable. I want to transfer the program to the hmi but I cant. When I turn on the power of hmi,  a series of test appears and finally it looks like the photo below and I cant enter the offline menu.. can anybody help me to solve the problem?
  11. I'm trying to understand the basics of using a serial to ethernet converter such as this Comtrol DM-EIP-2101, with Studio5000 code. Basically I have a weighing machine that only outputs data via RS-232 and I need to send that data to a PC that will process it through a Studio5000 program and have the data displayed on an HMI using FTview SE. Is it as simple as just connecting the serial and ethernet to the converter and it does all the work? Obviously checking ip addresses and firmware will need to be verified. The main thing I am unsure of is the process of passing the individual data packets from the machine to the Logix code on the PC,  things like what the weight of the item was, was it over weight or under, etc....  Would there be an AOI or tags built into the software for a machine like this Checkweigher? I've worked with much smaller items like Cognex Dataman cameras and I know you can just use their AOI that allows you to simply call a tag if you want to display information like if a scanned barcode was correct or whatever. If anyone has done something similar I'd appreciate any guidance. It can be difficult getting the information from the manufactures so I'm looking for answers anywhere I can. EDIT: I guess I should also clarify that only using one or the other (serial or E/IP) is not an option. It will be a serial connection from the Weighing machine to the converter and then Ethernet to the PC.
  12. Hi there, Im having issues controlling ATV 320 VSDs over Modbus RTU with a M221 plc, does anyone have any pointers for me to look at? I believe I Have set everything up correctly but when I run the program on the plc the atv's just stay in 'NST' state I have included screenshots if they are any use   My speed reference in this example is taken from the memory word %MW0 which I am inputting via a HMI   I have addressed all my ATVs accordingly in there setting with the correct Modbus parameters and selected Modbus under the FR1 configuration, am I missing anything?? Any help is appreciated as I am really struggling   Tom
  13. Hi All, I am new with PLCs. Currently I have a project that required me to send a 12 alphanumeric (2D code scanned) from multiple CP1Hs to NJ101. Then NJ101 will directly send the data into a SQL (haven't made yet). So basically, there are a few hurdle that I face. 1) How send data from CP1H to NJ101.  - I have tried using _CPU010_SendData from CP1H but I'm not sure how to do the ladder or what to use on sysmac (NJ101) side. Btw, I really not familiar with sysmac.  This is the first project that I use sysmac.  - I have read about TCP IP, Fins/UDP and Fins/TCP but I'm not familiar with those method. 2) How to confirm that NJ101 has received the data from CP1H 3) How to arrange the data received from CP1H into SQL - This one I have a sample program that I can follow from my colleague. 4) Setting up a dummy SQL server just for the sake of testing. - I don't have any idea on this. I anyone have an application or software that can used to test the database function, please let me know.   Your helps are greatly appreciated!   Thank you! Bob
  14. 1769-SM2

    Hello. I have a communication problem between an L30ER and SM2 module. It gives me a message error 16#001e, extended err code: 16#0000_0002, Error Text :Embedded service resulted in error. I have a Lovato network analyzer connected to SM2 module via Modbus RTU, on channel 1. The setting in the MSG instruction are: Configuration:Service type - Custom, Message type - CIP generic, service code 4b, Class 33f, instance 0, attribute 0, Source CH1_REQ[0] - INT[10], CH1_RESP[0] - INT[10]; Communication: slot 4, port 2, channel 1,  Connected - not checked. baud rate is 9600, DSI/RTU is 5, format 8-N-1. the channel led from the SM2 module is flashing. I read the value at a 2s. The rung is: XIO.TON.EN+TON.2s.EN+MSG.EN. The Cable betweenSM2 and Net.Anal is a CAT5, pins 4(A) and 5(B) Maybe someone has a clue.
  15. Modbus Addressing in Weintek HMI

    Modbus addressing in Weintek HMI to poll data from Temperature sensor through RS485. In my system i have connected Temperature sensor to I/O Scanner has output in terms of RS-485 which directly connected to COM3 Port pin. No. 6 (as Negative) & 9 (as Positive) of HMI (Model No: MT8071iE) and HMI connected to PC via ETHERNET. I want to read temp on HMI screen via MODBUS protocol. So, can you please provide me instruction about addressing of MODBUS register in Easy-Builder Software so can read data of corresponding register. Because when i do compile i got an error like " Device no Response". I hope i will get reply from your side as Fast as possible to overcome this problem. Thank you.
  16. Hello I have a scenario that's been bugging me for some time now. The scenario consists of a Micrologix 1400 that I need to control it's output from modbus/tcp. In detail what I really need is to be able to manipulate the O0:0 through modbus/tcp. The PLC would be the master and I would be the slave that triggers the connection to the master. I'm using a Modbus-Client on my PC and that should be the slave. Any idea as to how I can manage that? Currently I can send data to the master but everything is "stored" on B10 and I have no idea how I could write directly on O0. Thanks a bunch guys. PS: I'm borderline noob. 
  17. All, I have been trying for days to find a way to control a yaskawa v1000 over Ethernet. I have been trying to use explicit messaging but I cannot find the instance class  etc in any of the yaskawa literature. All I can find is to use EDS files with RS5000 but I have a micrologix 1400 and I don't have that capability. If anyone has any recommendations let me know. Thank You, Liam M.     
  18. hy everyone.. I want to communication inverter SJ700 to hmi mitsubishi GS2017 for read an code error in interface HMI? is it possible to communication between them?
  19. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  20. I am needing some guidance on an application I'm working on. I'm trying to obtain data from a profinet slave device to an Allen Bradley compactlogix PLC. I am using a Prosoft PLX82-EIP-PNC profinet-/ethernet-ip gateway as a median to allow me to access the profinet data. In RSlogix5000, I have created an EIP Class 1 connection for the profinet controller and AB PLC (248 words of input data, 248 words of output data). The same structure is created in the profinet controller (248 words of input data, 248 words of output data). The profinet gateway and PLC are communicating properly. From my profinet slave device, I have a specification that the data is structured within a 23 byte format. Connecting to my profinet gateway, I can see this data. I have attached an image that shows the specification of the profinet data and the data values displayed inside the profinet controller. From the PLC side, I'm needing to be able to see this data and put it in meaningful values. I am using the profinet slave device's internal temperature as an example to work towards. I'm not sure the best way to be able to handle this data and structure it to a meaningful value inside the PLC. (I am using the device's internal temperature as an example to try and get into the PLC).   Thanks,
  21. Hello I have a problem with dl-ep1 ethernet modul. I connected the module to a IL-1000 sensor amplifier. There is some problem with the communication. How should I adjust ? I made some pic about the trouble. The sensor is a IL-600 laser distance sensor. I dont know yet how can I get the actual value.  Anybody knows how to set this modul ? If I think correctly after the right setting, if I check the sensor output:0 then, I can see the actual value of the IL-600 sensor. But unfortunatelly this part also not so clear for me, because I can connect about 15 sensor this ethernet modul.  Thank you so much if anybody help.
  22. WRITE MULTIPLE REGISTER MODBUS

    Hallo my name is Danu, i have a CP1E wirh CP1W-CIF11 and connect to modbus RTU device, i have done with write single coil, write single register,  read single register and read multiple register. But i try to write multiple register,  the indicator of CP1W-CIF11 is off and if i check d memory its no data. I attached my cx programmer. Can you help me create write multiple register in cx programmer?  Thank you AD4402-modbus edit edit edit edit edit.cxp
  23. Hello everyone! Briefly introduction, I would like to communicate and test the following hardwares: 1- Omron CP1E (using an Option Port CP1W-CIF11) ; and 2- Arduino Nano using MAX485 RS485 transceiver. The CP1E will operate in "Modbus-RTU simple master" as illustrated in image 01. The arduino will be in slave mode address 1 and the library used is "SimpleModbus NG" ( https://github.com/angeloc/simplemodbusng/tree/master/SimpleModbusSlave ). Taking the sample in official manual ( https://industrial.omron.eu/en/services-support/technical-tools/downloads#cp1e ) , pages 248-253 in the "CP1E CPU Unit Software User's Manual" (Image 04) describes a sample communication to an "Inverter Slave". I want to use the Arduino Slave as the Inverter Slave just to be sure that all previous steps are correct. Therefore, I would like to know: 1- As illustrated in Image 02, Am I missing any resistors? 2- Should I connect the GND to the FG? 3- In this scenario, the DIP switch setup should be as illustrated in image 03? Only DIP4 is OFF. 4- Can I test it just forcing A641.00 and checking the DM Area Data, as shown in Image 05? The code used in it is the following: // Wiring: Arduino and MAX485 // RX0 - RO // TX1 - DI // D2 - DE/RE #include "SimpleModbusSlave.h" enum { REGISTER_0, REGISTER_1, REGISTER_2, REGISTER_3, REGISTER_4, REGISTER_5, REGISTER_6, REGISTER_7, REGISTER_8, TOTAL_REGS_SIZE }; unsigned int holdingRegs[TOTAL_REGS_SIZE] = { 0, 1, 2, 3, 4, 5, 6, 7, 8 }; void setup() { modbus_configure(&Serial, 9600, SERIAL_8N1, 1, 2, TOTAL_REGS_SIZE, holdingRegs); } void loop() { modbus_update(); }   Any answer can be helpful. Thank you for your time!   Regards, Jose.  
  24. I have a cpu33 that I had issues with a bad battery and it loaded from memory card.  The version on the card was old so I decided to download the latest version from 2 days ago to it.  When I did, I lost communication through ethernet.   Can't connect through usb either.   The thing that baffles me is that I can ping the plc at the address and I get a reply.   Any help/suggestions would be greatly appreciated as I am not familiar with omron plc's at all.  Also on the display it cycles through Er HE 1P 07.
  25. I using easymodbus library to connect and read data from 3 PLCs CP1L but it run unstablely, sometime it disconnect and i cant re-connect PLC, it give error time out when i try to reconnect when it happen, i restart PLC and everything back to work. Someone please help me. I am new with modbus and omron