Search the Community

Showing results for tags 'ethernet'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 123 results

  1. I have a AB CompactLogix L43S with 1768 ENBT Ethernet/IP module. I would like to talk to a TCP/IP device (such as my laptop) from the PLC. How can I do this without using RSLinx? 
  2. I have a line that I'm integrating that requires the main machine (Q13UDVCPU) to communicate via the built in Ethernet port with 3 different up and downstream machines using FX3G controllers with FX3U-ENET modules.    We are using GX Works 2 software. So far I'm having no luck with the Mitsubishi documentation, or online.  Some (old) sources say it is not possible, I hope that is not the case. What I could really use is a working example program to look at and dissect.  But any help would be appreciated.
  3. Anyone know any free libary to communication with FX3u-enet-adp, please help me ? Note: I've used mx Component , it work very well but it is too expensive and I dont even know it can work in windows server 2012/2016 or not.  one more question, Is there otherway to make program run in other computer without install mx compoment, it is very huge to install in every client computer Thank for reading and sorry for my bad english  
  4. Communication error

    Hey Guys,    This is my first time on a forum like this! but i need a hand with something if someone could point me in the right direction.   I have a Powerflex 40 drive communicating over Ethernet/IP to a switch, That drive has four Powerflex 4's connected to it thru DSI connection. They seemed to be wired correctly and seem to be sound connections but when someone on the production hits an E-Stop it removes power from this bank of drives. (Which is standard here) . However, when they power back up i get an F081 Error (Comms lost) on the master drive and one slave. Also, the port light on the 20-comm-e(Powerflex 40) is faintly flashing about every 5 seconds and is the only light on. In this state, none of them communicate. However, when i unplug the DSI cable, the 20-comm-e powers back up to normal operation. I then plug the DSI back in and everything works fine.  Should i start replacing parts or is there some parameters/other wiring i could check?   Thanks guys.
  5. I recently had an issue where a system shipped to a customer's site with a mismatch between the IP address loaded into the CJ1W-ETN21 card and the node dials on the card itself.  We had been testing the settings of the card by pinging the address and had assumed if the node dials were wrong we would not be able to ping the card.  As we just found out that is not the case! Both our quality department and our customer's end user were able to ping the Ethernet card, but the end user could not establish FINS communications because the node dials were not correctly set. Is there a way to test that the dials are correctly set?    Thank you!!!
  6. Is it possible to add another AB Rockwell PLC to the network tree as a Generic Ethernet Module and use it as IO? Any idea where I would find information regarding assembly instance and size of I/O/C for AB Rockwell products? If possible, what are the pros and cons when compared to produce/consume and MSG instructions? Don't need to use it real world, just curious. Many thanks in advance.
  7. Hi all !    I need a help about connection between mitsubishi GOT Simple series (gs2110) to kawasaki robot via crossed ethernet cable on tcp/ip protocol. I actually have a fx3g for main unit of my project, and also i have a kawasaki robot for slave unit. My purpose is basically to control both with HMI. I used RS422 between plc and got gs2112 and I want to use a crossed ethernet cable between robot and got but i did not communicate with ethernet even between pc and got. There is a manuel which I found on internet about GOT2000  Connection Manual (Microcomputers, MODBUS/Fieldbus Products, Peripherals) I think i need to work on  microcomputer connection (ethernet) subject, what do you think about that ? I need all advices and ideas which come from you.   [ROBOT]--------Ethernet--------[HMI]--------RS422--------[PLC] https://electrobit.ee/web/file_bank/Manuals/operaatorpaneelid/mitsubishi/GOT2000/GOT2000-connection-manual-ENG.pdf
  8. Zebra ZT230 Ethernet/IP

    Does anyone have an .eds file for the Zebra printers. I need to use ethernet/IP from a CJ2MCPU31
  9. SUPERVISION OF A CHAIN

    I have 6 PLCs CPM2A and 4 PLCs CP1LM I'm going to network them to do the supervision and data acquisition from each PLC and connects them to a pc via an ethernet port So what are the hardware and software used?
  10. What am I doing wrong? I have an FX3GE PLC. I have set up the IP address 192.168.3.254 and I am able to connect with my laptop running GX Works2 version 1.501X. I also have a GS2107 that I have set up with IP address 192.168.3.18 (Default). I can communicate with my laptop running GT Designer3 version 1.151H. The HMI is still failing to communicate with the PLC. I have followed different threads on this forum, tried different port settings on the HMI. I have attached my settings. Is there anything else I need to set?
  11. We have been successful using the EIP4CCPU module in communicating Ethernet IP between Compact Logix And Mits Q PLC's. Always with the Allen Bradley as the master. However, we are presently trying to control a 520 PowerFlex VFD from the Q series as master.  Has anyone attempted this?
  12. Any tool to simulate Ethernet/IP for omron PLcs? I need to know the complete packate structure for Omron Ethernet/IP over Omron PLCs. I have read that we can use FINS command inside Ethernet/Ip packet . But how to get full pacakte structure.   Please help , it is urgent.
  13. Hi, I've been working with RSLogix 500, today i found that i was unable to connect to Micrologix PLC because in the RSLinx the Driver Ethernet IP that was configured to communicate whit PLC appears with a Red Cross. Yesterday everything was working. I've installed an antivirus software, i supposed the reason was the antivirus, but i've tried on configs and even uninstalling it, and RSLinx seems that can't reconigze the ethernet adapter (guess that means red cross) RSLinx 3.51 CPR 9 SR 5.1 RSLogix 500 Pro 9.0 Windows 7 Ultimate 32 bits Could you, provide to me some guidelines to solve this, or if somebody has had this problem, could share the solution? thanks in advance
  14. mitsubhishi serial drivers

    Hello write now i am working with Q6UDEH PLC  project in which (nextgen 2000) 6021 card is used for conversion of serial to Ethernet data & vice versa , is it possible  by only installing the Mitsubishi serial drivers ?? or can anybody tell me how these Mitsubishi serial drivers works ??  
  15. mitsubhishi serial drivers

    Hello write now i am working with Q6UDEH PLC  project in which (nextgen 2000) 6021 card is used for conversion of serial to Ethernet data & vice versa , is it possible  by only installing the Mitsubishi serial drivers ?? or can anybody tell me how these Mitsubishi serial drivers works ??  
  16. Hello everyone, I need the help to do setting of datalink between CJ2 and LOGIX-5324ER. The Allen bradley PLC was programmed by contractor and I have no software of it, so I am doing the network setting in CX-one network configurator. I tried to do the instruction in the Quick Start Guides on Downloads section here under Omron, but I couldn't find the option to register tags in network configurator. Is there anything wrong here? or is it possibly because of that they not support to do a datalink in these version of PLCs? They appeared like these in the pictures.
  17. MES US over Ethernet

    I have a Mitsubishi MES US network module ( QJ71MES96US ) connected to an Ethernet remote PLC (through an Enet switch). I'm not sure if this matters, but the remote rack has a Q PLC and an Ethernet master module kit (Q03UDECPU-EIP-K is the kit that has a Q03UDECPU and EIP4CCPU next to it). I am wondering if and how we connect the MES to a Q PLC over Ethernet to pull data. A coworker has configured the MES US module to talk to a PLC in a local rack, but never to a remote rack. If anyone can assist, or even reference a manual that would be appreciated, thank you.
  18.   In a certain area of our facility we have several machine that manufacture a handful of products. These machines were built at random intervals starting in the late 80's and consequently have a range of different PLCs that are used to control them (SLC 500 to ControlLogix L61).   The other areas of our facility use a server that has a historian installed (Canary) and the client (Axiom) is installed on our computer so we can view data trends in real time.    I would like to network our PLCs mentioned in the first paragraph to this historian to gather production and maintenance data.   I know that I need to network these devices through an OPC server (which we have).   Several of these devices have been connected through DH+ and/or Ethernet networks in the past but are no longer connected.   We recently connected some of the DH+ Devices to the Ethernet network (just to see if we could) with a Prosoft AN-X2-AB-DHRIO.   My questions are:   Are there any best practices for networking devices with different protocols, i.e. DH+, Ethernet, etc.? Is the way we have it set up now (with the Prosoft DH+ to Ethernet bridge) a robust (scalable, etc.) solution? Is there a better way to do this? Is it worth getting EtherNet/IP cards for the PLCs that don't have them?   If anyone has any experience with a similar scenario, insights/advice would be much appreciated
  19. SLC 505 Message to TCP Port

    Hello I have a SLC5/05 and a Microscan MV40 smart camera which receives commands to a TCP port. Is there a way the LSC 5/05 can send a command to the camera using the MSG instruction or any other instruction? I would appreciate any advice 
  20. My client is a pharmaceutical company and they want to interface their Blood Gas Analyzer (which is a RAPIDPoint 500) to a Controllogix PLC via EtherNet. I have attached a Spec that I found, which gives the initial information you would need to do this. It says that the BGA can transmit data in ASCII. However, it doesn't list what bits I need to send to the device in order for it to send the PLC the data. I've tried contacting Siemen's (who makes the BGA) and they were useless. I also tried searching the RA knowledgebase.  Does anyone have any insight on how to communicate with a device in this way? Thank you Tyler RP500_LIS_5_20_13_-_Rev_C_.pdf
  21. Omron CJ2M - Wago remote I/O

    Hi there, I’m not sure how familiar most of you are with Wago remote I/O, but I hope you may have some solution for the following connection problem I’m having. I’m working on a project to modernise an old folder collecting machine for which I’m using an Omron CJ2M Cpu33 together with 8 Wago 750-352 remote I/O units over ethernet/ip. These Wago units all contain two 8DI digital input cards and two 8DO digital output cards alongside a 750-610 bus power supply card. Adding them to my network in CX network manager is no problem and all seems to work fine. That is, as long as I don’t physically add the bus power supply card, which I need to, well.. power the Wago bus. Soon as I add this card (which was in place while making all the necessary settings to the Wago and Omron units) it just won’t connect. Remove it and it connects like it should. As far as I know the power supply card has no I/O addresses or other communication functions whatsoever, so I can’t get my head around it. Even stranger is that when instead of it I add an analog input card, with bus power connections build in, it connects without a problem. The .eds file only contains info about the main Wago unit, after installing it I should be able to add any kind of I/O card and address them in the Omron software. Also, the supply card is added and visible as a fifth card in the Wago I/O settings and the I/O status led is green during this error. Therefore I would say the problem is at the Omron side. Any sugestions?   Thanks in advance Andy - The Netherlands  
  22. WeinTek to AB PLC Issues

    I am connecting a WeinTek eMT3105P to a CompactLogix L2 series PLC via the WeinTek Rockwell PLC (CompactLogix) - Free Tags driver and I cannot for the life of me get the thing to connect. I have all my tags imported and have played around with all the settings in the manuals I can find. Any help/advice would be greatly appreciated. I know my IP addresses are correct and if I connect my cable directly from the HMI to the PLC I still get the "PLC no response" message 
  23. Hello.   I'm trying to communicate between two PLC's  using FINS function block _CPU011:ReceiveData.   PLC1: IP 192.168.1.50 (MASTER)   PLC2:IP 192.168.1.51 (SLAVE)   If I don't use »IP Address Table« everything works using NODE number &51.       The problem is that on the real project these two PLC's will be on different subnet.   For example:   PLC1: IP 192.168.1.50   PLC2: IP 192.168.2.50   So I will have to use »IP Address Table« to achieve communication between these two PLC's.   I tried to sett IP Address Table on MASTER: Node 1=192.168.2.50   But If I try to communicate I see that packet is sended to network but I've got error #1005.   Do I have to sett the SLAVE IP Address Table?   Hoe to do this?   What are the right settings for MASTER and SLAVE IP Address Table?     I'm attaching pictures of CARD settings.  I don't want to use CX-Integrator because I would like to make project to UPLOAD and forget.       Thanks.  
  24. Studio 5000 Logix Designer

    We recently obtained a new Vendor ID (VID) Number from ODVA, 1477 for the purposes of developing an EtherNet/IP scanner device.  When we try to use that number with the Allen-Bradley PLC & Studio 5000 Logix Designer, our data type REAL's are showing up in Studio 5000 as SINT's.  We have seen this mangling of data types before when using the Omron VID, 47 with the same Allen-Bradley PLC/EIP Scanner.  The data types are being misinterpreted, or mangled from REAL to SINT, e.g. the *.eds file defines 32 REALs for Input and 32 REALs for Output, but within Studio 5000 we see 128 SINTs each for Input and Output. It is as though the Allen-Bradley/Studio 5000 database does not have our Vendor ID.  When I change the *.eds file, Vendor ID Number from #1477 to #1 then we see the *.eds file being properly read and interpreted, e.g. 32 REALs for Input and Output show up as 32 REALs each.  Does anyone know what file we need to modify in Studio 5000 ???  We want to add our Vendor ID #1477 to that file. Hardware: EIP Scanner: Allen-Bradley Compact Logix L18ERM EIP Adapter: Delta Tau Power PMAC Motion Controller (EIP OpeNer Stack) Thanks in advance! See screenshots below. within Studio 5000, see screenshots
  25. Hello to all, I am new here, and I have a project with FX3U plc and CR 2DA 700 robot controller. Does anyone have some experience in establishing communication over FX 3U enet module and robot controller, I need to send and receive 5- 10 M registers and D integers. Thanks