Search the Community

Showing results for tags 'cx programmer'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 46 results

  1. Hi, is it possible to communicate between the Sysmac studio simulator and the CX-Programmer simulator? I want to test the exchange of data between a NX1P2 and a CJ2H, but I don't have the controllers with me. Thanks and have a great day!
  2. Hi, I have some trouble with a CJ2M-CPU33. My client did a backup to memory card earlier today, and after this we did some changes through remote link. Now the client wanted to restore the previous backup to the PLC and has done so, but the system would not function correctly. After going online on the PLC it seems like the PLC is stuck in "Stop/Programming Mode". When trying to change to "Monitor" or "Run" mode a dialog comes up containing the following message: "Failed to change the operating mode. The operating mode may be still changing in the PLC."  - All the dip switches are set to off after restoring backup - The PLC has been rebooted  - I have downloaded the application again through CX-programmer  - Verified that the PLC is set to start up in "Monitor mode" But nothing helps. The same message comes up when trying to change the operating mode.  Hoping anyone can help to resolve this issue as it is very critical for us and the client. In advance, thanks for any tips or help received. Best regards Stian
  3. Help! PLC program removed

    Hi, Anyone knows how to retain PLC program for CQM1 PLC model in the EEPROM? Everytime I power off the PLC, when power on the PLC Program lost and the PLC status is in ERROR(No END Instruction error). Already tried downloading with AR1400 turn on from the CX Programmer software but still no luck. Hope someone out there guide me step by step. I'm new to CX Programmer. Thanks lot! marky  
  4. So I did this simple Function Block, pretty simple, and yet it keeps giving me this error, after a bunch of failed combinations the error persists, without telling me whats wrong. And therefore won't even allow me to download the program to the PLC (CJ2M CPU31) or even simulate.   I heard it's a simple thing to fix but I really dont know how to, since I'm quite new to this. Here's the function block  itself in the picture and the programming inside it, although since it gives me no errors, i don't think that would be the problem
  5. Hello, I need to Synchronize two 4kW motors connected to their own individual AltiVar VSDs. To put it simply the two motors are pulling cables on a pulley and when loaded the motor's slip and the speed varies. I have an Omron CP1L-EM PLC and 2x Omron Rotary Encoders ( E6C2-CWZ5B encoders - 360 PPR) - connected to each motor,   What is the best way to read the pulses from the two rotary encoders then convert to RPM? 1) Using  PRV or PRV2(883) instruction,  - this would be the best option as it would convert the value to RPM - however, can I use this instruction on both Counter 0 & Counter 1? 2) Or read the raw value from  Counter 0:  A270 (connected to motor one's encoder) Counter 1: A272 (connected to motor two's encoder) Convert the pulses to RPM - then compare and adjust? 3) Or using CTBL. - is this a useful instruction for this application?   Once I get the RPM speed from each motor - I can then do a compare instruction - see if there is a mismatch and if so send a scaled analogue output to the VSDs to correct the speed if required. (10-50Hz) What would be your recommendations? any help would be most helpful. Thank you.
  6. Hi..  someone please help me.. i'm working in omron CS1H-H CPU67 PLC. My struggle is I/O in one particular rung is not getting updated.  Note: the rung is consist of a P_On flag followed by a FB ; all I/O to the FB were correctly assigned. but the inputs inside the FB instance are not getting updated so that the output not updated. can anyone please help me....????   sorry for my poor english... thanks in advance.
  7. I am trying to use FINS/UDP network to communicate with a Siemens device (at a customers site over seas from my home office), today I attempted to set up a SEND command based on information my customer received from a local Omron representative but had no luck.  I feel like I am missing something in a setting somewhere, does anyone have experience doing this?  I am using a CJ2M-CPU35's built in Ethernet IP port which is also communicating to 5 other Omron devices over Ethernet IP, so I am wondering if there is an issue having both networks. Thank you!
  8. PID regulation PT

    Hello   Does someone have a good way to control pressure using PID in cx-programmer? I got two pumps and one PT(4-20mA) Half the year only one pump need`s to run (about 3bar)  but in the season (i work in a fabric) two pumps need to be running (about 4bar needed) except in the night. I`m going to use HMI for adjusting the setpoint so there is no need for any clock/date for this to change itself. The question is how to get one of the pumps to shut down when the need for pressure is not so high. And get the pumps to change "main" pump sometimes so one pump is not running all the time.   Hope this was understandable    
  9. Hello guys, I need help. I have an OMRON PLC; CJ2M series which I am not very familiar with. I need to do comparisons, but I see that do that I can't just compare with a value. It looks to me that I have to store the value I need to use to compare in a memory address and reference to the memory address for my comparison.  Is it possible for me to compare using a value and not have to first go through a memory address? Is there a way to use the instruction to store the value in a memory location ? Or do I specifically have to use CX-Designer for me to wrote the value to a memory location? Thanks in advance.
  10. Omron CJ2M - Wago remote I/O

    Hi there, I’m not sure how familiar most of you are with Wago remote I/O, but I hope you may have some solution for the following connection problem I’m having. I’m working on a project to modernise an old folder collecting machine for which I’m using an Omron CJ2M Cpu33 together with 8 Wago 750-352 remote I/O units over ethernet/ip. These Wago units all contain two 8DI digital input cards and two 8DO digital output cards alongside a 750-610 bus power supply card. Adding them to my network in CX network manager is no problem and all seems to work fine. That is, as long as I don’t physically add the bus power supply card, which I need to, well.. power the Wago bus. Soon as I add this card (which was in place while making all the necessary settings to the Wago and Omron units) it just won’t connect. Remove it and it connects like it should. As far as I know the power supply card has no I/O addresses or other communication functions whatsoever, so I can’t get my head around it. Even stranger is that when instead of it I add an analog input card, with bus power connections build in, it connects without a problem. The .eds file only contains info about the main Wago unit, after installing it I should be able to add any kind of I/O card and address them in the Omron software. Also, the supply card is added and visible as a fifth card in the Wago I/O settings and the I/O status led is green during this error. Therefore I would say the problem is at the Omron side. Any sugestions?   Thanks in advance Andy - The Netherlands  
  11. Programming Analog Outputs - Problems

    Hi All, I've been perusing this forum and I've seen this topic covered before, but I still can't make heads or tails of how to do it still. I'm trying to vary an analog output 10v signal to talk to a VFD according to how much time a certain input bit is energized. Currently I have it set up as a totalising timer, trying to move the PV into a word so I can use it to scale an appropriate output. The trouble is, I'm not having any luck getting the output to do much of anything. No errors show up. For reference, I'm using a CJ2M CPU 12 PLC and the output I'm trying to program is a DA042V, its in slot 05 of the main rack. I'm trying to scale a 0-20 time to a 0-10V signal out. I used to have a problem and I was getting ~-.5V out of output 1, but I enabled a bit and now it's hanging out at 0V. Clearly I did something right. Any help would be much appreciated. I'm sure it's something silly, and I'm new at OMRON PLCs.
  12. version incompatible

    I'm supposed to send the software from one machine to the other. The Dwonload but who does not want to open with the CX Programmer: comes version incompatible. But I do not want to pay 700 € for an update I just want a tool that allows me to send this data in the other machine. Weir has an idea or who helps me I pay the service. The machines are in Austria in Saint Pölten.
  13. CX-Simulator

    Hi guys, Do you have experience or know any good guides to set up a simulation case like this: - Simulating a PLC program such that the "PLC" is accessible on the Ethernet (for example just locally). - In addition, setting up the PLC settings with FINS protocol such that it is possible to write to the PLC with FINS protocol from another device. The first part is  most important. Best regards PC_VS_PLC
  14. Program help

    So I need some help with a program I am currently making, and wodnered if there was an easy way to make it. The function I need help with is this: There are 4 pumps, and 1 of them is going to start, after 10 sec shall the next start, so 10 sec after that the third one. And so like this it continues. But heres the clue. The pump which have been used the least is going to start first, if it is pump 1 that have been used the least, or if pump 3 has been used the least. If you know of any function block, or other way I can do to make this work, I would love the help.   (I know of the comparison blocks less than and more than, but with these I only can think of 1 way to make this work. And it would be over 48 function blocks, which I personally think is too much)
  15. "This type of PLC is not supported", this is the error which appears when I try to connect cx programmer V9 to CJ2M-CPU11 using a USB (A type - B type) cable. Please help me resolving this error.
  16. CP 1E NA ANALOG INPUT PROBLEM

    Hello Friends I am using  Omron PLC  CP 1E NA series, i have connected 4-20 mA input source to its first inbuilt analog I/P channel, I am uanble to programm the channel no 1,  how to get readings of the same? can anybody help?
  17. Hello. I have some issues with starting cx-programmer. It wont start. The start up screen shows, then closes, says that cx-programmer is running, but it is not, it is an empty window. When I look in task manager it says the program uses 0% of the processor, but it uses ram. Do you have any idea of how get the program to start the program again.
  18. Hello Guys, I Need some information about conncting method between cx-programmer and cx-supervisor? Anyone can explain? Please help me! thank you.
  19. I want to unify my programs and select only configuration words (the same program for many applications) . My problem is with the assigned outputs by the high-speed pulse output like PLS2, ACC, ORG ... I thing that the instructions JMP/JME may allows to use these outputs as normal outputs when HSPO functions is not required. Is it right ?
  20. All, I am looking to hire either a full time PLC programmer or contract programmer that will develop systems in Ignition.  Experience with Ignition is preferred, but if you have other experience that is related, that is also acceptable. Python scripting is prevalent throughout Ignition, so that experience is required.   PLC knowledge is required. ERP system knowledge would be a major plus, as well as how to connect Ignition to it. All are SQL based.  
  21. On-Off Temperature control

    Hi, i'm actually working on a project with a CPU33 CJ2M and a external analog output CJ1W-AD04U I'm trying to read the informations coming from a PT100 sensor and control a valve which act on the temperature. i'm kind of lost in this project because it's my "first time" with Omron ! Which function block must i use or how must i program this would you show me example ?  Thank you for the help guys.
  22. CJ2M-CPU32 and CJ1W-TC002 help

    Hi everyone. l have a project with omron plc but l dont know omron. l have CJ2M-CPU32 and CJ1W-TC002 also input and output units. do you have a example temperature control programme for this device ? 
  23. Hi   I'm all new to using omron but "stuck" with a project. I find the CX Programmer software (version 9.35) a bit confusing. Used Siemens a lot.  What I'm trying to do is to display date and time on a HMI showing cpu startup time. I use a "First cycle flag" that triggers once when CPU starts and then I understand that the date and timestamp is in the system variables A352 and A353. But how do I format them as a normal text? I only manage to display them as #hex-numbers. I have tried googeling but have not found an answer to my questions. edit: CPU type is: CJ1M CPU12 //Morten
  24. Hi everyone, now i am doing a project related to communication between c++ and Omron PLC CP1E. Anyone have a way to connect the cx programmer and visual studio c++? Thank.
  25. Hello, attached below is what i have attached above is what i have done so far for the ladder logic when controlling a pump stroke but i cant seem to get it to work  Im using an OMRON CP1LE-EL with CX programmer i use an analog extension board and its only capable for 1 analog device which is my pump  is there something wrong with my ladder logic? pls help    sorry if its lacking in information i'm new to this so just go ahead and ask me what u need to help me out