Search the Community

Showing results for tags 'cx designer or sysmac studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 177 results

  1. CX Designer Generic Popup Faceplate

    I was wondering if anybody out there has ever made a generic popup to deal with multiple devices, similar to what you can do with factory talk and wonderware. I want to be able to index addresses from the PLC to the PT memory but it doesn't look like you are able to do this. Is there anybody out there that has come across this same problem?
  2. Hi there, is there anybody who use macro function in NB designer? I need list of C language syntax who can be applicable in macro. I have a task to migration from NP designer to NB designer who use different languages. Thank you
  3. Hi. I can get horizontal scroll, but no idea how to get vertical scroll if I have more events than event window has rows. thanks for clue
  4. hi dears, I have one CS1D omron Redundant controller ( CP65H) that must be connected to NS15 Touch panel. I want to use Ethernet for connecting HMI and CPUs (CS1D-ETN21D). I have one question. for NS15 we can use CX designer and sysmac studio? is it true? which one is better? what is your recommendation for HMI software? Thanks.
  5. How do I edit an array size ARRAY[0..13] OF REAL to ARRAY[0..15] OF REAL? Sysmac Studio doesn't allow it to be done online, as far as I can see. If I do it offline and then go online and Synchronise, Transfer to Controller I receive error Any ideas?
  6. Trying to connect our old Sysmac C200HE PLC to the CX-Programmer software however, failed connection appears. We are using a USB-Serial connection and have set up the comms on the device manager. To try and connect to the PLC we are using the Auto connect function, selecting the usb-serial connection and selecting the comms the same as the host network. Any help would be greatly appreciated.
  7. Hey guys I have searched the forum, but can not find the answer I am looking for. I have an Omron Nx102-9000 along with an NA5 (9 ") that I use to control an industrial furnace. I need to set an output one at a given time (date and time)  A time that should be able to specified from day to day via the HMI Is there anyone who can help me? Then I would really appreciate it
  8. Excuse me , can anyone help me .. I made Graphic program with CX Designer-NSRuntime. But I'm having trouble making auto save/downloads my graphic. Because  in NSRuntime Graphics there is no auto save command. Please check my screenshoot
  9. Good morning, I am working with sysmac studio v1.25 controller NX1P2 and HMI NA5. I have been trying to link and modify members of an structure in HMI without success and I don't know if i'm missing some syntax or if it is even possible what I am trying to do. 1. In the PLC I have the struct "Formato" and global variable "Formatos" which is an array of Formato. 2. I have mapped this variable to the NA5 so I can use the same data type. 3. I am trying to give a value to the members of my struct with a recipe of the HMI. I am trying with different syntax, with AT connection, without AT connection and none is working for me.   Is it possible what I am trying to do?   Thanks very much in advance,
  10. Hello everyone, I have a problem with packing machine. There are some issues with one of the axis, when axis actual position is near to 1800000 some error appear and operator has to turn off machine on main contactor. This axis is working in Linear mode. I think that rotary mode would be better for this axis. And here is my question. Which instructions, and what options i should change/check when i change count mode in axis's options. Can any1 point me some manuals to read or give me some advice ? Thank you in advance.  
  11. This course is designed to equip the novice with no prior PLC programming experience with the basic tools necessary to create a complete PLC program using ladder logic common to most current platforms. Use Software : - Somachine EcoStruxure Machine Expert Basic - Free - Vijeo Designer Basic Full Articel About Lear PLC Schneider  Video Tutorial Learn PLC Training Free
  12. I need to import/export all recipe templates to/from a single csv. file Anyone with a Solution for this? Thank you 
  13. GT DESIGNER 3 - "SCREEN ERROR"

    Hey guys, I am trying to fix a problem with a machine for plastic jerrycans production, that i bought in the end of 2017 from a spanish company. That company refuses to help and assist us so i had to search for other solutions.  In short: i need to change a fixed value on the SCADA program of the machine to a variable value and i want to change it on the terminal i have installed on the machine (GOT 1000). The problem is dat whatever i change on the gt designer 3 file (if i move a button or a lamp 1mm to the side or change a letter) and then write it to GOT, when i try to open the screen where i did the modifications i get a white screen saying "screen error". Only replacing the new file for the original one i can continue to use my GOT 1000 normaly. I also wanted to translate some of the words because most of my employes dont know how to speak spanish and have some dificulty using the terminal correctly... I am corrently using 1.37P version of GT Designer 3 but the original file dat came already installed on the GOT was 1.165X.    
  14. Hi there,  I am considerably new with setting up E/IP on OMRON's NX1P2 PLC. I have been trying to connect a Keyence IV-G to my PLC with E/IP connection (because there's no analog I/O available) and struggling with getting a connection going between PLC and camera. I connect these two through an unmanaged network switch, which I believe doesn't need any further configuration. I have set tags on Built-in E/IP inside SYSMAC Studio, and when I monitor them it says "normally resolved". Unfortunately, it still has red dot which means connection is cannot be established. The error I'm getting is "Tag data link connection timeout". Maybe built-in E/Ip just doesnt work for this case? I have yet to try getting connected with Network Configurator, but have the feeling that it will just accomplish the same thing that I did with Built-in E/IP inside Sysmac Studio.
  15. Hello, I'm looking for sample program to communicate Cognex DataMan 262Q, now i have connecting by Tags, 496 bytes input/output, but in manual i see :  
  16. I am trying to use the Event "SaveUserAlarmLogToFile" tied to my F1 button to save my alarm history to my SD card installed in my screen, but I can not find any details on how to specify the file name for the save...can someone please clarify what should be entered for the file name?     Thank you!!!!
  17. Hello everyone, I have this message when I trying to open my project which I did.  "The project includes a model that cannot be used with the current license. The project is closed." I recently reinstalled windows, but version of Sysmac Studio is same, License is same, but now I not be able to open my project. I just tried to install last version of Sysmac Studio 1.25, and of course nothing changed, looks like issue with license. But again, license is same.
  18. I'm very new to sysmac. I am trying to display the current date and time in the corner of each of my HMI pages. I saw a button labeled date and time. It is asking for a variable for behavior. Do I need to write some basic structured text or FB in plc to get date and time and pass it over? I figured the button would update itsself since when I placed it on the screen it had the current date and time and refreshes every time I leave the page and come back. 
  19. NA5 Orientation

    I was wondering if the NA5 could be flipped for a portrait orientation, I am working on a new project that has serious width restrictions!  I looked through the Sysmac software but could not see anywhere that it could be done in the hardware configuration.   Thank you!!
  20. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  21. Dear all schneider Experts, anyone having "Vijeo designer screen editor"Software for XBT012110 megelis HMI. Please give a download link, I got very  stuck  to get this software #Advanced Thanking you......
  22. Good Evening, using the Ethernet Built-in LAN I need to program 4 power supply. I'm tryng to program the firstone but even if I can send the correct command to the power supply I always recive a 2006 error on SKTTCPRCP function Is there someone that can help me in order to not receive the 2006 error code? Have I to respect a procedure? It seems that at the second connection time the socket remain closed. Thank you!
  23. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  24. I am a long time Omron user, but this is my first time using the Sysmac software, I want to compare the 16 bits of my array to zero, if any of the bits are on I want to turn on an output, I see the AryCmpNE and AryCmpNEV, but they have a seperate bit for each item in the Array, is there any way to do this without using Unions?   Thank you!!
  25. I use Netgear routers with multi-NAT capability to attach machines to the company LAN. One of the advantages is that similar machines can have identical network addressing schemes while a multi-NAT router on each machine can be used to assign unique external addresses. The usual error on these setups is to forget to assign a gateway IP address and so the PLC can't respond to requests from outside its subnet. I have the router set up as normal (as I have done a hundred times before on other machines). PLC has correct IP address, subnet and gateway (that of the router LAN address). Router has NAT rule configured, correct LAN subnet, etc. I can PING the PLC from the company network. This implies that the router, wiring, etc., are all OK. If I disconnect the PLC ethernet cable during a PING I get errors. This implies that the address is unique, etc. Controller --> Communication Setup --> Ethernet connection via hub --> Ethernet communication test --> "A communication error has occurred." Has anyone seen this? Any reason why it shouldn't work as I expect? Many thanks.