Search the Community

Showing results for tags 'compact logix'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 39 results

  1. MNET to OMNI

    Good morning all, does anyone have any experience communicating to an OMNI Flow Computer through a MNET card, Im getting data back but it is not what i expected.  Should I be using Enron/Daniels? Byte Swapping? Thanks
  2. Version V12 (2017)

    4 downloads

    KUKA, Optional Interfaces for KRC4 Compact controller such as I/O, fast measure interface etc.
  3. View File KRC4 Compact Optional Interfaces KUKA, Optional Interfaces for KRC4 Compact controller such as I/O, fast measure interface etc. Submitter panic mode Submitted 03/02/18 Category Robots and Servos
  4. Ethernet/ip to modbus rtu

    HOW TO CONNECT AB 1769-L33ER ETHERNET /IP TO MOD BUS RTU
  5. Hi PLC programmers, I got a problem regarding my installation of Logix Designer/Logix5K. Here's the situation... a) Initially installed Studio 5000 without problem. b) I needed to open a program from Logix v20.1, installed RSLogix5k v20.1. After installing v20.1, RSLogix was corrupted and won't open program. c) Reinstalled entire Logix Software. d) Was able to open and convert program from Logix5k v20.1 to Logix Designer v24 but this annoying error occured on v24 (See attached "EN2T")... "Failed to Create Module Profile". All of a sudden, the module (1756-EN2T) I created with working v24 is no longer usable. Now, even when I create a new project, add a module with "Select Module Type", the list of available modules has been trimmed down to what it normally has (see attached "AB_Modtype"). Kept on re-installing entire Logix 3 times, clearing the registry with CCleaner and even deleted installation folder for Rockwell software but the problem is never gone. I even downloaded AOP for EN2T and installed it but to no avail. Now I'm lost and dumbfounded that uninstalling and reinstalling isn't working. By the way the OS I'm using is "Windows 7 Enterprise". I appreciate all the help I could get. Thank you very much. Sincerely, Andrei K.
  6. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  7. Hi,  I am writing some routines to decode the data from my Input: data array to User-defined Array Parameters. Is that possible to have a generic routine to decode data coming from more than one module? I have two Module ENode and ENode_1. I have defined User-Defined parameters for the module. Can I make a generic routine to decode the data coming from these two modules and put them in the defined arrays?  the two arrays ENodeData[0] and ENodeData[1] have the Generic User-Defined parameters.
  8. RS Logix Designer Tags

    Hi, Is that possible to define INT data type in EDS file so the Tags for the module in RS Logix Designer would receive INT data type in Input Tags not SINT? As marked in the image, the Logix Designer is receiving data as SINT but I want to have INT data type. Thanks Muhammad Azeem
  9. I have a "paddle wheel" style flow meter that I am trying to wire to my Micrologix 1400. It is a three wire device and there is a tag on it that says it can run at 6-36VDC. So, naturally, I thought to wire this to one of the HSC inputs of the Micrologix directly. I hooked the ( + ) on the meter to 24V, ( - ) on the meter to common, signal to the oscilloscope, and ground on the scope went to common. I see a small 60Hz sine wave @ like 5mv when the wheel is not turning. When the wheel is turning I get a small square wave but in the same mV range. It is not a nice smooth square wave either its all jumbled up with the 60Hz sine wave.  I hooked this thing up to a transmitter and scoped the signal and ( - ) in parallel with the wheel - I get a nice smooth square wave signal when the wheel turns. It is only at 4.5V though. My questions are? Why does't the paddle wheel give me what I am expecting directly? Also, what is the voltage range on the pulse that a micrologix will see? I am assuming that it will not count a wave with a 4.8V amplitude.... Thanks for your help in advanced! neech   
  10. Cimplicity 7,5

    Good Day There is a SCADA Cimplicity and controller Control logix 5561 AB. Communication between them is organized via Ethernet IP. It is necessary to transfer some tags from the Cimplicity to the controller Control Logix. How to do it better? Through Rslinx DDE OPC or write scripts in the Cimplicity? 
  11. 1.Can anyone say how can i communicate control logix plc with ethernet to serial converter. here i am not having any eds file.
  12. FX3U to FX3U via wifi

    Good day fellow PLC ninjas! I have a question/ concern which I would love your opinions on. We have 3 FX3U PLC’s+ENET cards. Two of the 3 PLC’s move around in an EMS trolley. The other is a ‘base station’ with a GOT2000 connected via Ethernet. Base PLC IP = 192.168.1.11 HMI IP = 192.168.1.31 Carrier 1 IP = 192.168.1.61 Carrier 2 IP = 192.168.1.62 I have programmed the base PLC to use Active communication; we are using fixed buffer communication to send and receive data to/ from the Carriers. The carriers are set up as Fullpassive ‘slaves’. This part works well and the update time changes (using a counter in the base station) from 1s to 100ms (because it enters a different work station).  My issue is the following: using a network sniffer (WireShark), I pick up plenty of re-transmits and sequence number errors coming from the base PLC’s ENET card. This is troublesome and causes delays when the update time is required to be fast (100ms). I am sending and receiving 10 words of data. The wifi seems stable, and there is minimal noise in the area. The power has been turned down and the antennas used are suited well for the application. The antennas are at a similar height to minimize possible loss of signal. I have LOS (line-of-sight) to the carriers at all times; to at least one of the antennas (I am using 802.11n). Has anyone picked up issues or found settings which can be used for comms over wifi? I can easily do this using a S7-1200 Siemens PLC and have done so using 12x S7-1200 clients and 2 AP’s with 1 base PLC. I have also successfully done this using 8xFX3U client with a System Q base PLC. My suspicion is that the delay in reading and writing to/ from the BFM in the ENET card is causing this. I am not sure that if I change to a FX5U will help. The communication cards on the Mitsubishi PLC’s seem very limited. Does anyone have any technical details on the access times between the CPU and communications cards’ BFM? Help is as always, appreciated.
  13. Could someone please generate PDF report for the ACD files on the attached .ZIP file? They are all RSLogix 5000 v20 files, I needed them for a university report which the deadline is today, but I don't have access to a computer with RSLogix 5000 :S Thanks!  ACD_files.zip
  14. Has anybody tried communicating Allen Bradley 5069 Compact logix PLC with Red Lion HMI ?  I am unable to communicate them in spite of adding AB tags via L5K file which gives me no error. I am able to see all the tags in Crimsion 3.0 software in development mode.  However, PLC & HMI are not communicating with each other. I am able to ping to both, using the same program in PLC of which I generated L5K file.  I think it may have something to do with the driver as 5069 is a new line of PLC Rockwell come out with only in 2016.   
  15. To Infinity

    Hello.  This is my first post and I hope someone has a solution. I have a program calculating Gal/sec adding to a running total and have up to the end.  Using REAL I can accumulate up to 16,777,216 (2^24) and using DINT up to 2,147,483,648 (2^31), but I need to have my registers continue past these limits.  I've read through many topics here and have tried the Rockwell Knowledge Base but can't seem to find a solution that truly works.  I have gone so far as to transfer the DINT to a string, cut the string into pieces and reassemble them in an Odometer type concatenation. If anyone has a suggestion, I would appreciate it.  I know I'm not the only one with this problem. PS & BTW - I'm using Studio 5000 v24 with a 1769 L33ER
  16. Thanks for your time.  We have purchased from auction a Getinge Autoclave (sterilizer) with Allen-Bradley controls (CompactLogix L32E).  The machine has a PanelView Plus 1000 installed.  A CD came with the machine w/ the following files.. HMI Project - (.apa file) Runtime (.mer file) Their is also a compact flash card installed in the CompactLogix L32E.  On the Panel View, their is an external Compact Flash slot, but no card, and on the inside of the panel view (if i remove the back cover) their is a compact flash card slot with a card installed.  I haven't checked what is on either of those cards yet.. We cannot get the program to load on the panel view. When the machine is powered on, the panel view goes through a quick dos setup screen and then the screen turns blue and we are stuck with an hour glass icon.  The icon will move depending upon where you touch on the screen.  I can boot the panel view in safe mode (by hitting the default button, then reset) at which point I get a message stating that the machines files may be corrupted and leaves me the options to Download new Firmware, or Continue.  Hitting Continue nothing happens, and choosing Download gives me Ethernet, or Serial options.  The Panel View is connected to the PLC via ethernet so I choose this option and it  gets stuck at this point. We do not want to make any changes to the program, but just to get it to run on the machine.  We do not have ANY of the software. Any advise is greatly appreciated. Craig
  17. RS Logix 5 Compare Tool

    Hi, Could someone explain or direct me to better understand the RS Logix 5 comparison tool? I'm comparing multiple PLC codes and having a little bit of trouble understanding what the concept of "deletion", "insertion" etc are portraying. Since, some rungs are labelled 'deleted' and 'inserted' in the comparison, however,  the rung labelled deleted seems to exist in the actual code?
  18. Hi, I'm a long time lurker and would like to start by saying thanks for all the help over the years, much appreciated!  This is my first post, please be gentle. I'm working through a large project with an L83 (V28) including 75 EIP nodes & 5 servos.  We have a need for quick real-time response of 2 cameras during a quick servo move (taking several pictures).  I've broken my program up into a few event driven tasks (allowing me to chose the execution time interval (5 to 8 ms for more important tasks and 20 ms for less important tasks, etc.)), along with these I have 2 periodic tasks: 1 for my HMIs & faults running every 30ms and 1 for this quick real-time response camera situation running at .5ms which contains my camera and servo logic.  Everything is running well and seems responsive and repeatable enough, but I am now adding the second half of the logic which will essentially double everything (2 up system).  This has made me consider the best structure approach: Is it better to have a few larger routines within a few larger tasks or better to have more smaller tasks containing an abundance of smaller routines or some other different mix? Thanks, JD43    
  19. Hello guys, Newbie on this site. I am looking for a run time free Allen Bradley .NET driver. Basically a library (.dll) that implements communication protocols to Allen Bradley PLC's ( CIP, Ethernet/IP, etc.). Can someone point me in the right direction please ?.
  20. KUKA: Agilus

    Version BA KR AGILUS sixx V10

    9 downloads

    KUKA: Agilus six axis
  21. KUKA: Agilus View File KUKA: Agilus six axis Submitter panic mode Submitted 02/16/17 Category Robots and Servos
  22. I get this error even if the application is compact edition. Plz halp
  23. We are replacing the Old hardware from PLC to new Control logix hardware. wondering Application of IEC-61508 and IEC-61511 compliance in this brown field project. Any Thoughts ??
  24. Hi! I just started with PLC programming. I am trying to get the time between a output signal and a input signal. The problem is that the time is ~200 ms but when i measure it with this code:   TONR(Timer1); IF PosFeedback <= PosFeedback_Min & not Timer1.Reset THEN Timer1.TimerEnable := 0; FullCloseDeltaTime[1] := Timer1.ACC; Timer1.Reset := 1; END_IF; IF (move & not Move_LastScan) THEN //Start timer Timer1.TimerEnable := 1; Timer1.Reset := 0; END_IF; Move_LastScan := move; i only get even values in intervalls of 50 ms like 150, 200 and 250 ms. I have changed the real time sample rate to 11 ms so i don't understand why i don't get a more exact result. And i can see in my trend that the time isn't exactly 150, 200 or 250 each time. I i tried and time my own click on a button and i see the problem is the timer, i only get values in an interval of 50 ms. Is there a way to make the timer more exact?
  25. It's another BOOTP post! I know you're all as excited as I am, so lets get started. But seriously, I'm trying to disable BOOTP on the built in Ethernet ports, not on an Ethernet module. I specifically say disable because BOOTP successfully assigns the IP address to my Compact Logix, however I still need to disable BOOTP to make it a static IP address rather than a dynamic IP address. I'm going to list everything that I have tried, so that anyone with the same issue can have an all-in-one-place reference. (Because there's a number of forum posts and other information for this topic on the internet, with many different suggestions) If I see different ideas/suggestions in other places, I can edit them into this post. Things I have tried: (and you should try if you have this issue) Disabling all firewalls, (For me: Windows/Avast) Disabling all other network adaptors. (Wifi especially, but any and all adaptors you are not using for the setup) Using a different laptop/operating system: (My current laptop runs windows 8.1 and uses a Linksys usb to Ethernet device to talk to the PLC, I tried a laptop running windows 7 which communicated using a built in Ethernet port) Lastly: Try to use all available methods to disable it. For me, that would be: BOOTP standalone server, RSLinx, (Trying to use both USB and Ethernet connections) and finally RSLogix. (Actually, only Ethernet modules have a "disable BOOTP" checkbox built into RSLogix, so that is not an option for me.) [If you have an Ethernet module, go to port configuration in RSLogix and uncheck the "enable BOOTP" checkbox] Anyway, RSLinx Classic (version 3.71) and BOOTP Standalone server (version 2.32) are each coming back with an error when I try to disable BOOTP. I'll attach a .jpg of some screenshots, and some Wireshark save files to show what I mean. In the RSLinx Wireshark file, it shows a "privilege violation" packet being sent from the PLC to the laptop towards the end of the exchange, but I'm not sure what privileges the laptop needs/doesn't have. For the wireshark files: I cleared everything happening before I try to send the command, so that there isn't a ton to search through. As far as timing of the wireshark files go: I start recording traffic, send the disable command (by clicking the disable BOOTP/DHCP button on BOOTP server or "apply" on RSLinx) then I stop recording traffic once I get the error message. So, the captured packets should be just the attempt to disable BOOTP and that's about it. I am sorry that I the pictures are strung together using paint, but I don't have photoshop on my work computer so it's the best I have. Any suggestions/help would be appreciated! (Regardless of whether they are suggestions for me, or suggestions that I may have missed intended for anyone with this problem.) Thank you for your time. Edit: I had the attached pictures open in paint/photo viewer, sorry that they look bad in the forum picture viewer. BOOTP_wireshark.pcapng rs_linx_USB_wireshark.pcapng rs_linx_wireshark.pcapng