Search the Community

Showing results for tags 'communication cimplicity with control logix ab'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 158 results

  1. Dear all, i have using nexgenie 1000 cpu for my new project. but i am not able to connect with codesys v2.3 . I have installed target file T1.4 and T2.4. trie with both. Now i have doubt with communication cable. I have used standard RS232 Cable with 5and 8 Pin short. Kindly suggest the correct one. Thanks in advance
  2. Ethernet/ip to modbus rtu

    HOW TO CONNECT AB 1769-L33ER ETHERNET /IP TO MOD BUS RTU
  3. MNET to OMNI

    Good morning all, does anyone have any experience communicating to an OMNI Flow Computer through a MNET card, Im getting data back but it is not what i expected.  Should I be using Enron/Daniels? Byte Swapping? Thanks
  4. Hello Everyone I have a problem to connect FX5U with Inverter Mitsubishi D700. ( no  respond from inverter) . I did read and following the manual. Could any one can help me?
  5. Modbus/TCP PN communication

    Hello, I'm trying to make communication between a 315-2 PN/DP and MSA Gasgard XL. I want to read out 40010, and 40020 from GasGard, it works sometimes, but most of time the connection does'nt  build up.  The parameters i using are: Start address: 9 Lenght: 10 Recv_Time: 5s Conn_Time: 5S I did playing with Recv and Conn Time and it effected the rate of succesful connections, but it still drops too often. Also i tried to read only 9 and 19, but then it didn't read 19. Anyone knows how could i optimize the connection? Thanks  
  6. Hi PLC programmers, I got a problem regarding my installation of Logix Designer/Logix5K. Here's the situation... a) Initially installed Studio 5000 without problem. b) I needed to open a program from Logix v20.1, installed RSLogix5k v20.1. After installing v20.1, RSLogix was corrupted and won't open program. c) Reinstalled entire Logix Software. d) Was able to open and convert program from Logix5k v20.1 to Logix Designer v24 but this annoying error occured on v24 (See attached "EN2T")... "Failed to Create Module Profile". All of a sudden, the module (1756-EN2T) I created with working v24 is no longer usable. Now, even when I create a new project, add a module with "Select Module Type", the list of available modules has been trimmed down to what it normally has (see attached "AB_Modtype"). Kept on re-installing entire Logix 3 times, clearing the registry with CCleaner and even deleted installation folder for Rockwell software but the problem is never gone. I even downloaded AOP for EN2T and installed it but to no avail. Now I'm lost and dumbfounded that uninstalling and reinstalling isn't working. By the way the OS I'm using is "Windows 7 Enterprise". I appreciate all the help I could get. Thank you very much. Sincerely, Andrei K.
  7. CP1E RS232 communication to my weighing

    hello, i want to connect CP1E to EK300i (weighing scale) with RS232 communication. i attach file of datasheet ek300i, wiring CP1E to ek300i and my cx programmer. if i push send data on ek300i, com LED indicator in CP1E is on. and i dont know why my cx programmer can't change data of memory with data from ek300i? what should i do?   ek300i.pdf CP1E to EK300i rs232 communication (belum dicoba).cxp CP1E to EK300i rs232 communication (belum dicoba).opt wiring rs232 ek300i to CP1E (belum dicoba).txt
  8. Fx3ge to Fx3ge communication trough lan

    Hello, For my assignment, I need to control lights from 2 seperate locations. I have two FX3GE-24M plc's connected through a LAN network. The idea is that when input X004 gets high, relays Y000 to Y004 gets disabled. I'm trying to use the Fixed Buffer communication protocol.  Master IP address: 192.168.1.80 Slave IP address: 192.168.1.81 I'm using GX Works2 together with the FX configurator  I'm lost in all the different datasheets... Could someone point me to the direction on what settings i need to change using fx configurator and a basic program of communication?  Thanks in advance, Dennis
  9. We have a Injection Molding Machine from Mitsubishi with a A2US-S30 CPU. I would like to establish a communication of this PLC with a  PC. The CPU has a 25 Pin Dsub connector. How can I achieve this? This is an old machine and we don't have any manual for this PLC. Somehow I could find an instructions manual on the internet but this manual does not contain information regarding PC communication or supported communication modules.  I have never worked with this Mitsubishi A series PLC. Please suggest a way to start and share any manual which I could refer to. Thanks!
  10. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  11. WeinTek to AB PLC Issues

    I am connecting a WeinTek eMT3105P to a CompactLogix L2 series PLC via the WeinTek Rockwell PLC (CompactLogix) - Free Tags driver and I cannot for the life of me get the thing to connect. I have all my tags imported and have played around with all the settings in the manuals I can find. Any help/advice would be greatly appreciated. I know my IP addresses are correct and if I connect my cable directly from the HMI to the PLC I still get the "PLC no response" message 
  12. CAM Control Data

    Hi everyone, I'm trying to use the cam control data by using an MR-J4-A-RJ and MR Configurator 2. When I switch the input "CAMC" to ON, I see that the output "CAMS" is switched to ON which means that the cam mode is activated. When I switch CI0 to ON to choose the Cam Data No.1 and switch ST1 to ON...nothing is happening like if there is no Cam Data. Please, have you any issue or idea ?? Thank you in advance Omar
  13. Hi,  I am writing some routines to decode the data from my Input: data array to User-defined Array Parameters. Is that possible to have a generic routine to decode data coming from more than one module? I have two Module ENode and ENode_1. I have defined User-Defined parameters for the module. Can I make a generic routine to decode the data coming from these two modules and put them in the defined arrays?  the two arrays ENodeData[0] and ENodeData[1] have the Generic User-Defined parameters.
  14. RS Logix Designer Tags

    Hi, Is that possible to define INT data type in EDS file so the Tags for the module in RS Logix Designer would receive INT data type in Input Tags not SINT? As marked in the image, the Logix Designer is receiving data as SINT but I want to have INT data type. Thanks Muhammad Azeem
  15. Hello to all, I am new here, and I have a project with FX3U plc and CR 2DA 700 robot controller. Does anyone have some experience in establishing communication over FX 3U enet module and robot controller, I need to send and receive 5- 10 M registers and D integers. Thanks
  16. Hello everybody, I have network from : PC - 192.168.3.11 PLC - 192.168.3.250 I change this option in FX5U PLC in GX Works3 for Network Ethernet port --> Application Setting -> Security -Disable Direct connect with MELSOFT : Enable/disable -DO not respond CPU module search : Respond / not respond and I upload program to PLC. After upload program to PLC and restart it was impossible to connect again. I Have ping between PLC and PC, but could't write program. Always writes me Error <ES:0180840b> So to disable Security Option you should to do : 1. Open Works3 2. New Project (Choose your PLC - FX5U) 3. Online menu 4. Specify Destination Communication 5. Click twice in PLC module 6. Set Connect via hub (In my case i connect PC and PLC directly !) 7. Choose IP Address ( in my project : 192.168.3.250 , PC must be in same network 192.168.3.X) 8. Give OK 9. Connect Test. With steps I disable security options and it was enable to connect to PLC and Write data on it. I Hope that will help to other with same problem. Special thanks to : Piotr Tynor(Mitsubishi, Poland ) , Adam Syrek (Mitsubish, Poland ) , I. Ayvazova (Bulgaria) , K. Raykov (Bulgaria)
  17. Hi All, Networking guy here, looking for network experts on a AB PLC (1756-EN3TR/B v217021900) which seems to STOP ARPing for a device after 10 ARP's. The device is purposefully powered down, but when powered up, it can take minutes before the PLC sees it again. The PLC team says only changes in the PLC's logic are made. When an older backup is restored though, I do NOT see the issue somehow. 1) The devices that are powered down are back on the network and reachable within 10 seconds or so (ping). The initial thought was that they were not even on the network, but they are. Just that PLC shows a comms loss. 2) With the 'good code', the PLC, once the device is offine, keeps sending ARPs to find the device. The first one is a directed one, the subsequent ones are broadcasts. These broadcasts keep happening till the device is back online and is able to talk to the PLC again. 1st ARP after comms is lost: 474.423859     Rockwell_cf:a7:6c     Hilscher_2e:ea:08     ARP      60     Who has 192.17.150.208? Tell 192.17.150.30 Next and subsequent ARPs after the first one: 475.423471     Rockwell_cf:a7:6c     Broadcast             ARP      60     Who has 192.17.150.208? Tell 192.17.150.30 These ARPs keep happening every 1 second, till the device is online again. 3) With the bad code, the PLC, once the device is offline, sends only 10 ARP messages total and then stops sending ARPs altogethe . Then it takes 10 minutes* before it sends another one. If the device is backup online by that time, the PLC finds it right away. SO with these 2 different code bases, how is that a low level L2 protocol like ARP is impacted so much. The PLC team tells me that they have no idea and not set anything related to it. My question is where is the ARP network behaviour governed and how to change it? How can older code which supposedly only has changes in logic have different ARP behavior? * The 10 minutes interval might lead people to think it's a ARP timer and most likely it is, but then people usually ask about gratuious ARPS (garp) and I've verified that they make it through from the device to the PLC OK. If the device is offline for say a minute, the PLC mirrored port does indeed see the garps, yet at that point the PLC is no longer ARPing and regardless of that garp, it has to sit out the time till it sends a next ARP till it connects. Thus, I suspect the coming back to life process is governed by the PLC ARPing for it, and not by the detection of a garps. Thanks everyone!  
  18. Flex i/o outputs shorting

    Hello everyone! Im hoping someone could shed some light on a issue im having. Im having issues with a 1794 ow8 output module. This module is used to control 8 hydraulic cylinders that push biomass into a burner. The overall problem is that roughly once every couple months a output will short in the on state and force a coil on, activating the vavle full time and burning out the coil. Each seperate output is fused on the module with a 2a fuse and each modules incoming power is also fused at 2a. The output that is shorted did not blow its fuse. The 'ON' light is not activated but 120v still runs through it. Since each valve has 2 coils and one is forced 'on' the main fuse will blow once the second half of the valve is activated because the valve is fighting itself. It is not just this one module, this happens on other modules that serve the same funtion as well. This is a contractor installed system but they have been no help so im left trying to figure it out. Could my seperate inputs be fused too high at 2a for this type of card. These are parker valves 120v 60hz with a max 1500psi pushing wet hog/chips. Any suggestions would be really appreciated!
  19. I have a "paddle wheel" style flow meter that I am trying to wire to my Micrologix 1400. It is a three wire device and there is a tag on it that says it can run at 6-36VDC. So, naturally, I thought to wire this to one of the HSC inputs of the Micrologix directly. I hooked the ( + ) on the meter to 24V, ( - ) on the meter to common, signal to the oscilloscope, and ground on the scope went to common. I see a small 60Hz sine wave @ like 5mv when the wheel is not turning. When the wheel is turning I get a small square wave but in the same mV range. It is not a nice smooth square wave either its all jumbled up with the 60Hz sine wave.  I hooked this thing up to a transmitter and scoped the signal and ( - ) in parallel with the wheel - I get a nice smooth square wave signal when the wheel turns. It is only at 4.5V though. My questions are? Why does't the paddle wheel give me what I am expecting directly? Also, what is the voltage range on the pulse that a micrologix will see? I am assuming that it will not count a wave with a 4.8V amplitude.... Thanks for your help in advanced! neech   
  20. Cimplicity 7,5

    Good Day There is a SCADA Cimplicity and controller Control logix 5561 AB. Communication between them is organized via Ethernet IP. It is necessary to transfer some tags from the Cimplicity to the controller Control Logix. How to do it better? Through Rslinx DDE OPC or write scripts in the Cimplicity? 
  21. 1.Can anyone say how can i communicate control logix plc with ethernet to serial converter. here i am not having any eds file.
  22. RSLINX help

    I am using rslinx in my configuration with 2 devices: windows xp computer and an SLC 5/05 CPU.  The XP PC is running a program that relies on a file that is automatically dropped in a shared folder from a separate networked PC.  The file is deleted immediately from the shared folder.  The program on the XP PC uses rslinx to control the SLC 5/05 CPU to complete the operation.  The original XP PC hard drive failed and a new PC was installed with all the necessary software and services.  Ounce I completed the  setup, the process worked for 48 hours, then stuck in one operation (one file).  Now, I can restart rslinx and the software and the process will function normally, but stall, then get stuck on one file.  There are no files in the shared folder, rslinks has not lost connection.  The original router was replaced at the same time as the PC.  I am leaning towards rslinx storing the files somewhere and stalling/stopping the operation.  I can not find files anywhere.  Does the SLC 5/05 CPU store the files?  I'm lost.  Do you have any troubleshooting suggestions?  
  23. Change Management LogIn(lost password

    I cant able to make any changes on the points (datatype from INT to DINT) on cimplicity workbench  everything thing is greyout!! i checked and found that the workbench has a change management logOn option asking to logon! Which asks for user name and password!! And No one here Now has the user name or its password!! what to do now on such cases , Also on doing modifications on logic developer validating project generates error  may be due to mismatch data type of that associated point on workbench.
  24. Is it possible to communicate from a PC program to PLC program for reading inputs and setting outputs? How can it be made ? is it possible to do from TER connector or AUX connector , without special comm module?
  25. Does anyone here use this? Control Draw If so how useful do find it? Worth spending the time on learning or better off with another product? If so what? My application is going to be for in-house management and design of control systems for a food manufacturing plant.   Thanks.