Search the Community

Showing results for tags 'communication cimplicity with control logix ab'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 147 results

  1. RS Logix Designer Tags

    Hi, Is that possible to define INT data type in EDS file so the Tags for the module in RS Logix Designer would receive INT data type in Input Tags not SINT? As marked in the image, the Logix Designer is receiving data as SINT but I want to have INT data type. Thanks Muhammad Azeem
  2. Hello to all, I am new here, and I have a project with FX3U plc and CR 2DA 700 robot controller. Does anyone have some experience in establishing communication over FX 3U enet module and robot controller, I need to send and receive 5- 10 M registers and D integers. Thanks
  3. Hello everybody, I have network from : PC - 192.168.3.11 PLC - 192.168.3.250 I change this option in FX5U PLC in GX Works3 for Network Ethernet port --> Application Setting -> Security -Disable Direct connect with MELSOFT : Enable/disable -DO not respond CPU module search : Respond / not respond and I upload program to PLC. After upload program to PLC and restart it was impossible to connect again. I Have ping between PLC and PC, but could't write program. Always writes me Error <ES:0180840b> So to disable Security Option you should to do : 1. Open Works3 2. New Project (Choose your PLC - FX5U) 3. Online menu 4. Specify Destination Communication 5. Click twice in PLC module 6. Set Connect via hub (In my case i connect PC and PLC directly !) 7. Choose IP Address ( in my project : 192.168.3.250 , PC must be in same network 192.168.3.X) 8. Give OK 9. Connect Test. With steps I disable security options and it was enable to connect to PLC and Write data on it. I Hope that will help to other with same problem. Special thanks to : Piotr Tynor(Mitsubishi, Poland ) , Adam Syrek (Mitsubish, Poland ) , I. Ayvazova (Bulgaria) , K. Raykov (Bulgaria)
  4. Hi All, Networking guy here, looking for network experts on a AB PLC (1756-EN3TR/B v217021900) which seems to STOP ARPing for a device after 10 ARP's. The device is purposefully powered down, but when powered up, it can take minutes before the PLC sees it again. The PLC team says only changes in the PLC's logic are made. When an older backup is restored though, I do NOT see the issue somehow. 1) The devices that are powered down are back on the network and reachable within 10 seconds or so (ping). The initial thought was that they were not even on the network, but they are. Just that PLC shows a comms loss. 2) With the 'good code', the PLC, once the device is offine, keeps sending ARPs to find the device. The first one is a directed one, the subsequent ones are broadcasts. These broadcasts keep happening till the device is back online and is able to talk to the PLC again. 1st ARP after comms is lost: 474.423859     Rockwell_cf:a7:6c     Hilscher_2e:ea:08     ARP      60     Who has 192.17.150.208? Tell 192.17.150.30 Next and subsequent ARPs after the first one: 475.423471     Rockwell_cf:a7:6c     Broadcast             ARP      60     Who has 192.17.150.208? Tell 192.17.150.30 These ARPs keep happening every 1 second, till the device is online again. 3) With the bad code, the PLC, once the device is offline, sends only 10 ARP messages total and then stops sending ARPs altogethe . Then it takes 10 minutes* before it sends another one. If the device is backup online by that time, the PLC finds it right away. SO with these 2 different code bases, how is that a low level L2 protocol like ARP is impacted so much. The PLC team tells me that they have no idea and not set anything related to it. My question is where is the ARP network behaviour governed and how to change it? How can older code which supposedly only has changes in logic have different ARP behavior? * The 10 minutes interval might lead people to think it's a ARP timer and most likely it is, but then people usually ask about gratuious ARPS (garp) and I've verified that they make it through from the device to the PLC OK. If the device is offline for say a minute, the PLC mirrored port does indeed see the garps, yet at that point the PLC is no longer ARPing and regardless of that garp, it has to sit out the time till it sends a next ARP till it connects. Thus, I suspect the coming back to life process is governed by the PLC ARPing for it, and not by the detection of a garps. Thanks everyone!  
  5. Flex i/o outputs shorting

    Hello everyone! Im hoping someone could shed some light on a issue im having. Im having issues with a 1794 ow8 output module. This module is used to control 8 hydraulic cylinders that push biomass into a burner. The overall problem is that roughly once every couple months a output will short in the on state and force a coil on, activating the vavle full time and burning out the coil. Each seperate output is fused on the module with a 2a fuse and each modules incoming power is also fused at 2a. The output that is shorted did not blow its fuse. The 'ON' light is not activated but 120v still runs through it. Since each valve has 2 coils and one is forced 'on' the main fuse will blow once the second half of the valve is activated because the valve is fighting itself. It is not just this one module, this happens on other modules that serve the same funtion as well. This is a contractor installed system but they have been no help so im left trying to figure it out. Could my seperate inputs be fused too high at 2a for this type of card. These are parker valves 120v 60hz with a max 1500psi pushing wet hog/chips. Any suggestions would be really appreciated!
  6. I have a "paddle wheel" style flow meter that I am trying to wire to my Micrologix 1400. It is a three wire device and there is a tag on it that says it can run at 6-36VDC. So, naturally, I thought to wire this to one of the HSC inputs of the Micrologix directly. I hooked the ( + ) on the meter to 24V, ( - ) on the meter to common, signal to the oscilloscope, and ground on the scope went to common. I see a small 60Hz sine wave @ like 5mv when the wheel is not turning. When the wheel is turning I get a small square wave but in the same mV range. It is not a nice smooth square wave either its all jumbled up with the 60Hz sine wave.  I hooked this thing up to a transmitter and scoped the signal and ( - ) in parallel with the wheel - I get a nice smooth square wave signal when the wheel turns. It is only at 4.5V though. My questions are? Why does't the paddle wheel give me what I am expecting directly? Also, what is the voltage range on the pulse that a micrologix will see? I am assuming that it will not count a wave with a 4.8V amplitude.... Thanks for your help in advanced! neech   
  7. Cimplicity 7,5

    Good Day There is a SCADA Cimplicity and controller Control logix 5561 AB. Communication between them is organized via Ethernet IP. It is necessary to transfer some tags from the Cimplicity to the controller Control Logix. How to do it better? Through Rslinx DDE OPC or write scripts in the Cimplicity? 
  8. 1.Can anyone say how can i communicate control logix plc with ethernet to serial converter. here i am not having any eds file.
  9. RSLINX help

    I am using rslinx in my configuration with 2 devices: windows xp computer and an SLC 5/05 CPU.  The XP PC is running a program that relies on a file that is automatically dropped in a shared folder from a separate networked PC.  The file is deleted immediately from the shared folder.  The program on the XP PC uses rslinx to control the SLC 5/05 CPU to complete the operation.  The original XP PC hard drive failed and a new PC was installed with all the necessary software and services.  Ounce I completed the  setup, the process worked for 48 hours, then stuck in one operation (one file).  Now, I can restart rslinx and the software and the process will function normally, but stall, then get stuck on one file.  There are no files in the shared folder, rslinks has not lost connection.  The original router was replaced at the same time as the PC.  I am leaning towards rslinx storing the files somewhere and stalling/stopping the operation.  I can not find files anywhere.  Does the SLC 5/05 CPU store the files?  I'm lost.  Do you have any troubleshooting suggestions?  
  10. Change Management LogIn(lost password

    I cant able to make any changes on the points (datatype from INT to DINT) on cimplicity workbench  everything thing is greyout!! i checked and found that the workbench has a change management logOn option asking to logon! Which asks for user name and password!! And No one here Now has the user name or its password!! what to do now on such cases , Also on doing modifications on logic developer validating project generates error  may be due to mismatch data type of that associated point on workbench.
  11. Is it possible to communicate from a PC program to PLC program for reading inputs and setting outputs? How can it be made ? is it possible to do from TER connector or AUX connector , without special comm module?
  12. Does anyone here use this? Control Draw If so how useful do find it? Worth spending the time on learning or better off with another product? If so what? My application is going to be for in-house management and design of control systems for a food manufacturing plant.   Thanks.
  13. Hello everyone, Is there any way to communicate with Mitsubishi Servo amplifier MR-J2S-350CP through RS232 ,I prefer to use 224XP because i already have it... thank you 
  14. Newbie Screwed up AB 5/04

    Greetings everyone, I am using a VERY OLD laptop, Windows 98, the correct AB cable....and only used to download programs into equipment to restore in emergencies into AB 5/04.  I was able to connect to SLC 5/04 using RSLinx (used Auto-Config, all worked correctly) , and wanted to install a program from earlier version using RSLogix500.  It seemed to download correctly, the pop-up asked if I was sure I wanted to install new program, hit YES...then said it would change channel, pop up buttons were "ALLOW" or "DENY" (something like that). I hit "ALLOW". All seemed good until I plugged HMI back in....had a bunch of codes it didn't like, so I went to install back to original version.  When I went through the same procedure (mentioned above)....5/04 and laptop no longer wanted to communicate.  I assume it has something with allowing the channel change.  As you can tell, I know Jack Squat...I'm not a programmer (duh), but was handed a computer with instructions....and now the machine is down.  Any help with getting me in right direction is highly appreciated in advance.  I searched the forum, and wasn't able to find a solution... I suppose it has to do with an in-experienced, well intending human messing with stuff he shouldn't be messing with !!
  15. FX3U PLC WITH OPTIDRIVE E3

    Hi can anyone help me to undestand more about modbus RTU between fx3u with optidrive e3 ?? I'm using rj45 with fx3u 485adp-Mb for the connection. Then specially in making the ladder program in Gx Works 2. I'm stuck understand the command code there. I'm first time using this. Please help me. Thank you.
  16. Hello   i have a versamax icu200udr064 and i want to connect it with simatic basic panel ktp 1200 dp  both support modbus rut but the problem is that i cant find GE communication driver on the tia portal by whom i program the HMI.  One more thing is that i found a communication driver for modbus rtu but the tags addresses are in the standard form for modbus, so is there any solution for this?  thanks a lot .  
  17. Hi, I'm trying to set up a TCP communication between a Q03UDECPU and a Beijer E110 panel  I've tried both TCP and UDP as "communication mode" in E-Designer. nothing seems to work.  What I'm I doing wrong Se attached files from E-designer and Gx IEC Developer
  18. Hello I downloaded a .mer file on the Panel view 1000 but it shows errors on the display graphics. i have configured the Rslinx communication several times by selecting the rigt PLC in Design and Runtime mode. I am using Facotry Talk view 8.20 and creating 5.10 runtime file. Please advice. I was able to correctly download and use the HMI on a similar machine. I dont know what am I missing on this one.    Thanks Pratik Jain
  19. I am trying to get the communication going between EZ3 EZAutomation Panel HMI and Omron NJ501-1300 PLC. I am currently using Modbus TCP/IP as a protocol. Has anybody figured out a way to do that? Or is there a better way to do this communication between HMI and PLC ? Right now I am using MTCP_Client_Connect function block to connect with HMI but it dont seem to be working. The IP address is correct along with Port no. I am still fuzzy about the Station address of NJ and the function code of the NJ for Modbus purposes. If anybody could help me out I would really appreciate it.
  20. Graphic Operational Controller

    Please give me the steps how to communicate GOC with Laptop using Ethernet and serial port I have using Codesys for Programming
  21. Hello, I am currently working on programming my first sortation system.  Attached is a blue print of the in feed conveyors and their loadout lines.  As boxes merge together they will be scanned by the barcode scanner.  From there we will be told which lane each box must go down, from the WCS.   My question is, without encoders, what would be the best way to control this system? Counting the packages as they pass through the photoeye? Or setting timers?   Thanks, James Sorting Conveyor Layout.pdf
  22. On-Off Temperature control

    Hi, i'm actually working on a project with a CPU33 CJ2M and a external analog output CJ1W-AD04U I'm trying to read the informations coming from a PT100 sensor and control a valve which act on the temperature. i'm kind of lost in this project because it's my "first time" with Omron ! Which function block must i use or how must i program this would you show me example ?  Thank you for the help guys.
  23. Hello everyone, I have difficulty to setting up the GSM configuration or the serial RTU configuration so that I allow you with another RTU. I use Schneider CPU Modicon M340 in conjunction with RTU communication NOR0200H and a Modem Schneider SR02 MOD02. This is the first time I'm working on this kind of project, want to help me, I'm stuck and I need a solution, thank you for your time.  
  24. Hi guys. I have 1 cj2m cpu33 reciving 3bits of info from 3 other plcs (all similar type cj2m cpu 34-33) The problem is that 2 bits are ariving the third one is not. See the pictures i uploaded:   I do not know these instructions, in the other cases it was working. However i noticed that the output plc had a different adress with D950. I changed the adress to D804 as you can see on the pictures but still not reciving the data.  I guess i will have to configure somwhere else also. All i found (https://www.myomron.com/index.php?action=kb&article=1416) on internet that i have to open this datalink tool from the integrator. When i actually do that of course i just get an error: FATAL Error. Cannot read the file.   How can i make this work? Is the other way to constantly send this one bit with ethernet? Any sollutions, advices are welcome!
  25. CJ2M-CPU32 and CJ1W-TC002 help

    Hi everyone. l have a project with omron plc but l dont know omron. l have CJ2M-CPU32 and CJ1W-TC002 also input and output units. do you have a example temperature control programme for this device ?