Search the Community

Showing results for tags 'communication'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 80 results

  1. Cimplicity 7,5

    Good Day There is a SCADA Cimplicity and controller Control logix 5561 AB. Communication between them is organized via Ethernet IP. It is necessary to transfer some tags from the Cimplicity to the controller Control Logix. How to do it better? Through Rslinx DDE OPC or write scripts in the Cimplicity? 
  2. RSLINX help

    I am using rslinx in my configuration with 2 devices: windows xp computer and an SLC 5/05 CPU.  The XP PC is running a program that relies on a file that is automatically dropped in a shared folder from a separate networked PC.  The file is deleted immediately from the shared folder.  The program on the XP PC uses rslinx to control the SLC 5/05 CPU to complete the operation.  The original XP PC hard drive failed and a new PC was installed with all the necessary software and services.  Ounce I completed the  setup, the process worked for 48 hours, then stuck in one operation (one file).  Now, I can restart rslinx and the software and the process will function normally, but stall, then get stuck on one file.  There are no files in the shared folder, rslinks has not lost connection.  The original router was replaced at the same time as the PC.  I am leaning towards rslinx storing the files somewhere and stalling/stopping the operation.  I can not find files anywhere.  Does the SLC 5/05 CPU store the files?  I'm lost.  Do you have any troubleshooting suggestions?  
  3. Is it possible to communicate from a PC program to PLC program for reading inputs and setting outputs? How can it be made ? is it possible to do from TER connector or AUX connector , without special comm module?
  4. Hello everyone, Is there any way to communicate with Mitsubishi Servo amplifier MR-J2S-350CP through RS232 ,I prefer to use 224XP because i already have it... thank you 
  5. Newbie Screwed up AB 5/04

    Greetings everyone, I am using a VERY OLD laptop, Windows 98, the correct AB cable....and only used to download programs into equipment to restore in emergencies into AB 5/04.  I was able to connect to SLC 5/04 using RSLinx (used Auto-Config, all worked correctly) , and wanted to install a program from earlier version using RSLogix500.  It seemed to download correctly, the pop-up asked if I was sure I wanted to install new program, hit YES...then said it would change channel, pop up buttons were "ALLOW" or "DENY" (something like that). I hit "ALLOW". All seemed good until I plugged HMI back in....had a bunch of codes it didn't like, so I went to install back to original version.  When I went through the same procedure (mentioned above)....5/04 and laptop no longer wanted to communicate.  I assume it has something with allowing the channel change.  As you can tell, I know Jack Squat...I'm not a programmer (duh), but was handed a computer with instructions....and now the machine is down.  Any help with getting me in right direction is highly appreciated in advance.  I searched the forum, and wasn't able to find a solution... I suppose it has to do with an in-experienced, well intending human messing with stuff he shouldn't be messing with !!
  6. FX3U PLC WITH OPTIDRIVE E3

    Hi can anyone help me to undestand more about modbus RTU between fx3u with optidrive e3 ?? I'm using rj45 with fx3u 485adp-Mb for the connection. Then specially in making the ladder program in Gx Works 2. I'm stuck understand the command code there. I'm first time using this. Please help me. Thank you.
  7. Hello   i have a versamax icu200udr064 and i want to connect it with simatic basic panel ktp 1200 dp  both support modbus rut but the problem is that i cant find GE communication driver on the tia portal by whom i program the HMI.  One more thing is that i found a communication driver for modbus rtu but the tags addresses are in the standard form for modbus, so is there any solution for this?  thanks a lot .  
  8. Hi, I'm trying to set up a TCP communication between a Q03UDECPU and a Beijer E110 panel  I've tried both TCP and UDP as "communication mode" in E-Designer. nothing seems to work.  What I'm I doing wrong Se attached files from E-designer and Gx IEC Developer
  9. Hello I downloaded a .mer file on the Panel view 1000 but it shows errors on the display graphics. i have configured the Rslinx communication several times by selecting the rigt PLC in Design and Runtime mode. I am using Facotry Talk view 8.20 and creating 5.10 runtime file. Please advice. I was able to correctly download and use the HMI on a similar machine. I dont know what am I missing on this one.    Thanks Pratik Jain
  10. I am trying to get the communication going between EZ3 EZAutomation Panel HMI and Omron NJ501-1300 PLC. I am currently using Modbus TCP/IP as a protocol. Has anybody figured out a way to do that? Or is there a better way to do this communication between HMI and PLC ? Right now I am using MTCP_Client_Connect function block to connect with HMI but it dont seem to be working. The IP address is correct along with Port no. I am still fuzzy about the Station address of NJ and the function code of the NJ for Modbus purposes. If anybody could help me out I would really appreciate it.
  11. Graphic Operational Controller

    Please give me the steps how to communicate GOC with Laptop using Ethernet and serial port I have using Codesys for Programming
  12. Hello everyone, I have difficulty to setting up the GSM configuration or the serial RTU configuration so that I allow you with another RTU. I use Schneider CPU Modicon M340 in conjunction with RTU communication NOR0200H and a Modem Schneider SR02 MOD02. This is the first time I'm working on this kind of project, want to help me, I'm stuck and I need a solution, thank you for your time.  
  13. Hi guys. I have 1 cj2m cpu33 reciving 3bits of info from 3 other plcs (all similar type cj2m cpu 34-33) The problem is that 2 bits are ariving the third one is not. See the pictures i uploaded:   I do not know these instructions, in the other cases it was working. However i noticed that the output plc had a different adress with D950. I changed the adress to D804 as you can see on the pictures but still not reciving the data.  I guess i will have to configure somwhere else also. All i found (https://www.myomron.com/index.php?action=kb&article=1416) on internet that i have to open this datalink tool from the integrator. When i actually do that of course i just get an error: FATAL Error. Cannot read the file.   How can i make this work? Is the other way to constantly send this one bit with ethernet? Any sollutions, advices are welcome!
  14. S7-1500 FW v 2 / Profinet issues non-Siemens devices

    Hello: Has any body encountered Profinet IO cyclic communication establishment problems between the latest S7-1500 PLC with firmware 2.0 or later and non-Siemens Profinet devices which had previously passed conformance testing campaigns? Thanks for your comments.    
  15. Has anybody tried communicating Allen Bradley 5069 Compact logix PLC with Red Lion HMI ?  I am unable to communicate them in spite of adding AB tags via L5K file which gives me no error. I am able to see all the tags in Crimsion 3.0 software in development mode.  However, PLC & HMI are not communicating with each other. I am able to ping to both, using the same program in PLC of which I generated L5K file.  I think it may have something to do with the driver as 5069 is a new line of PLC Rockwell come out with only in 2016.   
  16. Socket communication with Micro820

    Hi everyone ! I have a little project wich involves communication between two Micro820 controllers via TCP/IP. To do that, I started to work with TCP/IP socket. Within CCW (Connected Components Workbench), I tried to create a new socket instance using the instruction SOCKET_CREATE and set the socket address to 127.0.0.1:21. Basically, my computer through the FTP port. The problem was that it couldn't create a new socket instance (error variable is set to TRUE and status is set to 4, wich I don't know the meaning) because I didn't have a server-side application that listens to TCP/IP socket requests. That said, I found an open source application called SocketTest that listens for TCP/IP socket requests on a specified IP address and port. So, I started a listener on the following address : 127.0.0.1:21, but the error variable is still set to TRUE and status is still set to 4. So, my questions are : Is my IP address OK ? Is my port number OK ? What means the status code 4 ? Is SocketTest doing what I think it does ? Do I need to do something else before using the SOCKET_CREATE instruction ? Thank you in advance for your help !
  17. Serial communication of Micro830

    hello everyone, I'm trying to connect PC with Micro830 with RS232 cable for transfer serial data. However, the PLC can not receive the character from PC. I used ARD function block to read the characters from PC.  there is no error and the output of ARD function block is 0 when I debug ladder programme. the serial communication state LED illuminated once I send a character from PC to PLC. the channel of input is 2 which is the embedded serial port. I use an adapter from USB to RS232. Email: jeremietang531@gmail.com      
  18. Good day  I require some assistance with the configuration setup (GX Works 3) for FX5u PLC inter-communication (PLC to PLC), over Ethernet (using the built-in Ethernet port). The purpose of the inter-connection is data exchange. (Values stored within the PLC storage registers such as words and bits).  Does anyone perhaps support files on this such as a procedure or example? Thanks
  19. Hello,    I have a Cognex insight 5100 camera connected to Allen Bradley L62 processor. The is working fine since the last year but sometimes the I/O module faults out with error code 16#0022. I looked online it look it needed a Ethernet cable change ( I did that but no results).  Then I looked at the firmware in the I/O module and firmware in the camera and I found a difference. The firmware in the camera is 4.06 and the firmware of I/O module in the PLC is 4.005. Can anyone help me resolve the communication issue ? I want to know how to downgrade the camera firmware or change the revision in the PLC ( which I cannot )    Thanks in Advance 
  20. Hello,    I have a Cognex insight 5100 camera connected to Allen Bradley L62 processor. The is working fine since the last year but sometimes the I/O module faults out with error code 16#0022. I looked online it look it needed a Ethernet cable change ( I did that but no results).  Then I looked at the firmware in the I/O module and firmware in the camera and I found a difference. The firmware in the camera is 4.06 and the firmware of I/O module in the PLC is 4.005. Can anyone help me resolve the communication issue ? I want to know how to downgrade the camera firmware or change the revision in the PLC ( which I cannot )    Thanks in Advance 
  21. Good afternoon fellow members,I once again ask for your help to know if any of you have struggled with similar issues. For the past year and a half, Every 1-2 months we seem to be losing communication with one of our PLC's/racks. We have in the rack a 1756-EN2T card (revision 3.006) that will flash as if it is communicating and status OK (green LED), yet we will be unable to ping it and our operator interfaces go into error. We could also not open the web browser page of the EN2T card, nor connect to the PLC/rack through RSLogix5000. As this happened over the weekend, the local electrician was called and he tried cycling power to the rack and there was no change after it came back on (not sure how long he left power off to the rack though). The problem seemed to be fixed after we told him to pull the EN2T card out of its slot and then re-insert it.We verified the CIP cinnections for this card and it is around 98 to 101 CIP connections out of a max of 248, so not too high. the card's CPU usage is 24-29%, so no indication of problems there. EN2T Card is set to auto-negociate, just like all the other cards we use at all of our plants. Has anyone ever experienced a similar problem?Thank you in advance for all your help and knowledge-sharing!
  22. Hi, I have the following configuration where 4 PLC panels, with each having a Q12PH CPU and QJ71E71-100 module. All these QJ71E71-100 are connected to a HUB using straight cable. From the HUB one connection is going to an I-Fix SCADA which is already communicating with all 4 PLCs using MC protocol. I want to send data from 3 of this PLCs to the 4th PLC in the same network using fixed buffer communication. Can anyone provide a sample program for the same. Send and Receive side. I am using GX Works 2 for programming. Your help is very much appreciated.
  23. CP1E-N30DT with Hyperterminal PC

    Dear Expert, i'm issue to do communication CP1E with PC via RS232. im try to use plc for sending information and receive by hyperterminal pc. after googling some information there have multiway to success. by the way until now cannot settle. please expert share completed setup that's work: 1. communication cable from PLC - PC (my information use pin (2,3,9 jumper 4&5) - (2,3,5 jumper 7&8) 2. sample program that works (im using TXD & RXD with memory D1000 to keep data) 3. connection cable to PC using MOXA Serial to USB converter. 4. plc serial setting (default: 9600,7,N,1,Host link) my target to give instruction to printer to start print. printer need ACSII code. if this communication success i'm will convert all data to ACSII by ACSII convert function.   thanks,
  24. delta hmi communication speed

    Hello, i have DOP-07s411 delta hmi and i want to interface it with microcontroller using modbus (RTU) protocol over RS485( 8 bit data,1 stop bit, parity none,19200 baud rate). i have good speed of communication if i do not use macros. But as i place background macro(background macro is only 4 lines ) it slow down and  updates the display at every 3 seconds. i cant able to figure out what is the problem. I want to update display of  HMI very fast.Please help me to troubleshoot the problem.
  25. Hi,  I'm trying to test the serial communications with my Micro820. I acquired a 2080-SERIALISOL so I could have "someone" to talk to. I want to use RS485, so I figured that I'd have to connect: Modbus pin 1 (D+) to serialisol pin A1 (+485) Modbus pin 2 (D-) to serialisol pin B4 (-485) Modbus pin 3 (GND) to serialisol pin A2 (GND) Now when it comes to CCW, the thing gets a little harder. I know I need to use the MSG_MODBUS block (in fact I need 2, one for the modbus and another one for the serialisol), and I guess I specify the interface I'm using on the TargetCfg field (data type MODBUSTARPARA). But how do I figure out that the Addr (UDINT) and Node (USINT) values are for my Modbus and Serialisol? Or am I doing it wrong? Does anybody know of any place where I can get some more guidance or even a funcional ladder program? Thank you in advance