Search the Community

Showing results for tags 'Studio 5000'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 109 results

  1. Hi, Now I am using Sysmac Studio - NA HMI. I am facing the problem of Data edit tool here I am unable to give Indirect address. Like this address HM15_Recipe_hmi(Index_No).SetPoint_1 But If I give direct Address its working HM15_Recipe_hmi(8).SetPoint_1   I Hope someone give the solution.    
  2. Hello everyone, Working in Automation for the first time as a Co-op student so i'm fairly new to PLC's and the Automation field in general. I've recently been tasked with converting a RSlogix 5 program from an old PLC 5 project into a Studio5000 project. I referenced the manual (I'll attach link below), and had no issues using the RSlogix Project Migrator tool that I downloaded off the Rockwell website. My problem is that once I convert the program, my I/O tags that were originally sequenced in octets(0-7, 10-17, 20-27, ...) from the RSlogix 5 program, are switched into a sequential scheme in Studio5000 that just increments them in order (1, 2, 3, 4, ...). I hope this make sense, but basically the first seven tags match between the projects, but then I:010 in rslogix 5 is equivalent to I[8] in 5000, I:011 is I[9], and so on and so forth. Has anyone had this issue before and found a way to have Studio5000 keep the original octet scheme? I don't see this normally being an issue, but the customer has specifically asked that the I/O tag names be kept the same as the original program. Thanks for any help. - Ben   Converting PLC-5 reference manual link: https://literature.rockwellautomation.com/idc/groups/literature/documents/rm/1756-rm085_-en-p.pdf
  3. I have a new PC that is running Windows 10, I have RSLogix 500 loaded and working no problem, along with RSLinx, Factory Talk Activation... etc. I also loaded the Studio 5000 package and it loaded without a problem however will not run. It starts and allows you to pick a project to work on, then will display the Logix 5000 splash window for a second, then just close. No error message, crash or idea of what it is doing, just closes. So far no help from AB, perhaps someone here is running this on Windows 10 or has an idea how to figure out why it is closing. Thanks
  4. RFID + Proface

    Hi Guys! Is there anybody worked already with Proface panel and RFID reader ? Can anybody help me with that ? Even it is possible to use RFID reader on a Proface touch panel ?  The software what I use is RSlogix 5000 and of course, GP-PRO for the proface panel. Thank you so much for your answers.
  5. pid tuning

    Hi there! I have a problem with a process. The bottom line is I have a quite big asynchronous motor (about 110kw), with this motor I would like to fill a pool. There is a sensor that monitors the level. Im setting the PID for the motor control, it seems to be good, but unfortunately the fultuation is very big, however the level is perfect. I send a 4-20 mA signal to the inverter. Actually, it is almost everytime changing. I think it is not good for the motor. the changing scale is between 100 and 600 rpm ... What do you guys think ? Can this cause early motor or inverter failure? I had a thought, I did that I was doing an average and sent the current process data every 3 seconds. It causes that, the motor rpm 100 or 600 rpm.. nothing else, and change it about every 3 or 6 seconds,  because of te too much error I think.  How can I solve the this problem. The material runs out evenly from the pool, but the control variable is still bouncing. I monitored the process variable and the control variable too and the error too. I noticed that the output only changes when it is very close to the setpoint. for example the setpoint is 5000. And if the process variable is 4950 then the output is 100%. and if the process variable is 4992 then the output is about 67% but, the if the process data is 5010 then the output is 0%.   I'd expect that, for example that if the process variable is 2000 then the output is will be 100%. but the process data is 4000 then the output will be 50 % ... and so on.... so I hope I can find a permanent output value.  I dont know, maybe I made some mistake.... pls help me in this situation. Thank you.        
  6. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  7. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  8. FFL problem

    Hi Guys! I have a problem.  I have a leaser sensor, I already set the sampling frequency to 0,1 s. So 1 second I will get 10 data. I need to use the average of the datas. My problem is I dont know how can I solve that, after the 10. data every new data I have to  recount, the last 10 data's average. I think maybe I have to use the FFL instrucion or something like that. I need to solve this problem in ladder diagram. I use RS-logix 5000 software. Anyone can help me?  Unfortunatelly I havent the the software, so I cant show you what am I think.    Maybe the sliding window solution is the right, or is it not related to this? Im a bit confused.
  9. Hey, I am fairly new to the NA screen so I didn't get time to research much but for some bizarre reason, if my alarm message is long instead of going to the next line it just continues. Is there a specific way of creating a multiline alarm. Any suggestion or if you have inside for a crash course on NA screen would be helpful. Thanks
  10. RSlogix 5000 service edition

    We just downloaded and are using RSlogix 5000 service edition on one of our lines. This is a software that allows you to see the PLC program, but not make changes. It is great for our Maintenance guys, but one of my managers is worried that they will change what IP they are looking at and end up setting someone else up for failure later on. Is there a way to lock RSlogix on a PC to a specific PLC IP so there is no chance of them looking at Machine A's programming from machine B?
  11. Hello:   I need to link  a lot of variables, pointing to CIO address, like "AT" field, but is a large volume of tags to create, so, I have a chance to assign a memory location to a variable in ST like:  my_tag := %100;  (trying to assign tag address to CIO 100) ? If not, there is a method to import tags from a Excel ?   Thanks.    
  12. Hello:   Im new on this foroum, and Im glad to become a member, and new on the Sysmac studio too . I have the following ST program line: My_array[0]:= y[0];   Where My_array, is a array of bool, and y array too. After load and all, on monitoring return a "!" Sign, and trying to change value retuns "Failed to write variable, check if variable or memory area are alloed to write". I tried to move both arrays from global to local, and change adressing in "AT" field, witout changes. Any help will be wellcome. Thanks in advance Dante  
  13. C-mode hostlink library for NJ/NX1P or CP1L

    Anyone knows if there is a C-mode hostlink library for NJ/NX ? Also, a C-mode hostlink library for CP1L could be helpful, to translate such a library to work with NX1P is probaly less work whan writing a new library.  Maybe Omron France has developed such a library? - they seem very active..   Background: Looking into writing a programmatic c-mode hostlink master for NX1P12, this is for connecting the handheld NSH5 HMI to the NX1P12 via RS232C using a CIF01. I have the hardware set up, and an machine built, expected some compatibility efforts by Omron.... but the NSH5 seems to talk C-mode hostlink, and the CIF01 only seems to support the FINS version hostlink.   On the NJ you can of course add an SCU module, thus not need a library.  But working with NX1 ( due to limited space available ), you are dependet on available CIF-modules which do not support C-mode hostlink.  
  14. How to watch the value in decimal directly in the ladder page ?  Default Hexadecimal The only way I can do it is in Watch Tab and I/O map per example Thank you
  15. i am new in indusoft web studio. i am facing a problem about communication of indusoft with plc.   i am communicating with plc through fx2n-422-bd card.   can some one guide me the steps of communication.  he/she will be a life saver.. as i am  in a deep trouble
  16. Hi. I am new to Allen Bradley PLCs and bumped into the following issue, that I cannot find any solution to. When trying to add a module to the I/O configuration I get the attached error, error code 80131940. This prevents me from adding any hardware configurations in Logix Designer. I have tried to reinstall Logix Designer and uninstall all AOPs. I am running V30.00.00 on a Windows 7 Enterprise SP1 OS. Your feedback is very much appreciated.
  17. Hi, is it possible to communicate between the Sysmac studio simulator and the CX-Programmer simulator? I want to test the exchange of data between a NX1P2 and a CJ2H, but I don't have the controllers with me. Thanks and have a great day!
  18. Hi guys, I have a desktop with rs logix5000 activated with dongle and i want to activate rs logix 5000 on a laptop.Those 2 PC doesn't have internet.So I copy in the laptop license files of the dongle in the activation file , I see the available activations in FTA, but the activation in RS doesn't work even if I refresh the server...thx for ur help ! ;)
  19. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  20. Multiple branch

    Hi Guys! You can read my problem below, if anybody can help, please do it. Thank you. So, I have 4 knife. You can set the cutting width for each knife separately. The problem is, there is a lot of size. There is an example: No1 size:  #1: 20 mm, #2: 25mm, #3: 30mm, #4: 25mm   (#1=Knife1.......)                                       No2 size: #1: 22mm, #2:24mm, #3: 32mm, #4: 27mm What is make the problem more difficult is There are plenty of type code too. Like X1, X2, X3, Y1, Y2, Y3 ..... This is the main material code. and you can choose the belogging size. So you can select for X1 to No1 or No2 ... but you can select for X2 to No1 or No2 or any sizegroup you want. I can solve it with a lot programming, like deal every possible situation ... but there is a lot time .... :S  There is a touch panel where you can set the values.  Anybody have another idea for this problem ?    
  21. Torque Control

    Hi, For my system I use the functions Mc_MoveAbsolte and Mc_TorqueControl. my problem is when i use absolute function after torque control for zero point. the servo turns the torque point control. For example: Target 1: 200 mm target 2: 150 mm Target 3: 240 mm ( Start point of torque) Taget 4: 330  mm (end of process) Target 5: 0 mm After "end of process" the servo turns  to "start point of torque" Can you help me please    
  22. Problem with array

    Hi Guys! I have a problem with data collection. I use RS Logix 5000 software. I need to collect 11 int value. The sampling frequency is about 2 or 3 second. I tried to make an array but I faild, because I dont find what is correct for my task. I need about 5000 sample each of int value. Anybody have any idea about this problem ? If I have the datas then I have to exporting to an excel table . Thank you if anyone can help me.   T
  23. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  24. Hi all, I uploaded SW from working PLC NJ301 1100 v 1.9. Uploading worked, but when I tried to open program, all rungs were empty (see picture). Does anyone know the cause?
  25. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty