Search the Community

Showing results for tags 'SYSMAC STUDIO'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 76 results

  1. Hi, is it possible to communicate between the Sysmac studio simulator and the CX-Programmer simulator? I want to test the exchange of data between a NX1P2 and a CJ2H, but I don't have the controllers with me. Thanks and have a great day!
  2. Torque Control

    Hi, For my system I use the functions Mc_MoveAbsolte and Mc_TorqueControl. my problem is when i use absolute function after torque control for zero point. the servo turns the torque point control. For example: Target 1: 200 mm target 2: 150 mm Target 3: 240 mm ( Start point of torque) Taget 4: 330  mm (end of process) Target 5: 0 mm After "end of process" the servo turns  to "start point of torque" Can you help me please    
  3. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  4. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  5. Hi all, I uploaded SW from working PLC NJ301 1100 v 1.9. Uploading worked, but when I tried to open program, all rungs were empty (see picture). Does anyone know the cause?
  6. The hyphens (dashes) in Sysmac Studio have been replaced by ASCII "boxes."  Anyone having this problem?  See attached screenshot. Sysmac Studio 1.220.80, Windows 7
  7. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  8. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  9. Any new tags I add in studio 5000 the HMI project shortcut cannot locate the tags, it says unresolved route to processor. It's the same shortcut all of the other tags are using. Please help. 
  10. This is my first time to the forum and I am still very new to plc programming. I just had to move all of our software over to a new computer ( kind of new) it's running windows 7 pro. The same is as the computer before. Same computer name, same I'm, same file directory. However when I add tags in studio 5000 and reference them in the HMI, it says it is unresolved in route to the processor. It only does this for the new tags. I used the same shortcut and everything so I am at a complete loss here. What do I do.
  11. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.
  12. OS: Windows 7 Ultimate 64-bit running on VMware virtual machine. Installed software: Studio 5000 V21.0 Licence: Concurrent (served by licence server on another PC). On starting Setup.exe from the VM's desktop I get the message     "Studio 5000 does not support this version of windows" Any ideas how to proceed?
  13. Remote I/O weidmuller

    Hello,  I am trying to connect a Weidmüller UR20 Ethernet I/P  (Hardware version 1) to a Omron NX1P2 PLC via Sysmac Studio. I have imported the Weidmüller EDS file into Sysmac studio and connected two tags to the target variable 101 and 102 (I also tried using a array of bytes and a single word).   When I transfer this configuration to the controller and set the controller in run i get the following error: Tag Data Link Connection Failed (0x84070000). I have tried to update the firmware of the Weidmüller I/O but this doesn't seem to help. Also the web interface shows no connection with the PLC. I also tried to setup the connection with the CX network configurator but this gave the same result. Is there someone who can help me with this problem Thanks in advance.
  14. Hi guys, I am trying to open an application and i keep getting this error. Failed to initialize the service: {3F883B87-2208-11D4-B0E7-001083022E04} Does anyone know how to get rid of this error? Regards,
  15. Hello,   I want to do a small scada for Allen bradley plc  on C#. I did a hmi/scada for Siemens S7-1500 plc on C#, it is working and free. I dont want to use Advanced  Hmi. it is looking free but I can not use it in industries as free. so I decided to use direct C#. Do anybody has sample program, code, document, library, link, etc.. about C# and Rockwell plc communication? second solution and question, if anybody has no solution; I may solve it with modbus TCP. but I dont know Compact logix L27ERM CPU support direct modbus tcp protocol. if anybody has knowledge about the modbus tcp protocol document, sample program etc.. I can try to communicate with modbus tcp C# and Allen Bradley.   Thank you in advance. 
  16. Is there any way to establish a variable as min/max value of a gauge on sysmac studio?
  17. I am using an Omron NJ controller and a Cognex Dataman 260 bar-code scanner.   At this point I can trigger the scanner and receive data from the scanner via ethernet/ip. My issue is in converting the response from the scanner to something human readable. The bar-code I scanned reads "872-3GSq".  The results of the scan are located in the variable Dataman_to_NJ[8]-[11]. At some point I know I need to use the SWAP function but I believe my lack of data type knowledge in this system is hindering me. How can I convert the value in Dataman_to_NJ[8] to the string "87"? Any assistance would be appreciated.  
  18. Hello everyone, I am working with a NB10W HMI connected to a PLC NJ by Ethernet protocol, I would like to know where to start regarding the sending of data from the PLC to the HMI. I have a 50x15 array and should show all those values in the HMI for read / write. How to proceed? I started working with PLC for a while. I'm using Sysmac Studio to programm the PLC and NB designer to the HMI.
  19. HMI VIEWER APP

    Hi recently I have seen Omron Europe and I have download an app for Android and iOS, that app can allow you to remote view HMI types NB,NS and NA9last from Omron). The reason of all of this, is if some body have try this app and also if communication and remote view was creat it. I have try all my best but still can't make it, if some body did it, could you please share it?. Thanks, Jose
  20. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  21. Hello, Does anyone have experience with getting online a NJ/NX via USB with Sysmac Studio running on windows 10? At Omrons website it says Sysmac Studio offers windows 10 support from version 1.15 but I can't find drivers anywhere. Have checked in the communication middleware folder as you can see in the attached picture.  https://www.myomron.com/index.php?action=kb&article=1580 I have Sysmac Studio 1.20.1.0 running on Windows 10 Professional. Its not a big problem for me right now, because I can always connect via Ethernet, but if the driver exist I would appreciate having it.  
  22. Hey, this is probably a stupid question, but how do I delete old FactoryTalk View Programs. They are the ones that I have uploaded from a PanelView Plus via the "Transfer Utility" and then restored runtime using the "Application Manager". I open up FactoryTalk View Studio and I can see a list of all the runtime applications or I can create a new one. My question is, where are these applications stored by default? I have a bunch of old ones and test programs that I want to delete that are just cluttering up my list. I attached a screenshot to show you exactly what I'm talking about. Thanks, I'm sure this is a pretty easy/ dumb question. Howard
  23. Hi,  I am writing some routines to decode the data from my Input: data array to User-defined Array Parameters. Is that possible to have a generic routine to decode data coming from more than one module? I have two Module ENode and ENode_1. I have defined User-Defined parameters for the module. Can I make a generic routine to decode the data coming from these two modules and put them in the defined arrays?  the two arrays ENodeData[0] and ENodeData[1] have the Generic User-Defined parameters.
  24. Enumerations in Recipes

    Hello,   Is there a way to limit the input of an ingredient value, possibly by use of an Enum?  For example, I have an ingredient called Press_Speed. I want the values to be either Normal, Slow_1x, Slow_2x, or Slow_3x. On the PLC these values are interpreted as numbers. Can I limit the input to the String representation of the Enum?   I'm using the NA series HMI with Sysmac Studio. 
  25. Hello everybody, i'm using sysmac studio and i'm new with the program. I want to use the ladder tools to describe the influence of the valves on the temperature and the flow. Can somebody help me how to do this? and where to start? The requirements of the project are: Valve TCV 35.01 is a temperature valve: u can control the outlet temperature of the water flow. 100% = 2 degrees celcius and 0% = 20 degrees celcius. Valve LCV 35.01 is a level valve: u can control the outlet water flow. 100% = 50litres/hour and 0%=0litres/hour. In the appendix u can see a view of the proces.