joseph_cs

MrPLC Member
  • Content count

    5
  • Joined

  • Last visited

Everything posted by joseph_cs

  1. QJ71C24N-R4: G.INPUT and G.OUTPUT

    Currently working with a Q02HCPU where I have installed a serial module QJ71C24N-R4 in effort to read display temperature data from a device via RS485. The device request an ASCII command with CR (no line feed) where the command is "01ms." which is "30 31 6d 73 0D" in HEX.  To begin, I used G.OUTPUT to transmit the request of "01ms." in ASCII from Channel 1. My ladder then follows it with a G.INPUT instruction. My start I/O is 240 and I have configured all data format (8 data bit, even parity, 1 stop bit, non-procedural protocol) using Intelligent Function Module - Switch Settings. Lastly, I wrote all parameters and ladder to PLC and rebooted power as instructed by Mitsubishi. After turning everything back on, I am receiving Parity and Framing errors.  I have attached several pictures of the Circuit Trace to show send/receive packets as well as the switch settings. Has anyone seen this before? If so, what could be causing a framing / parity error even after having correct switch settings?   Thank you
  2. QJ71C24N-R4: G.INPUT and G.OUTPUT

    @Wasan @Asaddoris The external device is a pyrometer with "UPP" (universal pyrometer protocol) all it needs is to see a ASCII request with the proper command ("01ms+CR") and it will respond with the reading temperature. I have confirmed this using a hyper terminal.  I am using Non-procedural protocol and G.OUTPUT/INPUT instructions to transmit the request and read the incoming data. The problem is that I am not seeing anything come in, it is not reading. The PLC is currently spitting out framing and parity errors, which is odd because I have written all switch settings in respect to the data format of the pyrometer (external device). 
  3. QJ71C24N-R4: G.INPUT and G.OUTPUT

    I am currently not receiving any data at all. After reading more of the manual, it seems to me like I shall be using Pre-defined Protocol instead of Non-Procedural since I am communicating with an external device. Since I am not using Channel 2 at all I did not touch any echo back functions.  In addition, using a hyper-terminal I confirmed the transmission G.OUTPUT instruction to be executing the necessary command. The problem is that I am not reading any temperature data at all. Has anyone monitored data using G.CPRTCL instruction instead using INPUT/OUTPUT?
  4. QJ71C24N-R4: G.INPUT and G.OUTPUT

    @Wasan Is that necessary even if only using Channel 1? Channel 2 is not being touched.