grvchy

MrPLC Member
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About grvchy

  • Rank
    Hi, I am New!

Profile Information

  • Country Germany

Recent Profile Visitors

108 profile views
  1. Hello All I am new to Mitsibishi servodrive, i am using a Beckhoff PLC TwinCAT3  and MR-J4-TM servo drive from mitsubishi , i connected the servo to the NTwinCAT using etherCAT. I was able to write a program where i was able to activate the servo from the TwinCAT using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here .. datei_Mr-J4-TM_TwinCat_EtherCAT.pdf
  2. Hello  I am currently trying for testing purposes an Mitsubishi Servo Amplifier M4-J4-TM, which has a Servo motor (also from Mitsubishi) controls to integrate in Beckhoff's TwinCat 3. The controller is directly connected to the computer via EtherCat and is also communication between TwinCat and EtherCAT device is detected. But when I switch to online mode and try to control the engine manually, it always comes the following error message:  Error 51 'TCNC' (500): 'Axis 1' (axis ID: 1): The axis or the drive is not ready for positioning (error code: 0x4225)!  Somehow I miss a step to the valid activation of the engine. ?? In the documentation of Beckhoff and Mitsubishi there is no indication. Actually that should work like that. Has anyone ever had a similar problem and knows about advice? Thanks in advance in advance and many greetings
  3. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please
  4. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please